aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-Geometry-Planar/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-21 23:25:32 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-21 23:25:32 +0000
commitae159b0c6e4539a9cafcbde606bd6c501996413f (patch)
tree7b1b813fa428f3b88f95e40fd2c68647630271c2 /math/p5-Math-Geometry-Planar/Makefile
parentadbe1274286e882a9cd579c0e5831308436744c9 (diff)
downloadports-ae159b0c6e4539a9cafcbde606bd6c501996413f.tar.gz
ports-ae159b0c6e4539a9cafcbde606bd6c501996413f.zip
Adding port math/p5-Math-Geometry-Planar, a collection of planar geometry functions.
Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=163036
Diffstat (limited to 'math/p5-Math-Geometry-Planar/Makefile')
-rw-r--r--math/p5-Math-Geometry-Planar/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/math/p5-Math-Geometry-Planar/Makefile b/math/p5-Math-Geometry-Planar/Makefile
new file mode 100644
index 000000000000..db11b38e03ed
--- /dev/null
+++ b/math/p5-Math-Geometry-Planar/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Math-Geometry-Planar
+# Date created: 21 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Geometry-Planar
+PORTVERSION= 1.16
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= A collection of planar geometry functions
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Math/Geometry/Planar/GPC.pm:${PORTSDIR}/math/p5-Math-Geometry-Planar-GPC \
+ ${SITE_PERL}/Math/Geometry/Planar/Offset.pm:${PORTSDIR}/math/p5-Math-Geometry-Planar-Offset
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Math::Geometry::Planar.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>