aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-Intersection-StraightLine
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-02-18 08:20:27 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-02-18 08:20:27 +0000
commit02ddb4a65ecd5c2ffd6fad65d49db859810da300 (patch)
tree0e3709513dfc89fd5d25fa918e93179c2b0a0cd2 /math/p5-Math-Intersection-StraightLine
parentaa528ac5b70bd9a8fd7ce24d7c3dd16976943408 (diff)
downloadports-02ddb4a65ecd5c2ffd6fad65d49db859810da300.tar.gz
ports-02ddb4a65ecd5c2ffd6fad65d49db859810da300.zip
Adding port math/p5-Math-Intersection-StraightLine, calculates the intersection point of straight lines as defined by either function, vector, or points.
Submitted by: aaron Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=156258
Diffstat (limited to 'math/p5-Math-Intersection-StraightLine')
-rw-r--r--math/p5-Math-Intersection-StraightLine/Makefile28
-rw-r--r--math/p5-Math-Intersection-StraightLine/distinfo3
-rw-r--r--math/p5-Math-Intersection-StraightLine/pkg-descr12
-rw-r--r--math/p5-Math-Intersection-StraightLine/pkg-plist7
4 files changed, 50 insertions, 0 deletions
diff --git a/math/p5-Math-Intersection-StraightLine/Makefile b/math/p5-Math-Intersection-StraightLine/Makefile
new file mode 100644
index 000000000000..ab72d4f61ce4
--- /dev/null
+++ b/math/p5-Math-Intersection-StraightLine/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Math-Intersection-StraightLine
+# Date created: 18 Feb 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Intersection-StraightLine
+PORTVERSION= 0.02
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Calculate intersection point for two lines
+
+MAN3= Math::Intersection::StraightLine.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl5.6
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Math-Intersection-StraightLine/distinfo b/math/p5-Math-Intersection-StraightLine/distinfo
new file mode 100644
index 000000000000..c1145ad7af34
--- /dev/null
+++ b/math/p5-Math-Intersection-StraightLine/distinfo
@@ -0,0 +1,3 @@
+MD5 (Math-Intersection-StraightLine-0.02.tar.gz) = f686d5bc7b660f9a0d891c98d52908ed
+SHA256 (Math-Intersection-StraightLine-0.02.tar.gz) = 847830be0e77dbdc893f282f54af838889d69a9848b5c4330238303925c5ecdb
+SIZE (Math-Intersection-StraightLine-0.02.tar.gz) = 4145
diff --git a/math/p5-Math-Intersection-StraightLine/pkg-descr b/math/p5-Math-Intersection-StraightLine/pkg-descr
new file mode 100644
index 000000000000..05bbd0910ec5
--- /dev/null
+++ b/math/p5-Math-Intersection-StraightLine/pkg-descr
@@ -0,0 +1,12 @@
+This module calculates the intersection point of two straight lines (if
+one exists). It returns 0, if no intersection point exists. If the lines
+have an intersection point, the coordinates of the point are the
+returnvalue. If the given lines have infinite intersection points, -1 is
+returned.
+
+WWW: http://search.cpan.org/dist/Math-Intersection-StraightLine
+Author: Renee Baecker <module@renee-baecker.de>
+
+--
+Aaron Dalton
+aaron@FreeBSD.org
diff --git a/math/p5-Math-Intersection-StraightLine/pkg-plist b/math/p5-Math-Intersection-StraightLine/pkg-plist
new file mode 100644
index 000000000000..03c104575aa1
--- /dev/null
+++ b/math/p5-Math-Intersection-StraightLine/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Math/Intersection/StraightLine.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Intersection/StraightLine/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Intersection/StraightLine
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Intersection
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrmtry %%SITE_PERL%%/Math/Intersection
+@dirrmtry %%SITE_PERL%%/Math