aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-MatrixReal
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-22 19:07:32 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-22 19:07:32 +0000
commit9937b95e54d5a9b95cb27ec5782e99d1bd4e57b8 (patch)
tree3cdef8d0cb4826e67e4e4486f0b39da3a8467b14 /math/p5-Math-MatrixReal
parentb7ffdb5d78d881c7767aa9cac82c0da3a96feea7 (diff)
downloadports-9937b95e54d5a9b95cb27ec5782e99d1bd4e57b8.tar.gz
ports-9937b95e54d5a9b95cb27ec5782e99d1bd4e57b8.zip
- Respect upstream naming: rename math/p5-MatrixReal to math/p5-Math-MatrixReal
- Bump PORTREVISION for math/p5-MatrixReal PORTNAME/path change - While I'm here: - Remove unnecessary DISTNAME and MASTER_SITE_SUBDIR - Add LICENSE - Sort *_DEPENDS
Notes
Notes: svn path=/head/; revision=334605
Diffstat (limited to 'math/p5-Math-MatrixReal')
-rw-r--r--math/p5-Math-MatrixReal/Makefile21
-rw-r--r--math/p5-Math-MatrixReal/distinfo2
-rw-r--r--math/p5-Math-MatrixReal/pkg-descr18
-rw-r--r--math/p5-Math-MatrixReal/pkg-plist9
4 files changed, 50 insertions, 0 deletions
diff --git a/math/p5-Math-MatrixReal/Makefile b/math/p5-Math-MatrixReal/Makefile
new file mode 100644
index 000000000000..564a02242a33
--- /dev/null
+++ b/math/p5-Math-MatrixReal/Makefile
@@ -0,0 +1,21 @@
+# Created by: Sander Vesik <sander@haldjas.folklore.ee>
+# $FreeBSD$
+
+PORTNAME= Math-MatrixReal
+PORTVERSION= 2.10
+CATEGORIES= math perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Perl module implementing a Matrix of Reals
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+TEST_DEPENDS= p5-Test-Most>=0:${PORTSDIR}/devel/p5-Test-Most
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-MatrixReal/distinfo b/math/p5-Math-MatrixReal/distinfo
new file mode 100644
index 000000000000..dfc2099a995b
--- /dev/null
+++ b/math/p5-Math-MatrixReal/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Math-MatrixReal-2.10.tar.gz) = d9cb5d7e6bda907b8c5afbdd2d4ea618e2f40b3cb082e920cf4d47487f8b7ef3
+SIZE (Math-MatrixReal-2.10.tar.gz) = 80234
diff --git a/math/p5-Math-MatrixReal/pkg-descr b/math/p5-Math-MatrixReal/pkg-descr
new file mode 100644
index 000000000000..f6c6b98ac3c2
--- /dev/null
+++ b/math/p5-Math-MatrixReal/pkg-descr
@@ -0,0 +1,18 @@
+p5-MatrixReal is port of the perl module Math::MatrixReal, implementing a
+matrix of Reals.
+
+Math::MatrixReal needs support for operator overloading to support
+operations on matrixes as though they were just another basic perl type.
+
+In addition to the basics (+, -, *) also supported are:
+
+matrix norm, matrix transposition, matrix inverse, determinant of a
+matrix, order and numerical condition of a matrix, scalar product of
+vectors, vector product of vectors, vector length, projection of row and
+column vectors, a comfortable way for reading in a matrix from a file, the
+keyboard or your code, solving linear equations, etc.
+
+It also has an implementation of Kleene's algorithm for finding minimal
+costs for paths in a graph.
+
+WWW: http://search.cpan.org/dist/Math-MatrixReal/
diff --git a/math/p5-Math-MatrixReal/pkg-plist b/math/p5-Math-MatrixReal/pkg-plist
new file mode 100644
index 000000000000..4b25e3104bfb
--- /dev/null
+++ b/math/p5-Math-MatrixReal/pkg-plist
@@ -0,0 +1,9 @@
+%%PERL5_MAN3%%/Math::Kleene.3.gz
+%%PERL5_MAN3%%/Math::MatrixReal.3.gz
+%%SITE_PERL%%/Math/Kleene.pod
+%%SITE_PERL%%/Math/MatrixReal.pm
+%%SITE_PERL%%/Math/funcs.pl
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/MatrixReal/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/MatrixReal
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrmtry %%SITE_PERL%%/Math