aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-Prime-Util-GMP/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-09-10 20:26:08 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-09-10 20:26:08 +0000
commitfbbe99c118357a235fe0f50eb663811746ef1d77 (patch)
tree632d7e1ada07281f816539508000f0c2a0d99284 /math/p5-Math-Prime-Util-GMP/Makefile
parent633d6424526f4efe3b7cf1de34b514114c665a4a (diff)
downloadports-fbbe99c118357a235fe0f50eb663811746ef1d77.tar.gz
ports-fbbe99c118357a235fe0f50eb663811746ef1d77.zip
Add p5-Math-Prime-Util-GMP 0.51
Math::Prime::Util::GMP is a module for number theory in Perl using GMP. This includes primality tests, getting primes in a range, factoring, and more. These use GMP directly, so should be quite fast for bignums. This module is mainly intended to be used within Math::Prime::Util, but most functions can be easily used in independent C programs. Some, like factoring and primality proving, have explicit ways of compiling as standalone programs. WWW: https://metacpan.org/release/Math-Prime-Util-GMP
Notes
Notes: svn path=/head/; revision=479453
Diffstat (limited to 'math/p5-Math-Prime-Util-GMP/Makefile')
-rw-r--r--math/p5-Math-Prime-Util-GMP/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/math/p5-Math-Prime-Util-GMP/Makefile b/math/p5-Math-Prime-Util-GMP/Makefile
new file mode 100644
index 000000000000..ab47f9ec5be1
--- /dev/null
+++ b/math/p5-Math-Prime-Util-GMP/Makefile
@@ -0,0 +1,25 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Math-Prime-Util-GMP
+PORTVERSION= 0.51
+CATEGORIES= math perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Utilities related to prime numbers and factoring, using GMP
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libgmp.so:math/gmp
+
+USES= localbase perl5
+USE_PERL5= configure
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Math/Prime/Util/GMP/GMP.so
+
+.include <bsd.port.mk>