aboutsummaryrefslogtreecommitdiff
path: root/math/p5-NetCDF
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2009-09-26 15:11:38 +0000
committerRong-En Fan <rafan@FreeBSD.org>2009-09-26 15:11:38 +0000
commit18581ecd5684392ca58f1fe36e3547048e081c54 (patch)
tree3e44d7450523cea9f0a1ac3cabe04637d1c3990c /math/p5-NetCDF
parent9afeaca11ba81cb4ca608564b1dd20ceb283c2a7 (diff)
downloadports-18581ecd5684392ca58f1fe36e3547048e081c54.tar.gz
ports-18581ecd5684392ca58f1fe36e3547048e081c54.zip
- Update science/netcdf4 to 4.0.1
- Bump PORTREVISION for dependent ports PR: ports/136377 Submitted by: Sunpoet Po-Chuan Hsieh <sunpoet at sunpoet.net> (maintainer) Feature safe: yes
Notes
Notes: svn path=/head/; revision=242144
Diffstat (limited to 'math/p5-NetCDF')
-rw-r--r--math/p5-NetCDF/Makefile3
-rw-r--r--math/p5-NetCDF/files/patch-perl-NetCDF.xs13
2 files changed, 15 insertions, 1 deletions
diff --git a/math/p5-NetCDF/Makefile b/math/p5-NetCDF/Makefile
index 62032540632b..5315684c820b 100644
--- a/math/p5-NetCDF/Makefile
+++ b/math/p5-NetCDF/Makefile
@@ -7,6 +7,7 @@
PORTNAME= NetCDF
PORTVERSION= 1.2.3
+PORTREVISION= 1
CATEGORIES= math perl5
MASTER_SITES= ftp://ftp.unidata.ucar.edu/pub/netcdf-perl/
PKGNAMEPREFIX= p5-
@@ -19,7 +20,7 @@ COMMENT= Perl5 module to read and write netCDF files
NETCDF_VER?= 4
.if (${NETCDF_VER} == 4)
-LIB_DEPENDS= netcdf.5:${PORTSDIR}/science/netcdf4
+LIB_DEPENDS= netcdf.6:${PORTSDIR}/science/netcdf4
.else
LIB_DEPENDS= netcdf.4:${PORTSDIR}/science/netcdf
.endif
diff --git a/math/p5-NetCDF/files/patch-perl-NetCDF.xs b/math/p5-NetCDF/files/patch-perl-NetCDF.xs
new file mode 100644
index 000000000000..c3fd58c8c600
--- /dev/null
+++ b/math/p5-NetCDF/files/patch-perl-NetCDF.xs
@@ -0,0 +1,13 @@
+--- perl/NetCDF.xs.orig 2003-01-10 00:09:14.000000000 +0800
++++ perl/NetCDF.xs 2009-09-26 06:10:36.000000000 +0800
+@@ -23,6 +23,10 @@
+ #include <assert.h>
+ #include "netcdf.h"
+
++#if !defined(MAX_NC_OPEN)
++#define MAX_NC_OPEN sysconf(_SC_OPEN_MAX)
++#endif
++
+ /*
+ * Macro for setting a scalar value either directly or through a reference:
+ */