aboutsummaryrefslogtreecommitdiff
path: root/math/physcalc
diff options
context:
space:
mode:
authorShaun Amott <shaun@FreeBSD.org>2006-10-09 16:26:20 +0000
committerShaun Amott <shaun@FreeBSD.org>2006-10-09 16:26:20 +0000
commit243afd30371e8a77bd64564da54a9862249caab0 (patch)
tree1efb5b36292a7bc1c906686719fd54ccca4c109c /math/physcalc
parentd951c72be1e448433a0b245780ee0497ec45e3c5 (diff)
downloadports-243afd30371e8a77bd64564da54a9862249caab0.tar.gz
ports-243afd30371e8a77bd64564da54a9862249caab0.zip
Preemptively fix build for gcc 4.1.
PR: ports/104130 Submitted by: trasz <trasz@pin.if.uz.zgora.pl>
Notes
Notes: svn path=/head/; revision=175110
Diffstat (limited to 'math/physcalc')
-rw-r--r--math/physcalc/files/patch-physnode.c18
-rw-r--r--math/physcalc/pkg-plist20
2 files changed, 28 insertions, 10 deletions
diff --git a/math/physcalc/files/patch-physnode.c b/math/physcalc/files/patch-physnode.c
new file mode 100644
index 000000000000..0e2ca9307898
--- /dev/null
+++ b/math/physcalc/files/patch-physnode.c
@@ -0,0 +1,18 @@
+--- physnode.c.orig Sat Oct 7 21:33:27 2006
++++ physnode.c Sat Oct 7 21:33:30 2006
+@@ -305,12 +305,12 @@
+ }
+
+ EXPORT void bytecopy(dst, src, bytes)
+-VOID *dst;
+-VOID const *src;
++char *dst;
++char const *src;
+ int bytes;
+ {
+ while (bytes--)
+- *((char *)dst)++ = *((char const *)src)++;
++ *dst++ = *src++;
+ }
+
+ EXPORT NODEP copynode(n) /* Create a duplicate of node n (including sub-nodes) */
diff --git a/math/physcalc/pkg-plist b/math/physcalc/pkg-plist
index f8740c42d526..77e8ef80cbad 100644
--- a/math/physcalc/pkg-plist
+++ b/math/physcalc/pkg-plist
@@ -1,11 +1,11 @@
bin/physcalc
-share/physcalc/astro.phy
-share/physcalc/bits.phy
-share/physcalc/british.phy
-share/physcalc/light.phy
-share/physcalc/math.phy
-share/physcalc/money.phy
-share/physcalc/nuclear.phy
-share/physcalc/paper.phy
-share/physcalc/physcalc.phy
-@dirrm share/physcalc
+%%DATADIR%%/astro.phy
+%%DATADIR%%/bits.phy
+%%DATADIR%%/british.phy
+%%DATADIR%%/light.phy
+%%DATADIR%%/math.phy
+%%DATADIR%%/money.phy
+%%DATADIR%%/nuclear.phy
+%%DATADIR%%/paper.phy
+%%DATADIR%%/physcalc.phy
+@dirrm %%DATADIR%%