aboutsummaryrefslogtreecommitdiff
path: root/math/picosat/Makefile
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2014-08-25 11:10:03 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2014-08-25 11:10:03 +0000
commit19094cd53d0b198fa023c5c3d8adabf03e623a01 (patch)
tree6898effce91a7f174db4ff6ce39990f3074fd3a3 /math/picosat/Makefile
parentf24c8dd211cc3b2f69ac486c7f4f63f9f5e5fbb0 (diff)
downloadports-19094cd53d0b198fa023c5c3d8adabf03e623a01.tar.gz
ports-19094cd53d0b198fa023c5c3d8adabf03e623a01.zip
Move picosat and py-pycosat from devel -> math
- Remove from devel/Makefile - Add to math/Makefile - Update CATEGORIES for both ports - Add MOVED entries While I'm here, sort MOVED entries causing MOVEDlint.awk error [1] after r365599 [2] [1] 6470: date going backwards from 2014-08-20 to 2014-08-15 [2] https://svnweb.freebsd.org/changeset/ports/365599 Suggested by: vsevolod
Notes
Notes: svn path=/head/; revision=366063
Diffstat (limited to 'math/picosat/Makefile')
-rw-r--r--math/picosat/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/math/picosat/Makefile b/math/picosat/Makefile
new file mode 100644
index 000000000000..a5b862479dfd
--- /dev/null
+++ b/math/picosat/Makefile
@@ -0,0 +1,30 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= picosat
+DISTVERSION= 957
+CATEGORIES= math
+MASTER_SITES= http://fmv.jku.at/picosat/
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Satisfiability (SAT) solver for boolean variables
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_LDCONFIG= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --shared --trace --stats
+MAKEFILE= makefile
+MAKE_JOBS_UNSAFE= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/picosat ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/picomcs ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/picomus ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/picogcnf ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_LIB} ${WRKSRC}/libpicosat.so ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/libpicosat.a ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/picosat.h ${STAGEDIR}${PREFIX}/include
+
+.include <bsd.port.mk>