aboutsummaryrefslogtreecommitdiff
path: root/math/ploticus
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-16 16:22:04 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-16 16:22:04 +0000
commited724f8a62c7145923a236db31ae9b6940c40fa4 (patch)
tree46cd8c6f1a914d0aab880f0df3d6d5296104fa0a /math/ploticus
parent2352b8f97af1ab7ea25c535d65ff805b0cf6e8d3 (diff)
downloadports-ed724f8a62c7145923a236db31ae9b6940c40fa4.tar.gz
ports-ed724f8a62c7145923a236db31ae9b6940c40fa4.zip
upgrade to 2.04
use new REINPLACE_CMD for patch
Notes
Notes: svn path=/head/; revision=61378
Diffstat (limited to 'math/ploticus')
-rw-r--r--math/ploticus/Makefile6
-rw-r--r--math/ploticus/distinfo2
-rw-r--r--math/ploticus/files/patch-Makefile42
-rw-r--r--math/ploticus/pkg-plist6
4 files changed, 27 insertions, 29 deletions
diff --git a/math/ploticus/Makefile b/math/ploticus/Makefile
index 729c8929c979..861abeefe17f 100644
--- a/math/ploticus/Makefile
+++ b/math/ploticus/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= ploticus
-PORTVERSION= 2.03
+PORTVERSION= 2.04
CATEGORIES= math
MASTER_SITES= http://ploticus.sourceforge.net/download/
DISTNAME= plsrc${PORTVERSION:S/.//}
@@ -27,9 +27,7 @@ MAKE_ENV= LIBS="-L${LOCALBASE}/lib"
MAN1= pl.1
post-patch:
- @${PERL} -pi -e "s,%%X11BASE%%,${X11BASE},g ; \
- s,%%LOCALBASE%%,${LOCALBASE},g ; \
- s,^CC,#CC,g" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e "s,^CC,#CC,g" ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/pl ${PREFIX}/bin
diff --git a/math/ploticus/distinfo b/math/ploticus/distinfo
index 48b84d97fff0..543209f48944 100644
--- a/math/ploticus/distinfo
+++ b/math/ploticus/distinfo
@@ -1 +1 @@
-MD5 (plsrc203.tar.gz) = 807fa4ab2cefc6a1a54fd1c4cac67fc0
+MD5 (plsrc204.tar.gz) = 005fe1cd6fafceafe02f6353a4ad8a99
diff --git a/math/ploticus/files/patch-Makefile b/math/ploticus/files/patch-Makefile
index 4224b257f34e..9bf81a78815f 100644
--- a/math/ploticus/files/patch-Makefile
+++ b/math/ploticus/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig Thu Mar 7 16:10:46 2002
-+++ Makefile Thu Mar 7 16:10:50 2002
-@@ -22,14 +22,14 @@
+--- Makefile.orig Fri Jun 14 21:58:53 2002
++++ Makefile Mon Jun 17 00:12:22 2002
+@@ -23,14 +23,14 @@
######## Choose one of the following. All others should be commented out.
#### For Solaris 2.x uncomment the following..
@@ -12,30 +12,24 @@
#### For Linux and FreeBSD uncomment the following..
-# XLIBS = -L/usr/X11R6/lib -lX11
-# XINCLUDEDIR = -I/usr/X11R6/include
-+XLIBS = -L%%X11BASE%%/lib -lX11
-+XINCLUDEDIR = -I%%X11BASE%%/include
++XLIBS = -L${X11BASE}/lib -lX11
++XINCLUDEDIR = -I${X11BASE}/include
#### For FreeBSD uncomment the following and find GD16H or GD18H below and set to -I/usr/local/include
-# ADDLIBS = -L/usr/local/lib
-+ADDLIBS = -L%%LOCALBASE%%/lib
++ADDLIBS = -L${LOCALBASE}/lib
#### For Cygwin uncomment the following..
# PLATFORM = WIN32
-@@ -87,11 +87,11 @@
- # ZFLAG = -DWZ
+@@ -78,7 +78,7 @@
+ ######## Choose ONE of the following. All others should be commented out.
- #### For both pseudo-GIF & PNG uncomment the following.. (you must have libpng and zlib)
--ploticus: pl plpng
-+#ploticus: pl plpng
- # GD16LIBS = -lpng -lz
- # GD16H =
--GD16LIBS = /home/scg/lib/libpng.a /home/scg/lib/libz.a
--GD16H = -I/home/scg/lib
-+#GD16LIBS = /home/scg/lib/libpng.a /home/scg/lib/libz.a
-+#GD16H = -I/home/scg/lib
+ #### For pseudo-GIF uncomment the following.. (no libs required)
+-ploticus: pl
++#ploticus: pl
- #### For JPEG, WBMP, and PNG using your copy of GD 1.84+ uncomment the following..
- #### (you must have gd 1.84+, libpng, zlib, libjpeg)
-@@ -104,11 +104,11 @@
+ #### For PNG uncomment the following.. (you must have libpng and zlib)
+ # ploticus: plpng
+@@ -103,11 +103,11 @@
#### For JPEG, WBMP, and PNG & FreeType2 using your copy of GD 1.84+ uncomment the following..
#### (you must have gd 1.84+, libpng, zlib, libjpeg, libfreetype)
#### Before using set environment var GDFONTPATH to directory containing .ttf files
@@ -46,18 +40,18 @@
-# ZFLAG = -DWZ
+ploticus: plgd18
+GD18LIBS = -lgd -lpng -lz -ljpeg -lfreetype
-+GD18H = -I%%LOCALBASE%%/include -I%%LOCALBASE%%/include/gd -I%%LOCALBASE%%/include/freetype2
++GD18H = -I${LOCALBASE}/include/gd
+GDFREETYPE = -DGDFREETYPE
+ZFLAG = -DWZ
#### To disable GD image support (no GIF, PNG, JPEG, etc) uncomment the following..
# ploticus: plnogd
-@@ -122,11 +122,11 @@
+@@ -125,11 +125,11 @@
#### To set a hard-coded directory for prefabs files, uncomment & edit the following..
#### If done, users won't be required to have PLOTICUS_PREFABS environment variable defined.
#### This option not available for win32
-# PREFABS_DIR = "/usr/lib/ploticus"
-+PREFABS_DIR = "%%LOCALBASE%%/share/ploticus"
++PREFABS_DIR = "${LOCALBASE}/share/ploticus"
#### For LOCALE support (non-roman alphabets & collation), uncomment the following..
-# LOCALEOBJ = localef.o
@@ -67,7 +61,7 @@
#### If you want compressed svg (.svgz), and you selected "GIF only", "GIF & PNG", or "disable GD" above,
#### uncomment the following. You need to have zlib. If necessary change -lz to location of zlib.
-@@ -154,9 +154,9 @@
+@@ -156,9 +156,9 @@
GD = gdfontg.o gdfontl.o gdfontmb.o gdfonts.o gdfontt.o
diff --git a/math/ploticus/pkg-plist b/math/ploticus/pkg-plist
index 9a55aaddb4ec..d4fd75fa47b5 100644
--- a/math/ploticus/pkg-plist
+++ b/math/ploticus/pkg-plist
@@ -2,6 +2,8 @@ bin/pl
share/ploticus/README
share/ploticus/chron.pl
share/ploticus/chunk_area
+share/ploticus/chunk_logstubs
+share/ploticus/chunk_logtics
share/ploticus/chunk_read
share/ploticus/chunk_setstd
share/ploticus/chunk_title
@@ -10,6 +12,7 @@ share/ploticus/chunk_yaxis
share/ploticus/dist.pl
share/ploticus/draw.pl
share/ploticus/lines.pl
+share/ploticus/multidist.pl
share/ploticus/pie.pl
share/ploticus/scat.pl
share/ploticus/stack.pl
@@ -48,6 +51,7 @@ share/ploticus/vbars.pl
%%PORTDOCS%%share/doc/ploticus/dates.html
%%PORTDOCS%%share/doc/ploticus/defineunits.html
%%PORTDOCS%%share/doc/ploticus/drawcommands.html
+%%PORTDOCS%%share/doc/ploticus/dynamic.html
%%PORTDOCS%%share/doc/ploticus/endproc.html
%%PORTDOCS%%share/doc/ploticus/fonts.html
%%PORTDOCS%%share/doc/ploticus/functions.html
@@ -85,12 +89,14 @@ share/ploticus/vbars.pl
%%PORTDOCS%%share/doc/ploticus/prefab_dist.html
%%PORTDOCS%%share/doc/ploticus/prefab_draw.html
%%PORTDOCS%%share/doc/ploticus/prefab_lines.html
+%%PORTDOCS%%share/doc/ploticus/prefab_multidist.html
%%PORTDOCS%%share/doc/ploticus/prefab_pie.html
%%PORTDOCS%%share/doc/ploticus/prefab_scat.html
%%PORTDOCS%%share/doc/ploticus/prefab_stack.html
%%PORTDOCS%%share/doc/ploticus/prefab_stdparms.html
%%PORTDOCS%%share/doc/ploticus/prefab_vbars.html
%%PORTDOCS%%share/doc/ploticus/prefabs.html
+%%PORTDOCS%%share/doc/ploticus/prepress.html
%%PORTDOCS%%share/doc/ploticus/print.html
%%PORTDOCS%%share/doc/ploticus/processdata.html
%%PORTDOCS%%share/doc/ploticus/rangebar.html