aboutsummaryrefslogtreecommitdiff
path: root/math/pspp
diff options
context:
space:
mode:
authorCarlos J. Puga Medina <cpm@FreeBSD.org>2016-04-03 02:20:14 +0000
committerCarlos J. Puga Medina <cpm@FreeBSD.org>2016-04-03 02:20:14 +0000
commitd259dc35843f108df61b87579f6ad5c4b6dbf14a (patch)
tree38bef61e5e5c7636958435bb3db7182940539ff2 /math/pspp
parent32ba3aae3c46e1fbb210c390026fec3bd0ff9ff8 (diff)
downloadports-d259dc35843f108df61b87579f6ad5c4b6dbf14a.tar.gz
ports-d259dc35843f108df61b87579f6ad5c4b6dbf14a.zip
- Update to 0.10.0
- Update MAINTAINER to my @FreeBSD.org address - Update GUI dependency to GTK3 - Add EXAMPLES option - Fix pkg-plist Changelog: http://lists.gnu.org/archive/html/pspp-announce/2016-03/msg00000.html Approved by: junovitch (mentor)
Notes
Notes: svn path=/head/; revision=412443
Diffstat (limited to 'math/pspp')
-rw-r--r--math/pspp/Makefile17
-rw-r--r--math/pspp/distinfo4
-rw-r--r--math/pspp/pkg-plist42
3 files changed, 37 insertions, 26 deletions
diff --git a/math/pspp/Makefile b/math/pspp/Makefile
index b888038f5ca5..0660ab254cd8 100644
--- a/math/pspp/Makefile
+++ b/math/pspp/Makefile
@@ -2,12 +2,11 @@
# $FreeBSD$
PORTNAME= pspp
-PORTVERSION= 0.8.5
-PORTREVISION= 1
+PORTVERSION= 0.10.0
CATEGORIES= math
MASTER_SITES= GNU
-MAINTAINER= cpm@fbsd.es
+MAINTAINER= cpm@FreeBSD.org
COMMENT= Program for statistical analysis of sampled data
LICENSE= GPLv3
@@ -30,15 +29,16 @@ LDFLAGS+= -L${LOCALBASE}/lib
PLIST_SUB= VERSION="${PORTVERSION}"
PORTDOCS= AUTHORS ChangeLog NEWS ONEWS README THANKS TODO
+PORTEXAMPLES= *
INFO= pspp pspp-dev
-OPTIONS_DEFINE= DOCS GUI NLS PGSQL
+OPTIONS_DEFINE= DOCS EXAMPLES GUI NLS PGSQL
OPTIONS_SUB= yes
-GUI_LIB_DEPENDS= libgladeui-1.so:devel/glade3
+GUI_LIB_DEPENDS= libgladeui-2.so:devel/glade
GUI_RUN_DEPENDS= yelp:x11/yelp
GUI_USES= desktop-file-utils
-GUI_USE= gnome=gtksourceview2,libglade2
+GUI_USE= gnome=gtk30,gtksourceview3
GUI_CONFIGURE_WITH= cairo gui gui-tools
GUI_INSTALL_TARGET= install-icons install-ext-icons
NLS_USES= gettext
@@ -68,4 +68,9 @@ post-install:
"${PORTDOCS}" ${STAGEDIR}${DOCSDIR})
.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+ (cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \
+ "${PORTEXAMPLES}" ${STAGEDIR}${EXAMPLESDIR})
+.endif
+
.include <bsd.port.mk>
diff --git a/math/pspp/distinfo b/math/pspp/distinfo
index 01527a0a3e12..3355cc372eb8 100644
--- a/math/pspp/distinfo
+++ b/math/pspp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pspp-0.8.5.tar.gz) = e7efd2ffa58882e97f719cb403d84683751c913cc2ca133b49b1c5e9bd110331
-SIZE (pspp-0.8.5.tar.gz) = 6695394
+SHA256 (pspp-0.10.0.tar.gz) = ef3dbfc71755a4fd7f48f257d40599924b2b6c174d238818251eb95d51ee96db
+SIZE (pspp-0.10.0.tar.gz) = 7262172
diff --git a/math/pspp/pkg-plist b/math/pspp/pkg-plist
index 937cd31f1f3d..f646441443ea 100644
--- a/math/pspp/pkg-plist
+++ b/math/pspp/pkg-plist
@@ -2,10 +2,10 @@ bin/pspp
bin/pspp-convert
bin/pspp-dump-sav
%%GUI%%bin/psppire
-%%GUI%%lib/glade3/modules/libglade-psppire.a
-%%GUI%%lib/glade3/modules/libglade-psppire.so
-%%GUI%%lib/glade3/modules/libglade-psppire.so.0
-%%GUI%%lib/glade3/modules/libglade-psppire.so.0.0.0
+%%GUI%%lib/glade/modules/libglade-psppire.a
+%%GUI%%lib/glade/modules/libglade-psppire.so
+%%GUI%%lib/glade/modules/libglade-psppire.so.0
+%%GUI%%lib/glade/modules/libglade-psppire.so.0.0.0
lib/pspp/libpspp.a
lib/pspp/libpspp.so
lib/pspp/libpspp-%%VERSION%%.so
@@ -20,19 +20,19 @@ man/man1/pspp-dump-sav.1.gz
%%GUI%%share/applications/pspp.desktop
%%PORTDOCS%%%%DOCSDIR%%/pspp.xml
share/emacs/site-lisp/pspp-mode.el
-%%GUI%%share/glade3/catalogs/psppire.xml
-%%GUI%%share/glade3/pixmaps/16x16/psppire-acr.png
-%%GUI%%share/glade3/pixmaps/16x16/psppire-dialog.png
-%%GUI%%share/glade3/pixmaps/16x16/psppire-hbuttonbox.png
-%%GUI%%share/glade3/pixmaps/16x16/psppire-keypad.png
-%%GUI%%share/glade3/pixmaps/16x16/psppire-selector.png
-%%GUI%%share/glade3/pixmaps/16x16/psppire-vbuttonbox.png
-%%GUI%%share/glade3/pixmaps/22x22/psppire-acr.png
-%%GUI%%share/glade3/pixmaps/22x22/psppire-dialog.png
-%%GUI%%share/glade3/pixmaps/22x22/psppire-hbuttonbox.png
-%%GUI%%share/glade3/pixmaps/22x22/psppire-keypad.png
-%%GUI%%share/glade3/pixmaps/22x22/psppire-selector.png
-%%GUI%%share/glade3/pixmaps/22x22/psppire-vbuttonbox.png
+%%GUI%%share/glade/catalogs/psppire.xml
+%%GUI%%share/glade/pixmaps/hicolor/16x16/actions/widget-psppire-psppire-acr.png
+%%GUI%%share/glade/pixmaps/hicolor/16x16/actions/widget-psppire-psppire-dialog.png
+%%GUI%%share/glade/pixmaps/hicolor/16x16/actions/widget-psppire-psppire-hbuttonbox.png
+%%GUI%%share/glade/pixmaps/hicolor/16x16/actions/widget-psppire-psppire-keypad.png
+%%GUI%%share/glade/pixmaps/hicolor/16x16/actions/widget-psppire-psppire-selector.png
+%%GUI%%share/glade/pixmaps/hicolor/16x16/actions/widget-psppire-psppire-vbuttonbox.png
+%%GUI%%share/glade/pixmaps/hicolor/22x22/actions/widget-psppire-psppire-acr.png
+%%GUI%%share/glade/pixmaps/hicolor/22x22/actions/widget-psppire-psppire-dialog.png
+%%GUI%%share/glade/pixmaps/hicolor/22x22/actions/widget-psppire-psppire-hbuttonbox.png
+%%GUI%%share/glade/pixmaps/hicolor/22x22/actions/widget-psppire-psppire-keypad.png
+%%GUI%%share/glade/pixmaps/hicolor/22x22/actions/widget-psppire-psppire-selector.png
+%%GUI%%share/glade/pixmaps/hicolor/22x22/actions/widget-psppire-psppire-vbuttonbox.png
%%GUI%%share/icons/hicolor/16x16/apps/pspp.png
%%GUI%%share/icons/hicolor/16x16/mimetypes/application-x-spss-por.png
%%GUI%%share/icons/hicolor/16x16/mimetypes/application-x-spss-sav.png
@@ -76,6 +76,7 @@ share/emacs/site-lisp/pspp-mode.el
%%NLS%%share/locale/nl/LC_MESSAGES/pspp.mo
%%NLS%%share/locale/pl/LC_MESSAGES/pspp.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/pspp.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/pspp.mo
%%NLS%%share/locale/sl/LC_MESSAGES/pspp.mo
%%NLS%%share/locale/tr/LC_MESSAGES/pspp.mo
%%NLS%%share/locale/uk/LC_MESSAGES/pspp.mo
@@ -189,6 +190,7 @@ share/emacs/site-lisp/pspp-mode.el
%%GUI%%%%DATADIR%%/actions/32x32/view-value-labels.png
%%GUI%%%%DATADIR%%/aggregate.ui
%%GUI%%%%DATADIR%%/autorecode.ui
+%%GUI%%%%DATADIR%%/barchart.ui
%%GUI%%%%DATADIR%%/binomial.ui
%%GUI%%%%DATADIR%%/categories/16x16/align-center.png
%%GUI%%%%DATADIR%%/categories/16x16/align-left.png
@@ -214,6 +216,7 @@ share/emacs/site-lisp/pspp-mode.el
%%GUI%%%%DATADIR%%/categories/16x16/role-split.png
%%GUI%%%%DATADIR%%/categories/16x16/role-target.png
%%GUI%%%%DATADIR%%/chi-square.ui
+%%GUI%%%%DATADIR%%/comments.ui
%%GUI%%%%DATADIR%%/compute.ui
%%GUI%%%%DATADIR%%/correlation.ui
%%GUI%%%%DATADIR%%/count.ui
@@ -234,6 +237,7 @@ share/emacs/site-lisp/pspp-mode.el
%%GUI%%%%DATADIR%%/find.ui
%%GUI%%%%DATADIR%%/frequencies.ui
%%GUI%%%%DATADIR%%/goto-case.ui
+%%GUI%%%%DATADIR%%/histogram.ui
%%GUI%%%%DATADIR%%/indep-samples.ui
%%GUI%%%%DATADIR%%/k-means.ui
%%GUI%%%%DATADIR%%/k-related.ui
@@ -246,22 +250,24 @@ share/emacs/site-lisp/pspp-mode.el
%%GUI%%%%DATADIR%%/paired-samples.ui
%%GUI%%%%DATADIR%%/pspp.lang
%%GUI%%%%DATADIR%%/psppire.gtkrc
-%%GUI%%%%DATADIR%%/psppire.ui
%%GUI%%%%DATADIR%%/rank.ui
%%GUI%%%%DATADIR%%/recode.ui
%%GUI%%%%DATADIR%%/regression.ui
%%GUI%%%%DATADIR%%/reliability.ui
%%GUI%%%%DATADIR%%/roc.ui
%%GUI%%%%DATADIR%%/runs.ui
+%%GUI%%%%DATADIR%%/scatterplot.ui
%%GUI%%%%DATADIR%%/select-cases.ui
%%GUI%%%%DATADIR%%/sort.ui
%%GUI%%%%DATADIR%%/splash.png
%%GUI%%%%DATADIR%%/split-file.ui
%%GUI%%%%DATADIR%%/syntax-editor.ui
%%GUI%%%%DATADIR%%/t-test.ui
+%%GUI%%%%DATADIR%%/transpose.ui
%%GUI%%%%DATADIR%%/text-data-import.ui
%%GUI%%%%DATADIR%%/univariate.ui
%%GUI%%%%DATADIR%%/val-labs-dialog.ui
%%GUI%%%%DATADIR%%/var-sheet.ui
%%GUI%%%%DATADIR%%/var-type-dialog.ui
%%GUI%%%%DATADIR%%/variable-info.ui
+%%GUI%%%%DATADIR%%/weight.ui