aboutsummaryrefslogtreecommitdiff
path: root/math/pspp
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-03-05 17:07:43 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-03-05 17:07:43 +0000
commitfb3520254ab73be0aad04c3a63b781750cf26b5b (patch)
tree268d74f9d8738f78b0c895672044611aa6343387 /math/pspp
parent4706739618b79681811e5b336a54032908638160 (diff)
downloadports-fb3520254ab73be0aad04c3a63b781750cf26b5b.tar.gz
ports-fb3520254ab73be0aad04c3a63b781750cf26b5b.zip
- Convert to OptionsNG
- Trim header Reviewed by: beat, bapt, kwm
Notes
Notes: svn path=/head/; revision=313460
Diffstat (limited to 'math/pspp')
-rw-r--r--math/pspp/Makefile25
1 files changed, 10 insertions, 15 deletions
diff --git a/math/pspp/Makefile b/math/pspp/Makefile
index 0966e33dfdf4..39e64483ada8 100644
--- a/math/pspp/Makefile
+++ b/math/pspp/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pspp
-# Date created: 22 Apr 2000
-# Whom: Andrew L. Neporada <andrew@chg.ru>
-#
+# Created by: Andrew L. Neporada <andrew@chg.ru>
# $FreeBSD$
-#
PORTNAME= pspp
PORTVERSION= 0.6.2
@@ -17,8 +13,7 @@ COMMENT= Program for statistical analysis of sampled data
LIB_DEPENDS= plot.4:${PORTSDIR}/graphics/plotutils \
gslcblas.0:${PORTSDIR}/math/gsl
-OPTIONS= GUI "Build the PSPPIRE gui" off \
- PGSQL "Compile in PostgreSQL capability" off
+OPTIONS_DEFINE= GUI PGSQL
USE_GNOME= libxml2
USE_PERL5_BUILD=yes
@@ -32,17 +27,17 @@ INFO= pspp pspp-dev
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
-.if defined(WITH_GUI)
+.if ${PORT_OPTIONS:MGUI}
LIB_DEPENDS+= gladeui-1:${PORTSDIR}/devel/glade3
RUN_DEPENDS+= yelp:${PORTSDIR}/x11/yelp
USE_GNOME+= libglade2
@@ -53,7 +48,7 @@ CONFIGURE_ARGS+= --without-gui
PLIST_SUB+= GUI="@comment "
.endif
-.if defined(WITH_PGSQL)
+.if ${PORT_OPTIONS:MPGSQL}
USE_PGSQL= yes
.else
CONFIGURE_ARGS+= --without-libpq
@@ -65,4 +60,4 @@ post-patch:
post-install:
@${TOUCH} ${PREFIX}/lib/pspp/.keep_me
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>