aboutsummaryrefslogtreecommitdiff
path: root/math/py-PyWavelets/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2020-09-28 21:16:54 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2020-09-28 21:16:54 +0000
commit45fd022f5a05557d1b681581eb02d499595c19a0 (patch)
treef715c7740b46e2db48c366b2ba5d0d544b0f78db /math/py-PyWavelets/Makefile
parent5ba86fa011a72d35c3d321aab79ff9a52bffd807 (diff)
downloadports-45fd022f5a05557d1b681581eb02d499595c19a0.tar.gz
ports-45fd022f5a05557d1b681581eb02d499595c19a0.zip
math/py-PyWavelets:
- Update to 1.1.1. This release supports Python 3.7 and greater - Drop needless dependency - Take maintainership PR: 249565 Approved by: Eric Camachat (former maintainer)
Notes
Notes: svn path=/head/; revision=550451
Diffstat (limited to 'math/py-PyWavelets/Makefile')
-rw-r--r--math/py-PyWavelets/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/math/py-PyWavelets/Makefile b/math/py-PyWavelets/Makefile
index abeb35cbed86..94e3963a6f03 100644
--- a/math/py-PyWavelets/Makefile
+++ b/math/py-PyWavelets/Makefile
@@ -1,26 +1,24 @@
# $FreeBSD$
PORTNAME= PyWavelets
-PORTVERSION= 0.5.2
-PORTREVISION= 4
+PORTVERSION= 1.1.1
DISTVERSIONPREFIX= v
CATEGORIES= math python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= eric@camachat.org
+MAINTAINER= makc@FreeBSD.org
COMMENT= Discrete Wavelet Transforms in Python
LICENSE= MIT
-LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYNUMPY}
-RUN_DEPENDS= ${PYNUMPY} \
- ${PY_PILLOW}
+RUN_DEPENDS= ${PYNUMPY}
USE_GITHUB= yes
GH_PROJECT= pywt
-USES= cpe python
+USES= cpe python:3.7+
USE_PYTHON= autoplist distutils cython cython_run
PYDISTUTILS_BUILD_TARGET= build build_ext