aboutsummaryrefslogtreecommitdiff
path: root/math/py-Pyomo
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-31 08:23:34 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-31 08:23:34 +0000
commit5afffa40f160c3450e921e1369d39df422944b19 (patch)
tree6ec5c1ecdfbac9110e5df7efbbaa0eae0fc01633 /math/py-Pyomo
parent43d678c65aa9ee4deb8359e30ab2694430fa44be (diff)
downloadports-5afffa40f160c3450e921e1369d39df422944b19.tar.gz
ports-5afffa40f160c3450e921e1369d39df422944b19.zip
New port: math/py-Pyomo: Python Optimization Modeling Objects
Notes
Notes: svn path=/head/; revision=466033
Diffstat (limited to 'math/py-Pyomo')
-rw-r--r--math/py-Pyomo/Makefile23
-rw-r--r--math/py-Pyomo/distinfo3
-rw-r--r--math/py-Pyomo/pkg-descr24
3 files changed, 50 insertions, 0 deletions
diff --git a/math/py-Pyomo/Makefile b/math/py-Pyomo/Makefile
new file mode 100644
index 000000000000..11add28cfece
--- /dev/null
+++ b/math/py-Pyomo/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= Pyomo
+DISTVERSION= 5.4.3
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python Optimization Modeling Objects
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}appdirs>0:devel/py-appdirs@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ply>0:devel/py-ply@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}PyUtilib>=5.6.2:devel/py-PyUtilib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.4:devel/py-six@${FLAVOR}
+
+USES= python
+USE_PYTHON= distutils concurrent autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/math/py-Pyomo/distinfo b/math/py-Pyomo/distinfo
new file mode 100644
index 000000000000..8b55fbd8cb5a
--- /dev/null
+++ b/math/py-Pyomo/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522480103
+SHA256 (Pyomo-5.4.3.tar.gz) = 722887e1b4d8963eb648aaa61a70f5060cc3db63f48f5d2ffdc822ed90bb0f22
+SIZE (Pyomo-5.4.3.tar.gz) = 1377037
diff --git a/math/py-Pyomo/pkg-descr b/math/py-Pyomo/pkg-descr
new file mode 100644
index 000000000000..b4e9970de28d
--- /dev/null
+++ b/math/py-Pyomo/pkg-descr
@@ -0,0 +1,24 @@
+Pyomo is a Python-based open-source software package that supports a diverse
+set of optimization capabilities for formulating and analyzing optimization
+models.
+
+Modeling optimization applications is a core capability of Pyomo. Pyomo can be
+used to define symbolic problems, create concrete problem instances, and solve
+these instances with standard solvers. Thus, Pyomo provides a capability that is
+commonly associated with algebraic modeling languages such as AMPL, AIMMS, and
+GAMS, but Pyomo's modeling objects are embedded within a full-featured
+high-level programming language with a rich set of supporting libraries. Pyomo
+supports a wide range of problem types, including:
+* Linear programming
+* Quadratic programming
+* Nonlinear programming
+* Mixed-integer linear programming
+* Mixed-integer quadratic programming
+* Mixed-integer nonlinear programming
+* Mixed-integer stochastic programming
+* Generalized disjunctive programming
+* Differential algebraic equations
+* Bilevel programming
+* Mathematical programming with equilibrium constraints
+
+WWW: https://github.com/Pyomo/pyomo