aboutsummaryrefslogtreecommitdiff
path: root/math/py-bottleneck/Makefile
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-12-08 14:19:34 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-12-08 14:19:34 +0000
commitbdccad04ff09ad98a7750dddf7b0dff12dc8a155 (patch)
treeee2bfeb7e02f173f69188d404c39ca0c15407c74 /math/py-bottleneck/Makefile
parentce87faed915352606a13c800b4a20ad18414f63c (diff)
downloadports-bdccad04ff09ad98a7750dddf7b0dff12dc8a155.tar.gz
ports-bdccad04ff09ad98a7750dddf7b0dff12dc8a155.zip
math/py-bottleneck: Collection of fast NumPy array functions written in Cython
WWW: https://www.github.com/kwgoodman/bottleneck/ PR: ports/184584 Submitted by: Johannes Jost Meixner <xmj chaot.net>
Notes
Notes: svn path=/head/; revision=335898
Diffstat (limited to 'math/py-bottleneck/Makefile')
-rw-r--r--math/py-bottleneck/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/math/py-bottleneck/Makefile b/math/py-bottleneck/Makefile
new file mode 100644
index 000000000000..fbb6816bbd13
--- /dev/null
+++ b/math/py-bottleneck/Makefile
@@ -0,0 +1,37 @@
+# Created by: Johannes Meixner <xmj@chaot.net>
+# $FreeBSD$
+
+PORTNAME= bottleneck
+PORTVERSION= 0.7.0
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= Bottleneck-${PORTVERSION}
+
+MAINTAINER= xmj@chaot.net
+COMMENT= Collection of fast NumPy array functions written in Cython
+
+LICENSE= BSD
+
+BUILD_DEPENDS= ${PYNUMPY} \
+ cython:${PORTSDIR}/lang/cython
+RUN_DEPENDS= ${PYNUMPY}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:${PORTSDIR}/devel/py-nose
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
+
+OPTIONS_DEFINE= DOCS
+DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
+PORTDOCS= *
+
+regression-test: build
+ @cd ${WRKSRC} && nosetests
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.rst ${WRKSRC}/RELEASE.rst ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/doc/source/ && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>