aboutsummaryrefslogtreecommitdiff
path: root/math/py-colormath/Makefile
diff options
context:
space:
mode:
authorSteven Kreuzer <skreuzer@FreeBSD.org>2015-07-15 17:35:02 +0000
committerSteven Kreuzer <skreuzer@FreeBSD.org>2015-07-15 17:35:02 +0000
commita36857886d5baec6db6a061cd73f4d5251e5d434 (patch)
tree85a4e71c036cb47cfc1a5013868b86900f79dde3 /math/py-colormath/Makefile
parentd0eca59eaec54583045b58070a515e88e518d315 (diff)
downloadports-a36857886d5baec6db6a061cd73f4d5251e5d434.tar.gz
ports-a36857886d5baec6db6a061cd73f4d5251e5d434.zip
colormath is a simple Python module that spares the user from directly dealing
with color math. Some features include: * Support for a wide range of color spaces. A good chunk of the CIE spaces, RGB, HSL/HSV, CMY/CMYK, and many more. * Conversions between the various color spaces. For example, XYZ to sRGB, Spectral to XYZ, CIE Lab to Adobe RGB. * Calculation of color difference. All CIE Delta E functions, plus CMC. * Chromatic adaptations (changing illuminants). * RGB to hex and vice-versa. * 16-bit RGB support. WWW: https://pypi.python.org/pypi/colormath
Notes
Notes: svn path=/head/; revision=392173
Diffstat (limited to 'math/py-colormath/Makefile')
-rw-r--r--math/py-colormath/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/math/py-colormath/Makefile b/math/py-colormath/Makefile
new file mode 100644
index 000000000000..a972d3712d36
--- /dev/null
+++ b/math/py-colormath/Makefile
@@ -0,0 +1,21 @@
+# Created by: Steven Kreuzer <skreuzer@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= colormath
+PORTVERSION= 2.1.1
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= skreuzer@FreeBSD.org
+COMMENT= Module that spares the user from directly dealing with color math
+
+LICENSE= BSD2CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.9.2:${PORTSDIR}/math/py-numpy \
+ ${PYTHON_PKGNAMEPREFIX}networkx>=1.9.1:${PORTSDIR}/math/py-networkx
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>