aboutsummaryrefslogtreecommitdiff
path: root/math/py-cvxopt
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-10-31 19:20:14 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-10-31 19:20:14 +0000
commitcb1669ee3e99f1248fc0dfb675bf11bc6d0e1f61 (patch)
tree4181286d7d0e64ab20d0e04f98b3f9ac90f2b2c1 /math/py-cvxopt
parentabd45cf2f205e787dfe57de410c014967cd681c6 (diff)
downloadports-cb1669ee3e99f1248fc0dfb675bf11bc6d0e1f61.tar.gz
ports-cb1669ee3e99f1248fc0dfb675bf11bc6d0e1f61.zip
math/py-cvxopt: Remove WITH_ from options; Improve option descriptions
Reported by: mat
Notes
Notes: svn path=/head/; revision=483607
Diffstat (limited to 'math/py-cvxopt')
-rw-r--r--math/py-cvxopt/Makefile29
1 files changed, 14 insertions, 15 deletions
diff --git a/math/py-cvxopt/Makefile b/math/py-cvxopt/Makefile
index 7c20e6133c99..adf4750827a0 100644
--- a/math/py-cvxopt/Makefile
+++ b/math/py-cvxopt/Makefile
@@ -21,25 +21,24 @@ USE_PYTHON= distutils autoplist
CFLAGS+= -I${LOCALBASE}/include/suitesparse
-OPTIONS_DEFINE= WITH_GSL WITH_FFTW WITH_GLPK WITH_DSDP
-OPTIONS_DEFAULT= WITH_GSL WITH_FFTW WITH_GLPK WITH_DSDP
+OPTIONS_DEFINE= GSL FFTW GLPK DSDP
+OPTIONS_DEFAULT= GSL FFTW GLPK DSDP
-WITH_GSL_DESC= Build with gsl
-WITH_GSL_MAKE_ENV= CVXOPT_BUILD_GSL=1
-WITH_GSL_LIB_DEPENDS= libgsl.so:math/gsl
+GSL_DESC= Build with GSL, the GNU scientific library
+GSL_MAKE_ENV= CVXOPT_BUILD_GSL=1
+GSL_LIB_DEPENDS= libgsl.so:math/gsl
-WITH_FFTW_DESC= Build with fftw
-WITH_FFTW_MAKE_ENV= CVXOPT_BUILD_FFTW=1
-WITH_FFTW_LIB_DEPENDS= libfftw3.so:math/fftw3
+FFTW_MAKE_ENV= CVXOPT_BUILD_FFTW=1
+FFTW_LIB_DEPENDS= libfftw3.so:math/fftw3
-WITH_GLPK_DESC= Build with GLPK
-WITH_GLPK_MAKE_ENV= CVXOPT_BUILD_GLPK=1
-WITH_GLPK_LIB_DEPENDS= libglpk.so:math/glpk
+GLPK_DESC= Build with GLPK, the linear programming solver
+GLPK_MAKE_ENV= CVXOPT_BUILD_GLPK=1
+GLPK_LIB_DEPENDS= libglpk.so:math/glpk
-WITH_DSDP_DESC= Build with DSDP
-WITH_DSDP_MAKE_ENV= CVXOPT_BUILD_DSDP=1
-WITH_DSDP_CFLAGS= -I${LOCALBASE}/include/dsdp
-WITH_DSDP_LIB_DEPENDS= libdsdp.so:math/dsdp
+DSDP_DESC= Build with DSDP, the interior-point method
+DSDP_MAKE_ENV= CVXOPT_BUILD_DSDP=1
+DSDP_CFLAGS= -I${LOCALBASE}/include/dsdp
+DSDP_LIB_DEPENDS= libdsdp.so:math/dsdp
post-install:
@${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/cvxopt/*.so