aboutsummaryrefslogtreecommitdiff
path: root/math/py-ducc0/Makefile
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2022-04-22 15:37:40 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2022-04-22 15:37:40 +0000
commitfa071332cf53dac955d319ff22c13fe885335e60 (patch)
treeb5bd2c724f487db0b83bc7481a76f5a5179ed625 /math/py-ducc0/Makefile
parenta81e1987c5d49106a769fd83ddef034ab763574f (diff)
downloadports-fa071332cf53dac955d319ff22c13fe885335e60.tar.gz
ports-fa071332cf53dac955d319ff22c13fe885335e60.zip
math/py-ducc0: use clang on powerpc64
Diffstat (limited to 'math/py-ducc0/Makefile')
-rw-r--r--math/py-ducc0/Makefile11
1 files changed, 1 insertions, 10 deletions
diff --git a/math/py-ducc0/Makefile b/math/py-ducc0/Makefile
index aa77c2fdfe44..414f5c56f901 100644
--- a/math/py-ducc0/Makefile
+++ b/math/py-ducc0/Makefile
@@ -17,21 +17,12 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pybind11>0:devel/py-pybind11@${PY_FLAVOR}
RUN_DEPENDS= ${PYNUMPY}
TEST_DEPENDS= py.test:devel/py-pytest@${PY_FLAVOR}
-USES= python:3.6+
+USES= compiler:c++17-lang python:3.6+
USE_PYTHON= distutils autoplist
MAKE_ENV= DUCC0_OPTIMIZATION=none
-.include <bsd.port.options.mk>
-
-.if ${ARCH} == powerpc64
-CFLAGS+= -DNO_WARN_X86_INTRINSICS
-USES+= compiler:gcc-c++11-lib
-.else
-USES+= compiler:c++17-lang
-.endif
-
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/ducc0*.so