aboutsummaryrefslogtreecommitdiff
path: root/math/py-gato
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2003-12-18 07:07:37 +0000
committerMark Linimon <linimon@FreeBSD.org>2003-12-18 07:07:37 +0000
commit8123aa36741c3819ab59e68964da2cb1a19f9c4f (patch)
tree8e01f743ebb7f594abe8b7a4cb586bbe2446bb46 /math/py-gato
parent4761b241a4c8c6aa79c17843e05e922c74c15ccc (diff)
downloadports-8123aa36741c3819ab59e68964da2cb1a19f9c4f.tar.gz
ports-8123aa36741c3819ab59e68964da2cb1a19f9c4f.zip
Update to 0.98I of 12/05/2003. The old version had not been fetchable
for over a year. Adds priority queues, reworks menus, better integration with TK. Since the current maintainer is temporarily away from FreeBSD, anyone interested in this port should consider volunteering to be its maintainer. It appears to still be under active development.
Notes
Notes: svn path=/head/; revision=96132
Diffstat (limited to 'math/py-gato')
-rw-r--r--math/py-gato/Makefile2
-rw-r--r--math/py-gato/distinfo2
-rw-r--r--math/py-gato/files/patch-Gato.py33
-rw-r--r--math/py-gato/files/patch-GatoUtil.py13
-rw-r--r--math/py-gato/files/patch-Graph.py11
-rw-r--r--math/py-gato/files/patch-GraphUtil.py9
-rw-r--r--math/py-gato/files/patch-Gred.py17
-rw-r--r--math/py-gato/pkg-plist21
8 files changed, 42 insertions, 66 deletions
diff --git a/math/py-gato/Makefile b/math/py-gato/Makefile
index b19ae6fa6f29..5404921caf35 100644
--- a/math/py-gato/Makefile
+++ b/math/py-gato/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gato
-PORTVERSION= 0.96.g
+PORTVERSION= 0.98.I
CATEGORIES= math python
MASTER_SITES= http://www.zpr.uni-koeln.de/~gato/Download/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/math/py-gato/distinfo b/math/py-gato/distinfo
index d28a097282cb..2873180fc8fc 100644
--- a/math/py-gato/distinfo
+++ b/math/py-gato/distinfo
@@ -1 +1 @@
-MD5 (Gato-0.96G.tar) = c0c942acf0961847b07fb9a6cd7e535c
+MD5 (Gato-0.98I.tar) = 3ca25213e6f392f0722451e2d97b903d
diff --git a/math/py-gato/files/patch-Gato.py b/math/py-gato/files/patch-Gato.py
index c9ff38cbbaab..be050b9feeab 100644
--- a/math/py-gato/files/patch-Gato.py
+++ b/math/py-gato/files/patch-Gato.py
@@ -1,17 +1,10 @@
---- Gato.py.orig Wed May 16 13:16:55 2001
-+++ Gato.py Mon Sep 3 12:26:21 2001
-@@ -38,7 +38,6 @@
- import bdb
- import whrandom
- import re
--import regsub
- import string
- import StringIO
- import tokenize
-@@ -49,13 +48,13 @@
+--- Gato.py.dist Thu Dec 18 00:34:01 2003
++++ Gato.py Thu Dec 18 00:35:50 2003
+@@ -54,15 +54,15 @@
+ from tkFileDialog import askopenfilename, asksaveasfilename
+ from tkMessageBox import askokcancel, showerror, askyesno
from ScrolledText import ScrolledText
-
-
+-from GatoConfiguration import GatoConfiguration
-from Graph import Graph
-from GraphUtil import *
-from GraphDisplay import GraphDisplayToplevel
@@ -19,6 +12,8 @@
-from GatoGlobals import *
-from GatoDialogs import AboutBox, SplashScreen, HTMLViewer
-import GatoIcons
+-import GatoSystemConfiguration
++from Gato.GatoConfiguration import GatoConfiguration
+from Gato.Graph import Graph
+from Gato.GraphUtil import *
+from Gato.GraphDisplay import GraphDisplayToplevel
@@ -26,19 +21,11 @@
+from Gato.GatoGlobals import *
+from Gato.GatoDialogs import AboutBox, SplashScreen, HTMLViewer
+from Gato import GatoIcons
++import Gato.GatoSystemConfiguration
# put someplace else
def WMExtrasGeometry(window):
-@@ -67,7 +66,7 @@
-
- NOTE: Does not work with tk8.0 style menus, since those are
- handled by WM (according to Tk8.1 docs) """
-- g = regsub.split(window.geometry(),"+")
-+ g = re.split("\+", window.geometry())
- trueRootx = string.atoi(g[1])
- trueRooty = string.atoi(g[2])
-
-@@ -1159,11 +1158,11 @@
+@@ -1397,11 +1397,11 @@
self.algoGlobals['A'] = self.GUI.graphDisplay
# XXX
# explictely loading packages we want to make available to the algorithm
diff --git a/math/py-gato/files/patch-GatoUtil.py b/math/py-gato/files/patch-GatoUtil.py
deleted file mode 100644
index 7cdcf9b766a1..000000000000
--- a/math/py-gato/files/patch-GatoUtil.py
+++ /dev/null
@@ -1,13 +0,0 @@
---- GatoUtil.py.orig Wed May 16 13:16:56 2001
-+++ GatoUtil.py Mon Sep 3 12:14:42 2001
-@@ -40,8 +40,8 @@
-
- def extension(pathAndFile):
- """ Return ext if path/filename.ext is given """
-- import regsub
-- return regsub.split(stripPath(pathAndFile),"\.")[1]
-+ import re
-+ return re.split("\.", stripPath(pathAndFile))[1]
-
- def stripPath(pathAndFile):
- """ Return filename.ext if path/filename.ext is given """
diff --git a/math/py-gato/files/patch-Graph.py b/math/py-gato/files/patch-Graph.py
deleted file mode 100644
index 6d0e4937efbf..000000000000
--- a/math/py-gato/files/patch-Graph.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- Graph.py.orig Wed May 16 13:16:57 2001
-+++ Graph.py Fri Aug 31 17:12:01 2001
-@@ -31,7 +31,7 @@
- #
- ################################################################################
-
--from regsub import split
-+from re import split
- from GatoGlobals import *
- from DataStructures import Point2D, VertexLabeling, EdgeLabeling, EdgeWeight
- from math import log
diff --git a/math/py-gato/files/patch-GraphUtil.py b/math/py-gato/files/patch-GraphUtil.py
index 8c652aaaee22..fe744b91e881 100644
--- a/math/py-gato/files/patch-GraphUtil.py
+++ b/math/py-gato/files/patch-GraphUtil.py
@@ -1,14 +1,5 @@
--- GraphUtil.py.orig Wed May 16 13:16:58 2001
+++ GraphUtil.py Mon Sep 3 12:21:49 2001
-@@ -31,7 +31,7 @@
- #
- ################################################################################
-
--from regsub import split
-+from re import split
- from GatoGlobals import *
- from Graph import Graph
- from DataStructures import Point2D, VertexLabeling, EdgeLabeling, EdgeWeight, VertexWeight, Queue
@@ -223,13 +223,13 @@
break
diff --git a/math/py-gato/files/patch-Gred.py b/math/py-gato/files/patch-Gred.py
index cc10c754f8cd..0eb1005f69ca 100644
--- a/math/py-gato/files/patch-Gred.py
+++ b/math/py-gato/files/patch-Gred.py
@@ -1,32 +1,33 @@
---- Gred.py.orig Wed May 16 13:16:58 2001
-+++ Gred.py Mon Sep 3 12:01:13 2001
-@@ -31,16 +31,16 @@
+--- Gred.py.orig Fri Dec 5 13:08:46 2003
++++ Gred.py Thu Dec 18 00:43:24 2003
+@@ -34,17 +34,17 @@
# last change by $Author: schliep $.
#
################################################################################
+-from GatoGlobals import *
+-import GatoGlobals # Needed for help viewer.XXX
-from Graph import Graph
-from DataStructures import EdgeWeight, VertexWeight
-from GraphUtil import OpenCATBoxGraph, OpenGMLGraph, SaveCATBoxGraph, WeightedGraphInformer
-from GraphEditor import GraphEditor
++from Gato.GatoGlobals import *
++import Gato.GatoGlobals # Needed for help viewer.XXX
+from Gato.Graph import Graph
+from Gato.DataStructures import EdgeWeight, VertexWeight
+from Gato.GraphUtil import OpenCATBoxGraph, OpenGMLGraph, SaveCATBoxGraph, WeightedGraphInformer
+from Gato.GraphEditor import GraphEditor
from Tkinter import *
+ import tkFont
-from GatoUtil import stripPath, extension, gatoPath
--from GatoGlobals import *
-import GatoDialogs
--import GatoGlobals
-import GatoIcons
+from Gato.GatoUtil import stripPath, extension, gatoPath
-+from Gato.GatoGlobals import *
+from Gato import GatoDialogs
-+from Gato import GatoGlobals
+from Gato import GatoIcons
from ScrolledText import *
from tkFileDialog import askopenfilename, asksaveasfilename
-@@ -51,7 +51,8 @@
+@@ -55,7 +55,8 @@
import sys
import os
diff --git a/math/py-gato/pkg-plist b/math/py-gato/pkg-plist
index 274d75c61fba..14af193aead0 100644
--- a/math/py-gato/pkg-plist
+++ b/math/py-gato/pkg-plist
@@ -14,18 +14,30 @@ lib/%%PYTHON_VERSION%%/site-packages/Gato/AnimatedDataStructures.pyo
lib/%%PYTHON_VERSION%%/site-packages/Gato/DataStructures.py
lib/%%PYTHON_VERSION%%/site-packages/Gato/DataStructures.pyc
lib/%%PYTHON_VERSION%%/site-packages/Gato/DataStructures.pyo
+lib/%%PYTHON_VERSION%%/site-packages/Gato/EditObjectAttributesDialog.py
+lib/%%PYTHON_VERSION%%/site-packages/Gato/EditObjectAttributesDialog.pyc
+lib/%%PYTHON_VERSION%%/site-packages/Gato/EditObjectAttributesDialog.pyo
lib/%%PYTHON_VERSION%%/site-packages/Gato/Embedder.py
lib/%%PYTHON_VERSION%%/site-packages/Gato/Embedder.pyc
lib/%%PYTHON_VERSION%%/site-packages/Gato/Embedder.pyo
+lib/%%PYTHON_VERSION%%/site-packages/Gato/GatoConfiguration.py
+lib/%%PYTHON_VERSION%%/site-packages/Gato/GatoConfiguration.pyc
+lib/%%PYTHON_VERSION%%/site-packages/Gato/GatoConfiguration.pyo
lib/%%PYTHON_VERSION%%/site-packages/Gato/GatoDialogs.py
lib/%%PYTHON_VERSION%%/site-packages/Gato/GatoDialogs.pyc
lib/%%PYTHON_VERSION%%/site-packages/Gato/GatoDialogs.pyo
+lib/%%PYTHON_VERSION%%/site-packages/Gato/GatoFile.py
+lib/%%PYTHON_VERSION%%/site-packages/Gato/GatoFile.pyc
+lib/%%PYTHON_VERSION%%/site-packages/Gato/GatoFile.pyo
lib/%%PYTHON_VERSION%%/site-packages/Gato/GatoGlobals.py
lib/%%PYTHON_VERSION%%/site-packages/Gato/GatoGlobals.pyc
lib/%%PYTHON_VERSION%%/site-packages/Gato/GatoGlobals.pyo
lib/%%PYTHON_VERSION%%/site-packages/Gato/GatoIcons.py
lib/%%PYTHON_VERSION%%/site-packages/Gato/GatoIcons.pyc
lib/%%PYTHON_VERSION%%/site-packages/Gato/GatoIcons.pyo
+lib/%%PYTHON_VERSION%%/site-packages/Gato/GatoSystemConfiguration.py
+lib/%%PYTHON_VERSION%%/site-packages/Gato/GatoSystemConfiguration.pyc
+lib/%%PYTHON_VERSION%%/site-packages/Gato/GatoSystemConfiguration.pyo
lib/%%PYTHON_VERSION%%/site-packages/Gato/GatoTest.py
lib/%%PYTHON_VERSION%%/site-packages/Gato/GatoTest.pyc
lib/%%PYTHON_VERSION%%/site-packages/Gato/GatoTest.pyo
@@ -53,6 +65,15 @@ lib/%%PYTHON_VERSION%%/site-packages/Gato/PlanarEmbedding.pyo
lib/%%PYTHON_VERSION%%/site-packages/Gato/PlanarityTest.py
lib/%%PYTHON_VERSION%%/site-packages/Gato/PlanarityTest.pyc
lib/%%PYTHON_VERSION%%/site-packages/Gato/PlanarityTest.pyo
+lib/%%PYTHON_VERSION%%/site-packages/Gato/TextTreeWidget.py
+lib/%%PYTHON_VERSION%%/site-packages/Gato/TextTreeWidget.pyc
+lib/%%PYTHON_VERSION%%/site-packages/Gato/TextTreeWidget.pyo
+lib/%%PYTHON_VERSION%%/site-packages/Gato/TreeWidget.py
+lib/%%PYTHON_VERSION%%/site-packages/Gato/TreeWidget.pyc
+lib/%%PYTHON_VERSION%%/site-packages/Gato/TreeWidget.pyo
+lib/%%PYTHON_VERSION%%/site-packages/Gato/logging.py
+lib/%%PYTHON_VERSION%%/site-packages/Gato/logging.pyc
+lib/%%PYTHON_VERSION%%/site-packages/Gato/logging.pyo
lib/%%PYTHON_VERSION%%/site-packages/Gato/__init__.py
lib/%%PYTHON_VERSION%%/site-packages/Gato/__init__.pyc
lib/%%PYTHON_VERSION%%/site-packages/Gato/__init__.pyo