aboutsummaryrefslogtreecommitdiff
path: root/math/py-gmpy2
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2016-06-14 08:21:12 +0000
committerWen Heping <wen@FreeBSD.org>2016-06-14 08:21:12 +0000
commitce6138213f3c7e2cbef51f40deabe72745cc45e3 (patch)
tree5c5025cae5eb19d9bda657d78d90e2e46e9aac2f /math/py-gmpy2
parent3624e2cf23042eb6544edcc6ed257d3ee442db54 (diff)
downloadports-ce6138213f3c7e2cbef51f40deabe72745cc45e3.tar.gz
ports-ce6138213f3c7e2cbef51f40deabe72745cc45e3.zip
C-coded Python extension module that supports multiple-precision arithmetic.
In addition to supporting GMP or MPIR for multiple-precision integer and rational arithmetic, gmpy2 adds support for the MPFR (correctly rounded real floating-point arithmetic) and MPC (correctly rounded complex floating-point arithmetic) libraries. WWW: https://pypi.python.org/pypi/gmpy2 WWW: https://github.com/aleaxit/gmpy/releases PR: 210127 Submitted by: yuri@rawbw.com
Notes
Notes: svn path=/head/; revision=416879
Diffstat (limited to 'math/py-gmpy2')
-rw-r--r--math/py-gmpy2/Makefile25
-rw-r--r--math/py-gmpy2/distinfo3
-rw-r--r--math/py-gmpy2/pkg-descr8
3 files changed, 36 insertions, 0 deletions
diff --git a/math/py-gmpy2/Makefile b/math/py-gmpy2/Makefile
new file mode 100644
index 000000000000..a13292d3840e
--- /dev/null
+++ b/math/py-gmpy2/Makefile
@@ -0,0 +1,25 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= gmpy2
+PORTVERSION= 2.0.7
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= GMP/MPIR, MPFR, and MPC interface to Python
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= libgmp.so:math/gmp \
+ libmpc.so:math/mpc \
+ libmpfr.so:math/mpfr
+
+USES= python:2 zip
+USE_PYTHON= distutils autoplist
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/gmpy2.so
+
+.include <bsd.port.mk>
diff --git a/math/py-gmpy2/distinfo b/math/py-gmpy2/distinfo
new file mode 100644
index 000000000000..7774ebec7156
--- /dev/null
+++ b/math/py-gmpy2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1465375777
+SHA256 (gmpy2-2.0.7.zip) = 7ee694b8a4c3854f27890676aa8a509a2e3f8dbdd0916fa94cbed612420b9c86
+SIZE (gmpy2-2.0.7.zip) = 280400
diff --git a/math/py-gmpy2/pkg-descr b/math/py-gmpy2/pkg-descr
new file mode 100644
index 000000000000..a2466f294ed1
--- /dev/null
+++ b/math/py-gmpy2/pkg-descr
@@ -0,0 +1,8 @@
+C-coded Python extension module that supports multiple-precision arithmetic.
+In addition to supporting GMP or MPIR for multiple-precision integer and
+rational arithmetic, gmpy2 adds support for the MPFR (correctly rounded real
+floating-point arithmetic) and MPC (correctly rounded complex floating-point
+arithmetic) libraries.
+
+WWW: https://pypi.python.org/pypi/gmpy2
+WWW: https://github.com/aleaxit/gmpy/releases