aboutsummaryrefslogtreecommitdiff
path: root/math/py-heyoka
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-12-21 09:04:54 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-12-21 11:01:51 +0000
commit157b2563d1af3cc883bf262172fa9be96950dd79 (patch)
tree2ca97f6666fcec7645d8c1a67076bfcf5454ec0f /math/py-heyoka
parenta1fdb33ba4d91934a812ea24250a95273a397e01 (diff)
downloadports-157b2563d1af3cc883bf262172fa9be96950dd79.tar.gz
ports-157b2563d1af3cc883bf262172fa9be96950dd79.zip
math/py-heyoka: Update 0.19.0 -> 0.20.0
Reported by: portscout
Diffstat (limited to 'math/py-heyoka')
-rw-r--r--math/py-heyoka/Makefile5
-rw-r--r--math/py-heyoka/distinfo6
-rw-r--r--math/py-heyoka/files/patch-CMakeLists.txt21
-rw-r--r--math/py-heyoka/pkg-plist3
4 files changed, 19 insertions, 16 deletions
diff --git a/math/py-heyoka/Makefile b/math/py-heyoka/Makefile
index c8a0c52b1e12..8218a6cb2809 100644
--- a/math/py-heyoka/Makefile
+++ b/math/py-heyoka/Makefile
@@ -1,7 +1,6 @@
PORTNAME= heyoka
DISTVERSIONPREFIX= v
-DISTVERSION= 0.19.0
-PORTREVISION= 4
+DISTVERSION= 0.20.0
CATEGORIES= math
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,8 +15,10 @@ BUILD_DEPENDS= pybind11>0:devel/pybind11 \
${PYNUMPY}
LIB_DEPENDS= libboost_serialization.so:devel/boost-libs \
libfmt.so:devel/libfmt \
+ libgmp.so:math/gmp \
libheyoka.so:math/heyoka \
libmp++.so:math/mppp \
+ libmpfr.so:math/mpfr \
libtbb.so:devel/onetbb \
libspdlog.so:devel/spdlog
RUN_DEPENDS= ${PYNUMPY} \
diff --git a/math/py-heyoka/distinfo b/math/py-heyoka/distinfo
index 2fc1dd2f9d27..72aeb542d8ff 100644
--- a/math/py-heyoka/distinfo
+++ b/math/py-heyoka/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1663734102
-SHA256 (bluescarni-heyoka.py-v0.19.0_GH0.tar.gz) = 5191a6976fe89f14c6cde0d69607397db059009fecb0a3390c4b33c29e5d31ea
-SIZE (bluescarni-heyoka.py-v0.19.0_GH0.tar.gz) = 101947693
+TIMESTAMP = 1671607325
+SHA256 (bluescarni-heyoka.py-v0.20.0_GH0.tar.gz) = 65c90a5ffb870b4d2d19eef066b56964777f03eb7d081e331ae5bf903bbf94af
+SIZE (bluescarni-heyoka.py-v0.20.0_GH0.tar.gz) = 102109366
diff --git a/math/py-heyoka/files/patch-CMakeLists.txt b/math/py-heyoka/files/patch-CMakeLists.txt
index 09dff89eed8a..06441196fc2e 100644
--- a/math/py-heyoka/files/patch-CMakeLists.txt
+++ b/math/py-heyoka/files/patch-CMakeLists.txt
@@ -1,16 +1,15 @@
---- CMakeLists.txt.orig 2022-09-19 07:53:52 UTC
+--- CMakeLists.txt.orig 2022-12-18 12:54:30 UTC
+++ CMakeLists.txt
-@@ -144,7 +144,7 @@ else()
- # and Python3 is *not* found, we try again, this time with the full Development
- # component (rather than only Development.Module). This seems to work around the
- # issue, for now at least.
-- find_package(Python3 QUIET COMPONENTS ${_HEYOKA_PY_PYTHON3_COMPONENTS})
-+ find_package(Python3 ${FREEBSD_PYTHON_DISTVERSION} QUIET COMPONENTS ${_HEYOKA_PY_PYTHON3_COMPONENTS})
+@@ -140,14 +140,14 @@ set(_HEYOKA_PY_PYTHON3_COMPONENTS Interpreter NumPy De
+ # and Python3 is *not* found, we try again, this time with the full Development
+ # component (rather than only Development.Module). This seems to work around the
+ # issue, for now at least.
+-find_package(Python3 QUIET COMPONENTS ${_HEYOKA_PY_PYTHON3_COMPONENTS})
++find_package(Python3 ${FREEBSD_PYTHON_DISTVERSION} QUIET COMPONENTS ${_HEYOKA_PY_PYTHON3_COMPONENTS})
- if(NOT Python3_FOUND)
- list(POP_BACK _HEYOKA_PY_PYTHON3_COMPONENTS)
-@@ -152,7 +152,7 @@ else()
- endif()
+ if(NOT Python3_FOUND)
+ list(POP_BACK _HEYOKA_PY_PYTHON3_COMPONENTS)
+ list(APPEND _HEYOKA_PY_PYTHON3_COMPONENTS Development)
endif()
-find_package(Python3 QUIET REQUIRED COMPONENTS ${_HEYOKA_PY_PYTHON3_COMPONENTS})
diff --git a/math/py-heyoka/pkg-plist b/math/py-heyoka/pkg-plist
index 092e2fff0539..22ca7351b0c3 100644
--- a/math/py-heyoka/pkg-plist
+++ b/math/py-heyoka/pkg-plist
@@ -1,6 +1,9 @@
%%PYTHON_SITELIBDIR%%/heyoka/__init__.py
%%PYTHON_SITELIBDIR%%/heyoka/_ensemble_impl.py
%%PYTHON_SITELIBDIR%%/heyoka/_sympy_utils.py
+%%PYTHON_SITELIBDIR%%/heyoka/_test_mp.py
+%%PYTHON_SITELIBDIR%%/heyoka/_test_real.py
+%%PYTHON_SITELIBDIR%%/heyoka/_test_real128.py
%%PYTHON_SITELIBDIR%%/heyoka/_version.py
%%PYTHON_SITELIBDIR%%/heyoka/core%%PYTHON_EXT_SUFFIX%%.so
%%PYTHON_SITELIBDIR%%/heyoka/test.py