aboutsummaryrefslogtreecommitdiff
path: root/math/py-mathics
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2023-01-20 18:00:29 +0000
committerThierry Thomas <thierry@FreeBSD.org>2023-01-20 18:02:23 +0000
commitd9acc3ed3059b08c85a6d6d1684747607b035671 (patch)
tree847270cc67339fe63f870486100faef96e9e0699 /math/py-mathics
parent32e1b7c5c2d2736be32416862ecd0b0a16992c57 (diff)
downloadports-d9acc3ed3059b08c85a6d6d1684747607b035671.tar.gz
ports-d9acc3ed3059b08c85a6d6d1684747607b035671.zip
math/py-mathics: allow to run with sympy-1.11.1
Diffstat (limited to 'math/py-mathics')
-rw-r--r--math/py-mathics/Makefile2
-rw-r--r--math/py-mathics/files/patch-Mathics3.egg-info_requires.txt11
-rw-r--r--math/py-mathics/files/patch-setup.py11
3 files changed, 23 insertions, 1 deletions
diff --git a/math/py-mathics/Makefile b/math/py-mathics/Makefile
index 5f4c3a92c00a..5ab3bc487f85 100644
--- a/math/py-mathics/Makefile
+++ b/math/py-mathics/Makefile
@@ -1,6 +1,6 @@
PORTNAME= Mathics3
PORTVERSION= 5.0.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/math/py-mathics/files/patch-Mathics3.egg-info_requires.txt b/math/py-mathics/files/patch-Mathics3.egg-info_requires.txt
new file mode 100644
index 000000000000..76492469ca4e
--- /dev/null
+++ b/math/py-mathics/files/patch-Mathics3.egg-info_requires.txt
@@ -0,0 +1,11 @@
+--- Mathics3.egg-info/requires.txt.orig 2022-08-06 09:38:06 UTC
++++ Mathics3.egg-info/requires.txt
+@@ -1,7 +1,7 @@
+ Mathics-Scanner<1.3.0,>=1.2.1
+ numpy
+ llvmlite
+-sympy<1.11,>=1.8
++sympy<1.11.2,>=1.8
+ recordclass
+ Mathics_Scanner<1.3.0,>=1.2.1
+ mpmath>=1.2.0
diff --git a/math/py-mathics/files/patch-setup.py b/math/py-mathics/files/patch-setup.py
new file mode 100644
index 000000000000..0b3460f039fa
--- /dev/null
+++ b/math/py-mathics/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2023-01-20 17:32:12 UTC
++++ setup.py
+@@ -57,7 +57,7 @@ elif sys.version_info[:2] == (3, 6):
+ elif sys.version_info[:2] == (3, 7):
+ INSTALL_REQUIRES += ["numpy<1.22", "llvmlite", "sympy>=1.8, < 1.11"]
+ else:
+- INSTALL_REQUIRES += ["numpy", "llvmlite", "sympy>=1.8, < 1.11"]
++ INSTALL_REQUIRES += ["numpy", "llvmlite", "sympy>=1.8, < 1.11.2"]
+
+ if not is_PyPy:
+ INSTALL_REQUIRES += ["recordclass"]