aboutsummaryrefslogtreecommitdiff
path: root/math/py-matplotlib/Makefile
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2008-05-07 04:43:35 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2008-05-07 04:43:35 +0000
commita07f700bb5c04bfd35de0b0ef16720f2a4c27374 (patch)
tree920b3d04e4cfc8d0529eb50067038721e3bafce2 /math/py-matplotlib/Makefile
parent8c371366605c61946980acb0d866a4dafabeb656 (diff)
downloadports-a07f700bb5c04bfd35de0b0ef16720f2a4c27374.tar.gz
ports-a07f700bb5c04bfd35de0b0ef16720f2a4c27374.zip
- Update to 0.91.2 [1]
- portlint fix - Respect NOPORTEXAMPLES PR: ports/121893 Submitted by: Geoffrey Mainland <mainland AT apeiron.net> (maintainer)
Notes
Notes: svn path=/head/; revision=212771
Diffstat (limited to 'math/py-matplotlib/Makefile')
-rw-r--r--math/py-matplotlib/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/math/py-matplotlib/Makefile b/math/py-matplotlib/Makefile
index 49bdd7a02f00..28157e18fbbc 100644
--- a/math/py-matplotlib/Makefile
+++ b/math/py-matplotlib/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= matplotlib
-PORTVERSION= 0.90.0
-PORTREVISION= 1
+PORTVERSION= 0.91.2
CATEGORIES= math python
MASTER_SITES= SF
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,14 +15,14 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= mainland@apeiron.net
COMMENT= A plotting library uses a syntax familiar to matlab users
-BUILD_DEPENDS= ${PYNUMERIC} \
+BUILD_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}dateutil>=1.4:${PORTSDIR}/devel/py-dateutil \
- ${PYTHON_SITELIBDIR}/${PYPYTZ_EGG}:${PORTSDIR}/devel/py-pytz \
+ ${PYTHON_PKGNAMEPREFIX}pytz>0:${PORTSDIR}/devel/py-pytz \
${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter \
${LOCALBASE}/lib/libagg.a:${PORTSDIR}/graphics/agg
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
png.5:${PORTSDIR}/graphics/png
-RUN_DEPENDS= ${PYNUMERIC} \
+RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
.if defined(PACKAGE_BUILDING)
BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT}
@@ -49,12 +48,10 @@ post-patch:
-e s,%%USE_TCL%%,${USE_TCL}, \
${WRKSRC}/setupext.py
+.if !defined(NOPORTEXAMPLES)
post-install:
@${MKDIR} ${EXAMPLESDIR}
${CP} -R ${WRKSRC}/examples/ ${EXAMPLESDIR}
+.endif
-.include <bsd.port.pre.mk>
-
-PYPYTZ_EGG!= ${MAKE} -f ${PORTSDIR}/devel/py-pytz/Makefile -V PYPYTZ_EGG
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>