aboutsummaryrefslogtreecommitdiff
path: root/math/py-matplotlib
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-04-02 02:42:10 +0000
committerWen Heping <wen@FreeBSD.org>2010-04-02 02:42:10 +0000
commitfee7bdbf419c48c701534206f45c53daea88b4d1 (patch)
tree64b8fa55a53a945b7faf7574cb1f13c917800dd0 /math/py-matplotlib
parentbf27e4ab7a0506b781af6b6bed159846bf2e260e (diff)
downloadports-fee7bdbf419c48c701534206f45c53daea88b4d1.tar.gz
ports-fee7bdbf419c48c701534206f45c53daea88b4d1.zip
- Update to 0.99.1.1
PR: ports/145259 Submitted by: Wen Heping (myself) Approved by: maintainer
Notes
Notes: svn path=/head/; revision=251988
Diffstat (limited to 'math/py-matplotlib')
-rw-r--r--math/py-matplotlib/Makefile10
-rw-r--r--math/py-matplotlib/distinfo6
-rw-r--r--math/py-matplotlib/files/patch-lib__matplotlib__afm.py11
-rw-r--r--math/py-matplotlib/pkg-plist4
4 files changed, 13 insertions, 18 deletions
diff --git a/math/py-matplotlib/Makefile b/math/py-matplotlib/Makefile
index 0c4fc20539ab..7de788e7dfce 100644
--- a/math/py-matplotlib/Makefile
+++ b/math/py-matplotlib/Makefile
@@ -7,11 +7,11 @@
#
PORTNAME= matplotlib
-PORTVERSION= 0.99.0
-PORTREVISION= 2
+PORTVERSION= 0.99.1.1
CATEGORIES= math python
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-0.99/
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-0.99.1/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTFILES= ${PORTNAME}-0.99.1.2.tar.gz
MAINTAINER= mainland@apeiron.net
COMMENT= A plotting library uses a syntax familiar to matlab users
@@ -35,7 +35,7 @@ USE_GNOME= gtk20 pygtk2
USE_TCL_RUN= yes
USE_TK_RUN= yes
CFLAGS+= -I${LOCALBASE}/include
-
+WRKSRC= ${WRKDIR}/${PORTNAME}-0.99.1.1
WANT_WX= 2.6
.include <bsd.port.pre.mk>
@@ -51,6 +51,8 @@ EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
post-patch:
${REINPLACE_CMD} -e 's|png_infopp_NULL|NULL|' \
${WRKSRC}/src/_png.cpp
+ ${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
+ ${WRKSRC}/setupext.py
.if !defined(NOPORTEXAMPLES)
post-install:
diff --git a/math/py-matplotlib/distinfo b/math/py-matplotlib/distinfo
index 0444acdb2482..86ccff026da5 100644
--- a/math/py-matplotlib/distinfo
+++ b/math/py-matplotlib/distinfo
@@ -1,3 +1,3 @@
-MD5 (matplotlib-0.99.0.tar.gz) = 8e019e17396e816cc2ef52843532e727
-SHA256 (matplotlib-0.99.0.tar.gz) = f85ec0f69fcfe2bb19700817f7683ce278461f22924971c7c99907374a4b332b
-SIZE (matplotlib-0.99.0.tar.gz) = 11762345
+MD5 (matplotlib-0.99.1.2.tar.gz) = 952e2c992e4a762b8538171f51c9140a
+SHA256 (matplotlib-0.99.1.2.tar.gz) = 6911814dd1d8c5b5fc3100e996f01721b102cce568414352496732a8e6e3908a
+SIZE (matplotlib-0.99.1.2.tar.gz) = 11940390
diff --git a/math/py-matplotlib/files/patch-lib__matplotlib__afm.py b/math/py-matplotlib/files/patch-lib__matplotlib__afm.py
deleted file mode 100644
index d82ba9daed08..000000000000
--- a/math/py-matplotlib/files/patch-lib__matplotlib__afm.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/matplotlib/afm.py.orig 2008-02-22 14:38:41.000000000 -0500
-+++ lib/matplotlib/afm.py 2008-02-22 14:39:40.000000000 -0500
-@@ -164,7 +164,7 @@
- num = _to_int(vals[0].split()[1])
- wx = _to_float(vals[1].split()[1])
- name = vals[2].split()[1]
-- bbox = _to_list_of_ints(vals[3][2:])
-+ bbox = _to_list_of_floats(vals[3][2:])
- # Workaround: If the character name is 'Euro', give it the corresponding
- # character code, according to WinAnsiEncoding (see PDF Reference).
- if name == 'Euro':
diff --git a/math/py-matplotlib/pkg-plist b/math/py-matplotlib/pkg-plist
index 6d87b536c61c..dd304798666b 100644
--- a/math/py-matplotlib/pkg-plist
+++ b/math/py-matplotlib/pkg-plist
@@ -538,10 +538,12 @@
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/animation/animation_blit_qt4.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/animation/animation_blit_tk.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/animation/animation_blit_wx.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/animation/animate_decay_tk_blit.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/animation/dynamic_collection.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/animation/dynamic_image_gtkagg.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/animation/dynamic_image_wxagg2.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/animation/gtk_timeout.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/animation/histogram_tkagg.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/animation/movie_demo.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/animation/simple_anim_gtk.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/animation/simple_anim_tkagg.py
@@ -566,6 +568,7 @@
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/api/font_family_rc.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/api/font_file.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/api/histogram_demo.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/api/histogram_path_demo.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/api/image_zcoord.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/api/joinstyle.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/api/legend_demo.py
@@ -630,6 +633,7 @@
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/event_handling/idle_and_timeout.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/event_handling/keypress_demo.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/event_handling/lasso_demo.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/event_handling/looking_glass.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/event_handling/path_editor.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/event_handling/pick_event_demo.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/event_handling/pick_event_demo2.py