aboutsummaryrefslogtreecommitdiff
path: root/math/py-networkx1
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2019-01-13 17:36:49 +0000
committerMartin Wilke <miwi@FreeBSD.org>2019-01-13 17:36:49 +0000
commit2bca5ef0e99b0553689ff176a261e162cac1bcc0 (patch)
treee2b90edf0ea8096c295a0b7eb6d34a8322bab048 /math/py-networkx1
parent9abb4f251bc46abf2b71975faeb1cadb6fe665b5 (diff)
downloadports-2bca5ef0e99b0553689ff176a261e162cac1bcc0.tar.gz
ports-2bca5ef0e99b0553689ff176a261e162cac1bcc0.zip
- Copy math/py-networkx to math/py-networkx1 and applies modifications to
backport it to the latest version of the 1.x branch -> 1.11 - Adds CONFLICTS_INSTALL to math/py-networkx (no bump of PORTVERSION) and math/py-networkx1 - math/py-networkx1 is required by the package devel/py-taskflow that is not compatible with math/py-network PR: 232240 Submitted by: freebsd_ports@k-worx.org Sponsored by: iXsystems Inc.
Notes
Notes: svn path=/head/; revision=490159
Diffstat (limited to 'math/py-networkx1')
-rw-r--r--math/py-networkx1/Makefile57
-rw-r--r--math/py-networkx1/distinfo3
-rw-r--r--math/py-networkx1/files/patch-setup.py38
-rw-r--r--math/py-networkx1/pkg-descr23
4 files changed, 121 insertions, 0 deletions
diff --git a/math/py-networkx1/Makefile b/math/py-networkx1/Makefile
new file mode 100644
index 000000000000..e3652a01be36
--- /dev/null
+++ b/math/py-networkx1/Makefile
@@ -0,0 +1,57 @@
+# Created by: dikshie
+# $FreeBSD$
+
+PORTNAME= networkx
+PORTVERSION= 1.11
+CATEGORIES= math python
+MASTER_SITES= http://networkx.lanl.gov/download/networkx/ \
+ CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 1
+
+MAINTAINER= freebsd_ports@k-worx.org
+COMMENT= Tools for complex networks / Backported version
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}decorator>=3.4.0:devel/py-decorator@${PY_FLAVOR}
+
+USES= python shebangfix
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+PORTSCOUT= limit:^1\.
+PORTEXAMPLES= *
+SHEBANG_FILES= examples/graph/atlas.py \
+ examples/multigraph/chess_masters.py \
+ networkx/generators/tests/test_random_graphs.py
+
+CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}py-networkx
+
+OPTIONS_DEFINE= EXAMPLES YAML
+OPTIONS_GROUP= MATRIX RENDER
+OPTIONS_GROUP_MATRIX= NUMPY SCIPY
+OPTIONS_GROUP_RENDER= GRAPHVIZ MPL
+OPTIONS_DEFAULT= GRAPHVIZ MPL NUMPY SCIPY YAML
+
+GRAPHVIZ_DESC= Additional graph layout and rendering algorithms
+GRAPHVIZ_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pygraphviz>=1.2:graphics/py-pygraphviz@${PY_FLAVOR}
+
+MPL_DESC= Flexible graph rendering
+MPL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}matplotlib>=1.4.0:math/py-matplotlib@${PY_FLAVOR}
+
+NUMPY_DESC= Matrix representation of graphs
+NUMPY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.9.2,1:math/py-numpy@${PY_FLAVOR}
+
+SCIPY_DESC= Sparse matrix representation of graphs
+SCIPY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}scipy>=0.15.1:science/py-scipy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scikit-sparse>=0.2:science/py-scikit-sparse@${PY_FLAVOR}
+
+YAML_DESC= Reading and writing YAML files
+YAML_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>=0:devel/py-yaml@${PY_FLAVOR}
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/math/py-networkx1/distinfo b/math/py-networkx1/distinfo
new file mode 100644
index 000000000000..9b835db8bc24
--- /dev/null
+++ b/math/py-networkx1/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1539454780
+SHA256 (networkx-1.11.tar.gz) = 0d0e70e10dfb47601cbb3425a00e03e2a2e97477be6f80638fef91d54dd1e4b8
+SIZE (networkx-1.11.tar.gz) = 1315737
diff --git a/math/py-networkx1/files/patch-setup.py b/math/py-networkx1/files/patch-setup.py
new file mode 100644
index 000000000000..e9450c7172b7
--- /dev/null
+++ b/math/py-networkx1/files/patch-setup.py
@@ -0,0 +1,38 @@
+--- setup.py.orig 2015-12-26 17:06:48 UTC
++++ setup.py
+@@ -59,27 +59,6 @@ packages=["networkx",
+ "networkx.testing",
+ "networkx.utils"]
+
+-docdirbase = 'share/doc/networkx-%s' % version
+-# add basic documentation
+-data = [(docdirbase, glob("*.txt"))]
+-# add examples
+-for d in ['advanced',
+- 'algorithms',
+- 'basic',
+- '3d_drawing',
+- 'drawing',
+- 'graph',
+- 'multigraph',
+- 'pygraphviz',
+- 'readwrite']:
+- dd = os.path.join(docdirbase,'examples', d)
+- pp = os.path.join('examples', d)
+- data.append((dd, glob(os.path.join(pp ,"*.py"))))
+- data.append((dd, glob(os.path.join(pp ,"*.bz2"))))
+- data.append((dd, glob(os.path.join(pp ,"*.gz"))))
+- data.append((dd, glob(os.path.join(pp ,"*.mbox"))))
+- data.append((dd, glob(os.path.join(pp ,"*.edgelist"))))
+-
+ # add the tests
+ package_data = {
+ 'networkx': ['tests/*.py'],
+@@ -131,7 +110,6 @@ if __name__ == "__main__":
+ download_url = release.download_url,
+ classifiers = release.classifiers,
+ packages = packages,
+- data_files = data,
+ package_data = package_data,
+ install_requires = install_requires,
+ test_suite = 'nose.collector',
diff --git a/math/py-networkx1/pkg-descr b/math/py-networkx1/pkg-descr
new file mode 100644
index 000000000000..963707866848
--- /dev/null
+++ b/math/py-networkx1/pkg-descr
@@ -0,0 +1,23 @@
+NetworkX (NX) is a Python package for the creation, manipulation, and
+study of the structure, dynamics, and functions of complex networks.
+Features:
+* Includes standard graph-theoretic and statistical physics functions
+* Easy exchange of network algorithms between applications, disciplines,
+ and platforms
+* Includes many classic graphs and synthetic networks
+* Nodes and edges can be "anything" (e.g. time-series, text, images,
+ XML records)
+* Exploits existing code from high-quality legacy software in C, C++,
+ Fortran, etc.
+* Open source (encourages community input)
+* Unit-tested
+
+Additional benefits due to Python:
+* Allows fast prototyping of new algorithms
+* Easy to teach
+* Multi-platform
+* Allows easy access to almost any database
+
+Note: This is a backported version of the 1.x branch.
+
+WWW: https://networkx.github.io/