aboutsummaryrefslogtreecommitdiff
path: root/math/py-nevergrad/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-05-08 20:53:07 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-05-08 20:53:07 +0000
commit66df43bfe37a10457eeccb160e9095474b94da12 (patch)
tree2db7a42287da432b43b39004f50dc8eb65f2c4c4 /math/py-nevergrad/Makefile
parentbe89f88294c8277e6f1b215df013885e79d2d3ab (diff)
downloadports-66df43bfe37a10457eeccb160e9095474b94da12.tar.gz
ports-66df43bfe37a10457eeccb160e9095474b94da12.zip
Update to 0.4.1
Notes
Notes: svn path=/head/; revision=534455
Diffstat (limited to 'math/py-nevergrad/Makefile')
-rw-r--r--math/py-nevergrad/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/math/py-nevergrad/Makefile b/math/py-nevergrad/Makefile
index d86b14aae69d..8c66efaa64b9 100644
--- a/math/py-nevergrad/Makefile
+++ b/math/py-nevergrad/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= nevergrad
-PORTVERSION= 0.4.0
+PORTVERSION= 0.4.1
CATEGORIES= math python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,9 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bayesian-optimization>=1.1.0:math/py-bayesian-optimization@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}cma>=2.6.0:math/py-cma@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}hiplot>=0:graphics/py-hiplot@${PY_FLAVOR} \
- ${PYNUMPY} \
- ${PYTHON_PKGNAMEPREFIX}pandas>=0.23.4:math/py-pandas@${PY_FLAVOR}
+ ${PYNUMPY}
USES= python:3.6+
USE_PYTHON= autoplist distutils
@@ -29,8 +27,12 @@ OPTIONS_DEFAULT=BENCHMARK
BENCHMARK_DESC= Run benchmark functions
BENCHMARK_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gym>=0.12.1:math/py-gym@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}hiplot>=0:graphics/py-hiplot@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}matplotlib>=2.2.3:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>=0.23.4:math/py-pandas@${PY_FLAVOR} \
+ ${PY_PILLOW} \
${PYTHON_PKGNAMEPREFIX}requests>=2.21.0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tqdm>=0:misc/py-tqdm@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}xlrd>=1.2.0:textproc/py-xlrd@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}xlwt>=1.3.0:textproc/py-xlwt@${PY_FLAVOR}