aboutsummaryrefslogtreecommitdiff
path: root/math/py-nevergrad
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-03-21 19:40:05 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-03-21 19:40:05 +0000
commit6c1c1ce868a83e9a02a4ddad04dc9bc5e62dd790 (patch)
tree3d8b38df3b28c96a7c784ea3708a3ba35c75c6f5 /math/py-nevergrad
parent5e6e554bb95c50b788c7b922af3c306ca9bb0f9c (diff)
downloadports-6c1c1ce868a83e9a02a4ddad04dc9bc5e62dd790.tar.gz
ports-6c1c1ce868a83e9a02a4ddad04dc9bc5e62dd790.zip
Add py-nevergrad 0.1.6
Nevergrad is a gradient-free optimization platform. The goals of this package are to provide: - gradient/derivative-free optimization algorithms, including algorithms able to handle noise. - tools to instrument any code, making it painless to optimize your parameters/hyperparameters, whether they are continuous, discrete or a mixture of continuous and discrete variables. - functions on which to test the optimization algorithms. - benchmark routines in order to compare algorithms easily. WWW: https://github.com/facebookresearch/nevergrad
Notes
Notes: svn path=/head/; revision=496485
Diffstat (limited to 'math/py-nevergrad')
-rw-r--r--math/py-nevergrad/Makefile36
-rw-r--r--math/py-nevergrad/distinfo3
-rw-r--r--math/py-nevergrad/pkg-descr12
3 files changed, 51 insertions, 0 deletions
diff --git a/math/py-nevergrad/Makefile b/math/py-nevergrad/Makefile
new file mode 100644
index 000000000000..311dcd61932e
--- /dev/null
+++ b/math/py-nevergrad/Makefile
@@ -0,0 +1,36 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= nevergrad
+PORTVERSION= 0.1.6
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python toolbox for performing gradient-free optimization
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bayesian-optimization>=0.6.0:math/py-bayesian-optimization@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cma>=2.6.0:math/py-cma@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>=2.2.3:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}numpy>=1.15.0:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>=0.23.4:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.21.0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}xlrd>=1.2.0:textproc/py-xlrd@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}xlwt>=1.3.0:textproc/py-xlwt@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3700
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}typing-extensions>=3.6.6:devel/py-typing-extensions@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/py-nevergrad/distinfo b/math/py-nevergrad/distinfo
new file mode 100644
index 000000000000..8a598d49abde
--- /dev/null
+++ b/math/py-nevergrad/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1553188278
+SHA256 (nevergrad-0.1.6.tar.gz) = ffc900006535aa5590ed04f359d4a141e59ce3ec4245ef3740f9057daf8abb45
+SIZE (nevergrad-0.1.6.tar.gz) = 103150
diff --git a/math/py-nevergrad/pkg-descr b/math/py-nevergrad/pkg-descr
new file mode 100644
index 000000000000..2b728d063391
--- /dev/null
+++ b/math/py-nevergrad/pkg-descr
@@ -0,0 +1,12 @@
+Nevergrad is a gradient-free optimization platform.
+
+The goals of this package are to provide:
+- gradient/derivative-free optimization algorithms, including algorithms able to
+ handle noise.
+- tools to instrument any code, making it painless to optimize your
+ parameters/hyperparameters, whether they are continuous, discrete or a mixture
+ of continuous and discrete variables.
+- functions on which to test the optimization algorithms.
+- benchmark routines in order to compare algorithms easily.
+
+WWW: https://github.com/facebookresearch/nevergrad