aboutsummaryrefslogtreecommitdiff
path: root/math/py-numarray/Makefile
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2003-07-31 20:28:33 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2003-07-31 20:28:33 +0000
commit5fec7c98b7960e2cb206e333d64948b1170da6a5 (patch)
tree83bae5052a1696b9e53443a4fd823371dac8c79a /math/py-numarray/Makefile
parent095534c8b6bc0336c112ef5ec15495ba8ac3cb79 (diff)
downloadports-5fec7c98b7960e2cb206e333d64948b1170da6a5.tar.gz
ports-5fec7c98b7960e2cb206e333d64948b1170da6a5.zip
- Update to 0.6.1
- Update WWW URL - Use DOCSDIR and EXAMPLESDIR
Notes
Notes: svn path=/head/; revision=86078
Diffstat (limited to 'math/py-numarray/Makefile')
-rw-r--r--math/py-numarray/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/math/py-numarray/Makefile b/math/py-numarray/Makefile
index aa9e647842fa..414d2568de76 100644
--- a/math/py-numarray/Makefile
+++ b/math/py-numarray/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= numarray
-PORTVERSION= 0.6
+PORTVERSION= 0.6.1
CATEGORIES= math python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= numpy
@@ -18,9 +18,8 @@ COMMENT= Numeric array manipulation extension module for Python
USE_PYTHON= yes
USE_PYDISTUTILS=yes
NO_BUILD= yes # setup.py doesn't work as expected for 'build' target.
-
-DOCDIR= ${PREFIX}/share/doc/py-numarray
-EXAMPLEDIR= ${PREFIX}/share/examples/py-numarray
+PLIST_SUB= DOCSDIR=${DOCSDIR:S,${PREFIX}/,,} \
+ EXAMPLESDIR=${EXAMPLESDIR:S,${PREFIX}/,,}
post-extract:
cd ${WRKSRC} && \
@@ -29,9 +28,9 @@ post-extract:
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCDIR} ${EXAMPLEDIR}
- @${TAR} -C ${WRKSRC}/Doc -cf- .|${TAR} -C ${DOCDIR} -xf-
- @${TAR} -C ${WRKSRC}/Examples -cf- .|${TAR} -C ${EXAMPLEDIR} -xf-
+ @${MKDIR} ${DOCSDIR} ${EXAMPLESDIR}
+ @${TAR} -C ${WRKSRC}/Doc -cf- .|${TAR} -C ${DOCSDIR} -xf-
+ @${TAR} -C ${WRKSRC}/Examples -cf- .|${TAR} -C ${EXAMPLESDIR} -xf-
.endif
.include <bsd.port.mk>