aboutsummaryrefslogtreecommitdiff
path: root/math/py-optuna
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2021-01-01 10:06:27 +0000
committerKurt Jaeger <pi@FreeBSD.org>2021-01-01 10:06:27 +0000
commit548f16bd1a2915f08878b716eed92ff3267e6de2 (patch)
tree4c4495a69f218c342b2b80557cc43c71e81dee7a /math/py-optuna
parent133905cbe53f6fd80c310a19664cf284d3e5914f (diff)
downloadports-548f16bd1a2915f08878b716eed92ff3267e6de2.tar.gz
ports-548f16bd1a2915f08878b716eed92ff3267e6de2.zip
New port: math/py-optuna: A hyperparameter optimization framework
Optuna is an automatic hyperparameter optimization software framework, particularly designed for machine learning. It features an imperative, define-by-run style user API. Thanks to our define-by-run API, the code written with Optuna enjoys high modularity, and the user of Optuna can dynamically construct the search spaces for the hyperparameters. WWW: https://optuna.org/ PR: 252151 Submitted by: Neel Chauhan <neel@neelc.org>
Notes
Notes: svn path=/head/; revision=559821
Diffstat (limited to 'math/py-optuna')
-rw-r--r--math/py-optuna/Makefile32
-rw-r--r--math/py-optuna/distinfo3
-rw-r--r--math/py-optuna/files/pkg-message.in9
-rw-r--r--math/py-optuna/pkg-descr7
4 files changed, 51 insertions, 0 deletions
diff --git a/math/py-optuna/Makefile b/math/py-optuna/Makefile
new file mode 100644
index 000000000000..ec73636a229d
--- /dev/null
+++ b/math/py-optuna/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= optuna
+DISTVERSION= 2.3.0
+CATEGORIES= math # machine-learning
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= neel@neelc.org
+COMMENT= Hyperparameter optimization framework
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}alembic>0:databases/py-alembic@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cliff>0:devel/py-cliff@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cmaes>0:math/py-cmaes@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}colorlog>0:devel/py-colorlog@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}joblib>0:devel/py-joblib@${PY_FLAVOR} \
+ ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}packaging>0:devel/py-packaging@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sqlalchemy12>0:databases/py-sqlalchemy12@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tqdm>0:misc/py-tqdm@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+SUB_FILES= pkg-message
+
+.include <bsd.port.mk>
diff --git a/math/py-optuna/distinfo b/math/py-optuna/distinfo
new file mode 100644
index 000000000000..359c37b4b112
--- /dev/null
+++ b/math/py-optuna/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1608953168
+SHA256 (optuna-2.3.0.tar.gz) = 876dad2e4d9f3b368f573c0c49724ce5f3b9abfcb14dde6a5ad1b427e73e6a2e
+SIZE (optuna-2.3.0.tar.gz) = 258631
diff --git a/math/py-optuna/files/pkg-message.in b/math/py-optuna/files/pkg-message.in
new file mode 100644
index 000000000000..cd438590cdea
--- /dev/null
+++ b/math/py-optuna/files/pkg-message.in
@@ -0,0 +1,9 @@
+[
+{ type: install
+ message: <<EOM
+There is no Tensorflow port currently in FreeBSD ports tree that is required
+by Keras by default. To make Keras work with Theano backend, one needs to modify
+theirs $HOME/.keras/keras.json file and set "backend" option to "theano".
+EOM
+}
+]
diff --git a/math/py-optuna/pkg-descr b/math/py-optuna/pkg-descr
new file mode 100644
index 000000000000..91ea094994d1
--- /dev/null
+++ b/math/py-optuna/pkg-descr
@@ -0,0 +1,7 @@
+Optuna is an automatic hyperparameter optimization software framework,
+particularly designed for machine learning. It features an imperative,
+define-by-run style user API. Thanks to our define-by-run API, the code
+written with Optuna enjoys high modularity, and the user of Optuna can
+dynamically construct the search spaces for the hyperparameters.
+
+WWW: https://optuna.org/