aboutsummaryrefslogtreecommitdiff
path: root/math/py-pynleq2
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-02-14 18:12:28 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-02-14 18:12:28 +0000
commitdddedc7f785cb40e85fac99baaa249c366746f23 (patch)
treee3c912b938ec88e6fb59c095edfccb447e6ec102 /math/py-pynleq2
parente6a37234bab01ef58881b313948a441b9173ffa1 (diff)
downloadports-dddedc7f785cb40e85fac99baaa249c366746f23.tar.gz
ports-dddedc7f785cb40e85fac99baaa249c366746f23.zip
math/py-pynleq2: Remove dependency on flang.
Notes
Notes: svn path=/head/; revision=565258
Diffstat (limited to 'math/py-pynleq2')
-rw-r--r--math/py-pynleq2/Makefile10
-rw-r--r--math/py-pynleq2/distinfo6
-rw-r--r--math/py-pynleq2/files/patch-setup.py4
3 files changed, 9 insertions, 11 deletions
diff --git a/math/py-pynleq2/Makefile b/math/py-pynleq2/Makefile
index 8a21feecd8b4..3ffaddec4ae0 100644
--- a/math/py-pynleq2/Makefile
+++ b/math/py-pynleq2/Makefile
@@ -2,7 +2,7 @@
PORTNAME= pynleq2
DISTVERSION= 0.0.2
-PORTREVISION= 5
+PORTREVISION= 7
CATEGORIES= math python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,12 +16,10 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYNUMPY}
-USES= fortran:flang python:3.6+
+USES= fortran python:3.6+
USE_PYTHON= distutils autoplist
USE_GITHUB= nodefault
-GH_TUPLE= PySCeS:pysces:0.9.6:fortran
-
-BINARY_ALIAS= gfortran6=flang # it keeps using gfortran6 regardless of the environment variables and arguments
+GH_TUPLE= PySCeS:pysces:0.9.8:fortran
FORTRAN_FILES= linalg_nleq2.f nleq2.f wnorm.f zibconst.f zibmon.f zibsec.f
@@ -31,7 +29,7 @@ post-patch:
pre-build: # compile fortran files into a static library because distutils fails while doing this
@${MKDIR} ${WRKDIR}/.fbuild && \
cd ${WRKDIR}/.fbuild && \
- flang -c ${CFLAGS} -fPIC ${FORTRAN_FILES:C,^,${WRKSRC_fortran}/pysces/nleq2/,} && \
+ ${FC} -c ${CFLAGS} -fPIC ${FORTRAN_FILES:C,^,${WRKSRC_fortran}/pysces/nleq2/,} && \
${AR} -qc libff.a ${FORTRAN_FILES:S/.f/.o/}
post-install:
diff --git a/math/py-pynleq2/distinfo b/math/py-pynleq2/distinfo
index d6dece079765..838ddb07e02b 100644
--- a/math/py-pynleq2/distinfo
+++ b/math/py-pynleq2/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1524415019
+TIMESTAMP = 1589502332
SHA256 (pynleq2-0.0.2.tar.gz) = b9be75bb7def34cd7a82aed87b70f6c3c9f4602cbe9e8d4fcf43a4aae241112d
SIZE (pynleq2-0.0.2.tar.gz) = 6219
-SHA256 (PySCeS-pysces-0.9.6_GH0.tar.gz) = 0888488fa9a8d11c4885e084af0c5825d9c37d1fb8a133899a657d79bc503fa4
-SIZE (PySCeS-pysces-0.9.6_GH0.tar.gz) = 2673710
+SHA256 (PySCeS-pysces-0.9.8_GH0.tar.gz) = a97af5afe50fe994e84d33455ded5821f694d809f6a36adc9b486bb209d58a72
+SIZE (PySCeS-pysces-0.9.8_GH0.tar.gz) = 2655864
diff --git a/math/py-pynleq2/files/patch-setup.py b/math/py-pynleq2/files/patch-setup.py
index 036483b8c3fe..c8e27f0124a8 100644
--- a/math/py-pynleq2/files/patch-setup.py
+++ b/math/py-pynleq2/files/patch-setup.py
@@ -20,8 +20,8 @@
Extension('pynleq2.nleq2', [os.path.join('nleq2', f)
- for f in ('nleq2.pyf',) + sources])
+ for f in ('nleq2.pyf',)]
-+ , libraries=['ff', 'flang', 'execinfo']
-+ , library_dirs=['../.fbuild', '/usr/local/flang/lib'])
++ , libraries=['ff', 'execinfo']
++ , library_dirs=['../.fbuild'])
]
PYNLEQ2_RELEASE_VERSION = os.environ.get('PYNLEQ2_RELEASE_VERSION', '')