aboutsummaryrefslogtreecommitdiff
path: root/math/py-pytorchvideo
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2021-07-14 03:36:03 +0000
committerNeel Chauhan <nc@FreeBSD.org>2021-07-14 03:36:48 +0000
commitec0263baf50f4a5c89eb57fae793488f9ef7e70c (patch)
tree4bc9a8469056d8d6a2365f759e266a1620c7977c /math/py-pytorchvideo
parentbb6b488ec8338b30dc0712f7eb7d196081b85cdf (diff)
downloadports-ec0263baf50f4a5c89eb57fae793488f9ef7e70c.tar.gz
ports-ec0263baf50f4a5c89eb57fae793488f9ef7e70c.zip
math/py-pytorchvideo: New port: Video understanding deep learning library
Diffstat (limited to 'math/py-pytorchvideo')
-rw-r--r--math/py-pytorchvideo/Makefile22
-rw-r--r--math/py-pytorchvideo/distinfo3
-rw-r--r--math/py-pytorchvideo/pkg-descr7
3 files changed, 32 insertions, 0 deletions
diff --git a/math/py-pytorchvideo/Makefile b/math/py-pytorchvideo/Makefile
new file mode 100644
index 000000000000..6ddb8f56154d
--- /dev/null
+++ b/math/py-pytorchvideo/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= pytorchvideo
+PORTVERSION= 0.1.2
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= nc@FreeBSD.org
+COMMENT= Video understanding deep learning library
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}av>0:multimedia/py-av@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}fvcore>0:math/py-fvcore@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}iopath>0:devel/py-iopath@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}parameterized>0:devel/py-parameterized@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/math/py-pytorchvideo/distinfo b/math/py-pytorchvideo/distinfo
new file mode 100644
index 000000000000..5f1b1e6523a3
--- /dev/null
+++ b/math/py-pytorchvideo/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1626233697
+SHA256 (pytorchvideo-0.1.2.tar.gz) = 441def1c771881220c693b8117dcfdc6c55b13ccf9ff691adfe2a50d3ef4da81
+SIZE (pytorchvideo-0.1.2.tar.gz) = 115424
diff --git a/math/py-pytorchvideo/pkg-descr b/math/py-pytorchvideo/pkg-descr
new file mode 100644
index 000000000000..40515a2e55cc
--- /dev/null
+++ b/math/py-pytorchvideo/pkg-descr
@@ -0,0 +1,7 @@
+PyTorchVideo is a deeplearning library with a focus on video understanding
+work. PytorchVideo provides reusable, modular and efficient components needed
+to accelerate the video understanding research. PyTorchVideo is developed using
+PyTorch and supports different deeplearning video components like video models,
+video datasets, and video-specific transforms.
+
+WWW: https://github.com/facebookresearch/pytorchvideo