aboutsummaryrefslogtreecommitdiff
path: root/math/py-rapi
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-09-01 15:39:55 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-09-01 15:39:55 +0000
commitb3d4f192dd3fd4c038cdfbe1df7afcd294e8a976 (patch)
tree82a99a99690bf95341a8d27ad0bc4e4864ed1fa6 /math/py-rapi
parent3f0dd45f39ffdef118fd10f24e0d8883af76f604 (diff)
downloadports-b3d4f192dd3fd4c038cdfbe1df7afcd294e8a976.tar.gz
ports-b3d4f192dd3fd4c038cdfbe1df7afcd294e8a976.zip
New port: math/py-rapi: Minimal R API for Python
Notes
Notes: svn path=/head/; revision=478706
Diffstat (limited to 'math/py-rapi')
-rw-r--r--math/py-rapi/Makefile24
-rw-r--r--math/py-rapi/distinfo5
-rw-r--r--math/py-rapi/pkg-descr6
3 files changed, 35 insertions, 0 deletions
diff --git a/math/py-rapi/Makefile b/math/py-rapi/Makefile
new file mode 100644
index 000000000000..b0ec76368542
--- /dev/null
+++ b/math/py-rapi/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= rapi
+DISTVERSION= 0.1.2
+CATEGORIES= math
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+PATCH_SITES= https://github.com/randy3k/${PORTNAME}/commit/
+PATCHFILES= fb8b962651d6bec009f1bf67eb0369e62da134c4.patch:-p1
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Minimal R API for Python
+
+LICENSE= MIT
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-runner>0:devel/py-pytest-runner@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}multipledispatch>0:devel/py-multipledispatch@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/math/py-rapi/distinfo b/math/py-rapi/distinfo
new file mode 100644
index 000000000000..674016ad14a5
--- /dev/null
+++ b/math/py-rapi/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1535815878
+SHA256 (rapi-0.1.2.tar.gz) = 645e9337b1ededd677e9f8310db412c0b5b8fdfbe26a3222a37d21041e596e74
+SIZE (rapi-0.1.2.tar.gz) = 23744
+SHA256 (fb8b962651d6bec009f1bf67eb0369e62da134c4.patch) = 78d97c372209a947a2767244043a116af5f0605e1e0def2d07d41205c0f1ca97
+SIZE (fb8b962651d6bec009f1bf67eb0369e62da134c4.patch) = 765
diff --git a/math/py-rapi/pkg-descr b/math/py-rapi/pkg-descr
new file mode 100644
index 000000000000..157f43cce2da
--- /dev/null
+++ b/math/py-rapi/pkg-descr
@@ -0,0 +1,6 @@
+Minimal R API for Python.
+
+It is similar to rpy2 in its functionality, but doesn't require compilation,
+toolchains, etc.
+
+WWW: https://github.com/randy3k/rapi