aboutsummaryrefslogtreecommitdiff
path: root/math/py-sympy/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2021-02-15 01:22:17 +0000
committerWen Heping <wen@FreeBSD.org>2021-02-15 01:22:17 +0000
commita6ddcdd92456141b09be05aad7ade0892e3e62a5 (patch)
tree13a619171dc9689cbd30d6c5b636c5d2680c371f /math/py-sympy/Makefile
parentca1c61bbad92afd94f49c4690ff0a036631c5655 (diff)
downloadports-a6ddcdd92456141b09be05aad7ade0892e3e62a5.tar.gz
ports-a6ddcdd92456141b09be05aad7ade0892e3e62a5.zip
- Update to 1.7.1
- Add test target PR: 253520 Submitted by: thierry@FreeBSD.org
Notes
Notes: svn path=/head/; revision=565280
Diffstat (limited to 'math/py-sympy/Makefile')
-rw-r--r--math/py-sympy/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/math/py-sympy/Makefile b/math/py-sympy/Makefile
index b7ac6a1181d3..d4fd67f55da8 100644
--- a/math/py-sympy/Makefile
+++ b/math/py-sympy/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= sympy
-PORTVERSION= 1.7
+PORTVERSION= 1.7.1
CATEGORIES= math python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,8 +13,9 @@ COMMENT= Python Library For Symbolic Mathematics
LICENSE= BSD3CLAUSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mpmath>=0.19:math/py-mpmath@${PY_FLAVOR}
+TEST_DEPENDS= py.test:devel/py-pytest@${PY_FLAVOR}
-USES= python:3.5+
+USES= python:3.6+
USE_PYTHON= distutils concurrent autoplist
NO_ARCH= yes
@@ -26,4 +27,7 @@ PYGLET_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyglet>=1.1.2:graphics/py-pyglet@${PY
post-patch:
@${REINPLACE_CMD} -e "s#share/man/man1#man/man1#" ${WRKSRC}/setup.py
+do-test: install
+ (cd ${WRKSRC} && py.test)
+
.include <bsd.port.mk>