aboutsummaryrefslogtreecommitdiff
path: root/math/qalculate
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-08-29 17:39:02 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-08-29 17:39:02 +0000
commit37073a11e1b0bf6e3ff683873939b10465f86ad4 (patch)
treeb3372b4a32e56c4a74b6b25f6e50d754c928ca7c /math/qalculate
parent424de77b9000f8bc411cd22393d3dce5275727a7 (diff)
downloadports-37073a11e1b0bf6e3ff683873939b10465f86ad4.tar.gz
ports-37073a11e1b0bf6e3ff683873939b10465f86ad4.zip
Add qalculate, a multi-purpose desktop calculator for GNU/Linux (heh).
It is small and simple to use but with much power and versatility underneath. Features include customizable functions, units, arbitrary precision, plotting, and a user-friendly interface. PR: ports/68979 Submitted by: Sergey Akifyev <asa@gascom.ru>
Notes
Notes: svn path=/head/; revision=117583
Diffstat (limited to 'math/qalculate')
-rw-r--r--math/qalculate/Makefile40
-rw-r--r--math/qalculate/distinfo2
-rw-r--r--math/qalculate/files/extra-patch-FreeBSD411
-rw-r--r--math/qalculate/files/patch-src::calclib::Calculator.cc15
-rw-r--r--math/qalculate/pkg-descr6
-rw-r--r--math/qalculate/pkg-plist67
6 files changed, 141 insertions, 0 deletions
diff --git a/math/qalculate/Makefile b/math/qalculate/Makefile
new file mode 100644
index 000000000000..1540584a5e13
--- /dev/null
+++ b/math/qalculate/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: qalculate
+# Date created: 07 July 2004
+# Whom: Sergey Akifyev <asa@gascom.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qalculate
+PORTVERSION= 0.6.3
+CATEGORIES= math
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-gtk-${PORTVERSION}
+
+MAINTAINER= asa@gascom.ru
+COMMENT= Very powerful GUI calculator for GNOME
+
+LIB_DEPENDS= cln.3:${PORTSDIR}/math/cln
+RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot \
+ wget:${PORTSDIR}/ftp/wget
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_GNOME= gnomeprefix gnomehack intlhack libglade2 libgnome
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+# cln is built with gcc 3.3 on FreeBSD 4.x
+USE_GCC= 3.3
+# in FreeBSD 4.x struct liconv does not contain int_p_cs_precedes
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-FreeBSD4
+# XXX configure script fails to detect gettext on FreeBSD 4.x with gcc 3.3
+PLIST_SUB+= 5X="@comment "
+.else
+PLIST_SUB+= 5X=""
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/qalculate/distinfo b/math/qalculate/distinfo
new file mode 100644
index 000000000000..d6af4b659a2b
--- /dev/null
+++ b/math/qalculate/distinfo
@@ -0,0 +1,2 @@
+MD5 (qalculate-gtk-0.6.3.tar.gz) = 6deb12cb5b457c42f26f0da9abf442f4
+SIZE (qalculate-gtk-0.6.3.tar.gz) = 1387128
diff --git a/math/qalculate/files/extra-patch-FreeBSD4 b/math/qalculate/files/extra-patch-FreeBSD4
new file mode 100644
index 000000000000..a58aaaa1701e
--- /dev/null
+++ b/math/qalculate/files/extra-patch-FreeBSD4
@@ -0,0 +1,11 @@
+--- src/calclib/Calculator.cc.orig Sun Aug 29 17:22:28 2004
++++ src/calclib/Calculator.cc Sun Aug 29 17:27:37 2004
+@@ -225,7 +225,7 @@
+
+ saved_locale = strdup(setlocale(LC_NUMERIC, NULL));
+ struct lconv *lc = localeconv();
+- place_currency_code_before = lc->int_p_cs_precedes;
++ place_currency_code_before = lc->p_cs_precedes;
+ place_currency_sign_before = lc->p_cs_precedes;
+ setlocale(LC_NUMERIC, "C");
+ ILLEGAL_IN_NAMES = DOT_S + RESERVED OPERATORS SPACES PARENTHESISS VECTOR_WRAPS;
diff --git a/math/qalculate/files/patch-src::calclib::Calculator.cc b/math/qalculate/files/patch-src::calclib::Calculator.cc
new file mode 100644
index 000000000000..01119f0b6ded
--- /dev/null
+++ b/math/qalculate/files/patch-src::calclib::Calculator.cc
@@ -0,0 +1,15 @@
+--- src/calclib/Calculator.cc.orig Thu Jul 8 12:00:01 2004
++++ src/calclib/Calculator.cc Thu Jul 8 12:05:08 2004
+@@ -27,9 +27,11 @@
+ #include <unistd.h>
+ #include <time.h>
+ #include <sys/types.h>
++#include <sys/wait.h>
+ #include <sys/stat.h>
++#include <sys/time.h>
++#include <sys/resource.h>
+ #include <dirent.h>
+-#include <wait.h>
+ #include <queue>
+ #include <stack>
+
diff --git a/math/qalculate/pkg-descr b/math/qalculate/pkg-descr
new file mode 100644
index 000000000000..45ee2936fc83
--- /dev/null
+++ b/math/qalculate/pkg-descr
@@ -0,0 +1,6 @@
+Qalculate! is a multi-purpose desktop calculator. It is small and simple to
+use but with much power and versatility underneath. Features include
+customizable functions, units, arbitrary precision, plotting, and
+a user-friendly interface.
+
+WWW: http://qalculate.sourceforge.net
diff --git a/math/qalculate/pkg-plist b/math/qalculate/pkg-plist
new file mode 100644
index 000000000000..0e51d858659a
--- /dev/null
+++ b/math/qalculate/pkg-plist
@@ -0,0 +1,67 @@
+bin/qalculate
+bin/qalculate-gtk
+share/gnome/applnk/Utilities/qalculate.desktop
+share/gnome/applications/qalculate.desktop
+share/gnome/help/qalculate-gtk/C/legal.xml
+share/gnome/help/qalculate-gtk/C/qalculate-gtk.xml
+share/gnome/help/qalculate-gtk/C/figures/calculation-history.png
+share/gnome/help/qalculate-gtk/C/figures/calculator-buttons-screen.png
+share/gnome/help/qalculate-gtk/C/figures/calculator-buttons.png
+share/gnome/help/qalculate-gtk/C/figures/completion.png
+share/gnome/help/qalculate-gtk/C/figures/convert-number-bases.png
+share/gnome/help/qalculate-gtk/C/figures/convert-unit.png
+share/gnome/help/qalculate-gtk/C/figures/edit-function.png
+share/gnome/help/qalculate-gtk/C/figures/edit-matrix.png
+share/gnome/help/qalculate-gtk/C/figures/edit-unit.png
+share/gnome/help/qalculate-gtk/C/figures/function-manager.png
+share/gnome/help/qalculate-gtk/C/figures/gnuplot.png
+share/gnome/help/qalculate-gtk/C/figures/import-csv.png
+share/gnome/help/qalculate-gtk/C/figures/insert-function-screen.png
+share/gnome/help/qalculate-gtk/C/figures/insert-function.png
+share/gnome/help/qalculate-gtk/C/figures/mainwindow-screen.png
+share/gnome/help/qalculate-gtk/C/figures/mainwindow.png
+share/gnome/help/qalculate-gtk/C/figures/plot-data.png
+share/gnome/help/qalculate-gtk/C/figures/plot-settings.png
+share/gnome/help/qalculate-gtk/C/figures/store-variable.png
+share/gnome/help/qalculate-gtk/C/figures/unit-manager.png
+share/gnome/help/qalculate-gtk/C/figures/variable-manager.png
+share/gnome/omf/qalculate-gtk/qalculate-gtk-C.omf
+share/gnome/qalculate-gtk/glade/about.glade
+share/gnome/qalculate-gtk/glade/argumentrules.glade
+share/gnome/qalculate-gtk/glade/csvexport.glade
+share/gnome/qalculate-gtk/glade/csvimport.glade
+share/gnome/qalculate-gtk/glade/decimals.glade
+share/gnome/qalculate-gtk/glade/functionedit.glade
+share/gnome/qalculate-gtk/glade/functions.glade
+share/gnome/qalculate-gtk/glade/main.glade
+share/gnome/qalculate-gtk/glade/matrixedit.glade
+share/gnome/qalculate-gtk/glade/namesedit.glade
+share/gnome/qalculate-gtk/glade/nbases.glade
+share/gnome/qalculate-gtk/glade/nbexpression.glade
+share/gnome/qalculate-gtk/glade/periodictable.glade
+share/gnome/qalculate-gtk/glade/plot.glade
+share/gnome/qalculate-gtk/glade/precision.glade
+share/gnome/qalculate-gtk/glade/preferences.glade
+share/gnome/qalculate-gtk/glade/unit.glade
+share/gnome/qalculate-gtk/glade/unitedit.glade
+share/gnome/qalculate-gtk/glade/units.glade
+share/gnome/qalculate-gtk/glade/unknownedit.glade
+share/gnome/qalculate-gtk/glade/variableedit.glade
+share/gnome/qalculate-gtk/glade/variables.glade
+share/gnome/qalculate/elements.xml
+share/gnome/qalculate/functions.xml
+share/gnome/qalculate/prefixes.xml
+share/gnome/qalculate/units.xml
+share/gnome/qalculate/variables.xml
+%%5X%%share/locale/sv/LC_MESSAGES/qalculate-gtk.mo
+@exec scrollkeeper-install -q %D/share/gnome/omf/qalculate-gtk/qalculate-gtk-C.omf 2>/dev/null || /usr/bin/true
+@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/qalculate-gtk/qalculate-gtk-C.omf 2>/dev/null || /usr/bin/true
+@dirrm share/gnome/applnk/Utilities
+@dirrm share/gnome/applnk
+@dirrm share/gnome/help/qalculate-gtk/C/figures
+@dirrm share/gnome/help/qalculate-gtk/C
+@dirrm share/gnome/help/qalculate-gtk
+@dirrm share/gnome/omf/qalculate-gtk
+@dirrm share/gnome/qalculate
+@dirrm share/gnome/qalculate-gtk/glade
+@dirrm share/gnome/qalculate-gtk