aboutsummaryrefslogtreecommitdiff
path: root/math/reduce
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-08-08 16:13:44 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-08-08 16:15:44 +0000
commit183c0e2bc8137958e026e990c0fef99b74b45168 (patch)
treedbacc11c0af4cc794c0e2184bd2d958c373e7a86 /math/reduce
parent14c8b9f26c9228b9eedce8289686328eee7fb4f6 (diff)
downloadports-183c0e2bc8137958e026e990c0fef99b74b45168.tar.gz
ports-183c0e2bc8137958e026e990c0fef99b74b45168.zip
math/reduce: Fix build on armv6, aarch64; Enable on powerpc64
It was failing with 'wcwidth' related message.
Diffstat (limited to 'math/reduce')
-rw-r--r--math/reduce/Makefile2
-rw-r--r--math/reduce/files/patch-generic_newfront_redfront.h26
2 files changed, 26 insertions, 2 deletions
diff --git a/math/reduce/Makefile b/math/reduce/Makefile
index e598f3d2edac..1dda4866d5f4 100644
--- a/math/reduce/Makefile
+++ b/math/reduce/Makefile
@@ -9,9 +9,7 @@ COMMENT= Codemist Standard Lisp REDUCE general-purpose computer system
LICENSE= BSD2CLAUSE
-BROKEN_armv6= fails to compile: redfront.h:118:12: conflicting types for '__wcwidth'
BROKEN_i386= fails to compile: sysv.S:832:1: changed section flags for .eh_frame, expected: 0x2
-BROKEN_powerpc64= fails to compile: arith01.cpp: 'statuc' does not name a type
BUILD_DEPENDS= gnuplot:math/gnuplot
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
diff --git a/math/reduce/files/patch-generic_newfront_redfront.h b/math/reduce/files/patch-generic_newfront_redfront.h
new file mode 100644
index 000000000000..83ed9bd1f793
--- /dev/null
+++ b/math/reduce/files/patch-generic_newfront_redfront.h
@@ -0,0 +1,26 @@
+- fix of this failure on arm64:
+-
+- In file included from /wrkdirs/usr/ports/math/reduce/work/Reduce-svn6339-src/generic/newfront/redchild.c:31:
+- /wrkdirs/usr/ports/math/reduce/work/Reduce-svn6339-src/generic/newfront/redfront.h:118:12: error: conflicting types for '__wcwidth'
+- extern int wcwidth(wchar_t c);
+- ^
+- /usr/include/wchar.h:213:21: note: expanded from macro 'wcwidth'
+- #define wcwidth(_c) __wcwidth(_c)
+- ^
+- /usr/include/_ctype.h:161:1: note: previous definition is here
+- __wcwidth(__ct_rune_t _c)
+- ^
+- 1 error generated.
+
+--- generic/newfront/redfront.h.orig 2021-03-16 10:41:22 UTC
++++ generic/newfront/redfront.h
+@@ -115,7 +115,9 @@ typedef void (*sig_t)(int);
+ */
+ #ifndef NATIVE_WINDOWS
+ #include "sys.h"
++# if !defined(__FreeBSD__)
+ extern int wcwidth(wchar_t c);
++# endif
+ #include "chartype.h"
+ #endif
+