aboutsummaryrefslogtreecommitdiff
path: root/math/rkward-kde4/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2015-11-21 14:09:12 +0000
committerThierry Thomas <thierry@FreeBSD.org>2015-11-21 14:09:12 +0000
commit08260f4eba076bf69e2e354c18ac4634754d8949 (patch)
tree4de42f2ce0b0530668aaa2734ede48d1d1bb14a1 /math/rkward-kde4/Makefile
parent8e315b3d56fa89e7e909284a53638d52876343f1 (diff)
downloadports-08260f4eba076bf69e2e354c18ac4634754d8949.tar.gz
ports-08260f4eba076bf69e2e354c18ac4634754d8949.zip
Resurrect math/rkward-kde4, which had been removed because math/R-cran-car
might gbe removed, but this dependency is recommended, not mandatory.
Notes
Notes: svn path=/head/; revision=402161
Diffstat (limited to 'math/rkward-kde4/Makefile')
-rw-r--r--math/rkward-kde4/Makefile86
1 files changed, 86 insertions, 0 deletions
diff --git a/math/rkward-kde4/Makefile b/math/rkward-kde4/Makefile
new file mode 100644
index 000000000000..6946512c83ff
--- /dev/null
+++ b/math/rkward-kde4/Makefile
@@ -0,0 +1,86 @@
+# Created by: thierry@pompo.net
+# $FreeBSD$
+
+PORTNAME= rkward
+PORTVERSION= 0.6.2
+PORTREVISION= 1
+CATEGORIES= math
+MASTER_SITES= SF/${PORTNAME}/Current_Stable_Releases
+PKGNAMESUFFIX= -kde4
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= IDE/GUI for the R-project
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/R:${PORTSDIR}/math/R
+RUN_DEPENDS= ${LOCALBASE}/bin/R:${PORTSDIR}/math/R \
+ ${KDE4_PREFIX}/lib/kde4/katepart.so:${PORTSDIR}/editors/kate
+
+CONFLICTS= rkward-0.4.*
+
+USE_QT4= qmake_build moc_build rcc_build uic_build phonon
+
+USE_KDE4= kdeprefix automoc4 kdelibs
+USE_PHP= yes
+WANT_PHP_CLI= yes
+USES= cmake gettext fortran
+INSTALLS_ICONS= yes
+
+CFLAGS+= -I${LOCALBASE}/include
+
+DOCSDIR= ${PREFIX}/share/doc/HTML/en/rkward
+
+OPTIONS_DEFINE= RECDEP DOCS NLS
+RECDEP_DESC= Recommended runtime dependencies
+OPTIONS_DEFAULT=RECDEP
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+NLS= ""
+.else
+NLS= "@comment "
+.endif
+PLIST_SUB+= NLS=${NLS}
+
+.if ${PORT_OPTIONS:MRECDEP}
+LR_MOD_DIR= ${LOCALBASE}/lib/R/library
+RUN_DEPENDS+= ${LR_MOD_DIR}/R2HTML/INDEX:${PORTSDIR}/textproc/R-cran-R2HTML \
+ ${LR_MOD_DIR}/XML/INDEX:${PORTSDIR}/textproc/R-cran-XML \
+ ${LR_MOD_DIR}/mvtnorm/INDEX:${PORTSDIR}/math/R-cran-mvtnorm \
+ ${LR_MOD_DIR}/outliers/INDEX:${PORTSDIR}/math/R-cran-outliers \
+ ${LR_MOD_DIR}/tseries/INDEX:${PORTSDIR}/finance/R-cran-tseries
+ # ${LR_MOD_DIR}/car/INDEX:${PORTSDIR}/math/R-cran-car
+.endif
+
+pre-configure:
+ ${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' \
+ ${WRKSRC}/rkward/rbackend/rkfrontendtransmitter.cpp
+.if ! ${PORT_OPTIONS:MDOCS}
+ ${REINPLACE_CMD} -e 's|ADD_SUBDIRECTORY(doc)|#ADD_SUBDIRECTORY(doc)|' \
+ ${WRKSRC}/CMakeLists.txt
+.else
+#Fix build with kdelibs>=4.5.0
+ ${REINPLACE_CMD} -e 's,V4.1-Based Variant V1.0,V4.2-Based Variant V1.1,g' \
+ ${WRKSRC}/doc/rkward/index.docbook
+.endif
+.if ! ${PORT_OPTIONS:MNLS}
+ ${REINPLACE_CMD} -e 's|ADD_SUBDIRECTORY(po)|#ADD_SUBDIRECTORY(po)|' \
+ ${WRKSRC}/CMakeLists.txt
+.endif
+ @(if [ ! -e ${LOCALBASE}/lib/R/lib/libR.so ] ; then \
+ ${ECHO_MSG} "==> ${PKGNAME} requires math/R to be built WITH_LIBR" ; \
+ exit 1; fi)
+
+post-install:
+ ${RM} ${STAGEDIR}${PREFIX}/share/apps/katepart/syntax/r.xml # Conflicts with kate
+
+.if defined(MAINTAINER_MODE)
+regression-test: install
+ @${ECHO_MSG} "To pass the tests, some CRAN packages like R2HTML"
+ @${ECHO_MSG} "must be installed."
+ (cd ${WRKSRC}/tests && KDE_LANG=en_US make plugintests)
+.endif
+
+.include <bsd.port.mk>