aboutsummaryrefslogtreecommitdiff
path: root/math/rngstreams/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-06-29 19:35:48 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-06-29 19:35:48 +0000
commitfa592f7c63c3812242fde3da2f1a3c1cc42f8d5d (patch)
treeae9ccb629f13ebc48292ae14c135986157c8bc42 /math/rngstreams/Makefile
parent3ab77007b6359696dc14a0a58a50388873517826 (diff)
downloadports-fa592f7c63c3812242fde3da2f1a3c1cc42f8d5d.tar.gz
ports-fa592f7c63c3812242fde3da2f1a3c1cc42f8d5d.zip
- Add LICENSE
- Switch to new test framework - Style fixes - Strip library - Switch to options helpers
Notes
Notes: svn path=/head/; revision=417790
Diffstat (limited to 'math/rngstreams/Makefile')
-rw-r--r--math/rngstreams/Makefile29
1 files changed, 18 insertions, 11 deletions
diff --git a/math/rngstreams/Makefile b/math/rngstreams/Makefile
index 085fd42bd78d..eb730185b942 100644
--- a/math/rngstreams/Makefile
+++ b/math/rngstreams/Makefile
@@ -3,38 +3,45 @@
PORTNAME= rngstreams
PORTVERSION= 1.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= http://statmath.wu-wien.ac.at/software/RngStreams/
MAINTAINER= ports@FreeBSD.org
COMMENT= C implementation of a high-quality uniform random number generator
+LICENSE= GPLv2+ # code says GPLv2+, COPYING is GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
USES= libtool
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --enable-shared
+CONFIGURE_ARGS= --enable-shared
USE_LDCONFIG= yes
-PLIST_FILES= lib/librngstreams.a \
- lib/librngstreams.so.0.0.0 \
- lib/librngstreams.so.0 \
+TEST_TARGET= check
+
+PLIST_FILES= include/RngStream.h \
+ lib/librngstreams.a \
lib/librngstreams.so \
- include/RngStream.h
+ lib/librngstreams.so.0 \
+ lib/librngstreams.so.0.0.0
PORTDOCS= rngstreams.txt
PORTEXAMPLES= example1.c
OPTIONS_DEFINE= DOCS EXAMPLES
post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/librngstreams.so
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for DD in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/doc/${DD} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${DD} ${STAGEDIR}${DOCSDIR}
.endfor
+
+post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for EE in ${PORTEXAMPLES}
- @${INSTALL_DATA} ${WRKSRC}/examples/${EE} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/${EE} ${STAGEDIR}${EXAMPLESDIR}
.endfor
-regression-test: build
- @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_ARGS} check)
-
.include <bsd.port.mk>