aboutsummaryrefslogtreecommitdiff
path: root/math/saga/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2017-01-23 23:30:20 +0000
committerWen Heping <wen@FreeBSD.org>2017-01-23 23:30:20 +0000
commita269606cbbc8f07c56af98e14902597c819cdec2 (patch)
treed9effd096c09e5346900663aa97891558e9cbdd4 /math/saga/Makefile
parent0d5eb765dfada8b0008dfca2458f542faadf2146 (diff)
downloadports-a269606cbbc8f07c56af98e14902597c819cdec2.tar.gz
ports-a269606cbbc8f07c56af98e14902597c819cdec2.zip
- Update from 2.3.1 to 3.0.0
- Add dependency science/libsvm - Add USES=pkgconfig - Sort USES alphabetical - INSTALL_TARGET=install-strip PR: 216367 Submitted by: rhurlin@gwdg.de(maintainer)
Notes
Notes: svn path=/head/; revision=432306
Diffstat (limited to 'math/saga/Makefile')
-rw-r--r--math/saga/Makefile48
1 files changed, 23 insertions, 25 deletions
diff --git a/math/saga/Makefile b/math/saga/Makefile
index 633a172a7d1f..bda083a9705c 100644
--- a/math/saga/Makefile
+++ b/math/saga/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= saga
-PORTVERSION= 2.3.1
-PORTREVISION= 4
+PORTVERSION= 3.0.0
CATEGORIES= math
-MASTER_SITES= SF/saga-gis/SAGA%20-%20${PORTVERSION:C/\.[[:digit:]]*$//}/SAGA%20${PORTVERSION}
+MASTER_SITES= SF/saga-gis/SAGA%20-%20${PORTVERSION:C/\.[[:digit:]]\.[[:digit:]]*$//}/SAGA%20-%20${PORTVERSION}
DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= rhurlin@gwdg.de
@@ -24,6 +23,7 @@ LIB_DEPENDS= libfftw3.so:math/fftw3 \
libopencv_ml.so:graphics/opencv2 \
libopencv_core.so:graphics/opencv2-core \
libproj.so:graphics/proj \
+ libsvm.so:science/libsvm \
libtbb.so:devel/tbb \
libtiff.so:graphics/tiff
RUN_DEPENDS:= ${BUILD_DEPENDS}
@@ -34,9 +34,9 @@ CONFIGURE_ENV= SWIG="${LOCALBASE}/bin/swig3.0"
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_CXXSTD= c++11
-USE_WX= 3.0+
-USES= autoreconf libtool localbase compiler:gcc-c++11-lib \
- iconv:wchar_t dos2unix python:2
+USE_WX= 3.0
+USES= autoreconf desktop-file-utils libtool localbase compiler:gcc-c++11-lib \
+ iconv:wchar_t dos2unix pkgconfig python:2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
INSTALLS_ICONS= yes
@@ -58,6 +58,8 @@ PGSQL_USES= pgsql
VIGRA_BUILD_DEPENDS= ${LOCALBASE}/lib/libvigraimpex.so:graphics/vigra
VIGRA_RUN_DEPENDS= ${LOCALBASE}/lib/libvigraimpex.so:graphics/vigra
+INSTALL_TARGET= install-strip
+
.include <bsd.port.pre.mk>
SUB_FILES= pkg-message
@@ -69,31 +71,31 @@ post-extract:
${WRKSRC}/src/saga_core/saga_cmd/Makefile.am \
${WRKSRC}/src/saga_core/saga_gdi/Makefile.am \
${WRKSRC}/src/saga_core/saga_gui/Makefile.am \
- ${WRKSRC}/src/modules/garden/garden_3d_viewer/Makefile.am \
- ${WRKSRC}/src/modules/garden/garden_webservices/Makefile.am \
- ${WRKSRC}/src/modules/io/io_grid_image/Makefile.am \
- ${WRKSRC}/src/modules/io/io_shapes/Makefile.am \
- ${WRKSRC}/src/modules/io/io_virtual/Makefile.am \
- ${WRKSRC}/src/modules/pointcloud/pointcloud_tools/Makefile.am \
- ${WRKSRC}/src/modules/pointcloud/pointcloud_viewer/Makefile.am \
- ${WRKSRC}/src/modules/tin/tin_viewer/Makefile.am \
- ${WRKSRC}/src/modules/statistics/statistics_kriging/Makefile.am
+ ${WRKSRC}/src/tools/garden/garden_3d_viewer/Makefile.am \
+ ${WRKSRC}/src/tools/garden/garden_webservices/Makefile.am \
+ ${WRKSRC}/src/tools/io/io_grid_image/Makefile.am \
+ ${WRKSRC}/src/tools/io/io_shapes/Makefile.am \
+ ${WRKSRC}/src/tools/io/io_virtual/Makefile.am \
+ ${WRKSRC}/src/tools/pointcloud/pointcloud_tools/Makefile.am \
+ ${WRKSRC}/src/tools/pointcloud/pointcloud_viewer/Makefile.am \
+ ${WRKSRC}/src/tools/statistics/statistics_kriging/Makefile.am \
+ ${WRKSRC}/src/tools/tin/tin_viewer/Makefile.am
@${REINPLACE_CMD} -e 's|/usr/include/opencv|${LOCALBASE}/include/opencv ${LOCALBASE}/include|g' \
- ${WRKSRC}/src/modules/imagery/imagery_opencv/Makefile.am
+ ${WRKSRC}/src/tools/imagery/imagery_opencv/Makefile.am
post-patch:
.if ${ARCH} == "powerpc"
@${REINPLACE_CMD} -e 's|typedef unsigned long DWORD;|typedef unsigned int DWORD;|' \
${WRKSRC}/src/saga_core/saga_api/api_core.h
.endif
- @${REINPLACE_CMD} -e 's|PORTVERSION|${PORTVERSION:C/\./-/g}|' \
+ @${REINPLACE_CMD} -e 's|PORTVERSION|${PORTVERSION}|' \
${WRKSRC}/src/saga_core/saga_gui/dlg_about.cpp
post-configure:
@${REINPLACE_CMD} -e 's|cd $$(pkgdatadir);|cd ${STAGEDIR}${DATADIR};|g' \
${WRKSRC}/src/saga_core/saga_gui/Makefile
@${REINPLACE_CMD} -e 's|^LDFLAGS = .*|& -lopencv_contrib|' \
- ${WRKSRC}/src/modules/imagery/imagery_opencv/Makefile
+ ${WRKSRC}/src/tools/imagery/imagery_opencv/Makefile
post-install:
${MKDIR} ${STAGEDIR}${DATADIR}
@@ -101,15 +103,11 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/src/saga_core/saga_gui/res/saga.png ${STAGEDIR}${DATADIR}
${RM} ${STAGEDIR}${DATADIR}/saga_dic.txt ${STAGEDIR}${DATADIR}/saga_srs.txt
# toolchains dir was moved in r2805 (and followups r2810,r2811,r2820)
- ${MKDIR} ${STAGEDIR}${DATADIR}/scripting
- (cd ${WRKSRC}/src/scripting && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/scripting)
- @${RM} -R ${STAGEDIR}${DATADIR}/scripting/toolchains
+ ${MKDIR} ${STAGEDIR}${DATADIR}/accessories
+ (cd ${WRKSRC}/src/accessories && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/accessories)
+ ${RM} -R ${STAGEDIR}${DATADIR}/accessories/toolchains
${INSTALL_DATA} ${WRKSRC}/src/saga_core/saga_gui/res/saga.desktop \
${STAGEDIR}${PREFIX}/share/applications/
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libsaga_api-${PORTVERSION}.so
- @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/_saga_api-${PORTVERSION}.so
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libsaga_gdi-${PORTVERSION}.so
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/saga/*.so
# library helper files are not needed and cripple some math/qgis extensions
@${RM} ${STAGEDIR}${PREFIX}/lib/saga/*.la