aboutsummaryrefslogtreecommitdiff
path: root/math/sage
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2012-02-01 00:20:29 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2012-02-01 00:20:29 +0000
commit349f7fbd3bbe91845ac98f00995792f8acffb6a7 (patch)
treec6b50b484b59f06c03260f02ddf5d592df4da09d /math/sage
parentfaad8b9921a948a391da7e892455c201598164b7 (diff)
downloadports-349f7fbd3bbe91845ac98f00995792f8acffb6a7.tar.gz
ports-349f7fbd3bbe91845ac98f00995792f8acffb6a7.zip
- Small changes to post-patch target so that it can be restarted.
- Switch off parallel builds if FreeBSD version>=9 (hoping to get some useful feedback from tinderbox builds, as parallel building mangles the log).
Notes
Notes: svn path=/head/; revision=290211
Diffstat (limited to 'math/sage')
-rw-r--r--math/sage/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/math/sage/Makefile b/math/sage/Makefile
index 4348f5aeb5d0..c11964f3e089 100644
--- a/math/sage/Makefile
+++ b/math/sage/Makefile
@@ -55,11 +55,11 @@ post-patch:
@${LN} -s -f ${LOCALBASE}/bin/gmake ${WRKSRC}/local/bin/make
@${LN} -s -f ${LOCALBASE}/bin/bash ${WRKSRC}/local/bin/sh
@${SED} -e 's#%%CC%%#${LOCALBASE}/bin/${CC}#' -e 's#%%CFLAGS%%#${CFLAGS}#' ${FILESDIR}/gcc.in > ${WRKSRC}/local/bin/cc
- @${CHMOD} ${BINMODE} ${WRKSRC}/local/bin/cc
- @${LN} -s cc ${WRKSRC}/local/bin/gcc
+ @${CHMOD} +x ${WRKSRC}/local/bin/cc
+ @${LN} -s -f cc ${WRKSRC}/local/bin/gcc
@${SED} -e 's#%%CC%%#${LOCALBASE}/bin/${CXX}#' -e 's#%%CFLAGS%%#${CXXFLAGS}#' ${FILESDIR}/gcc.in > ${WRKSRC}/local/bin/c++
- @${CHMOD} ${BINMODE} ${WRKSRC}/local/bin/c++
- @${LN} -s c++ ${WRKSRC}/local/bin/g++
+ @${CHMOD} +x ${WRKSRC}/local/bin/c++
+ @${LN} -s -f c++ ${WRKSRC}/local/bin/g++
@${SED} -e 's#%%CC%%#${LOCALBASE}/bin/${FC}#' -e 's#%%CFLAGS%%#${FFLAGS}#' ${FILESDIR}/gcc.in > ${WRKSRC}/local/bin/gfortran
@${CHMOD} +x ${WRKSRC}/local/bin/gfortran
@${MKDIR} ${WRKSRC}/tmp
@@ -96,7 +96,7 @@ post-patch:
IGNORE= POSIX semaphores are required, and the support only works in FreeBSD 7-STABLE and later
.endif
-.if !defined(DISABLE_MAKE_JOBS)
+.if !defined(DISABLE_MAKE_JOBS) && ${OSVERSION} < 900000
MAKE_ENV+= MAKE="make -j${MAKE_JOBS_NUMBER}"
.endif