aboutsummaryrefslogtreecommitdiff
path: root/math/sage
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2012-06-15 03:56:31 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2012-06-15 03:56:31 +0000
commit9f5d6899f5b8ca74cc40a16f1cdc8b90689a7a03 (patch)
tree87ca05a14bddf0d025d326a3eb9be57981db97fc /math/sage
parentdfae2fda40e72ab9b26037c2803c4f7f48dc0f4f (diff)
downloadports-9f5d6899f5b8ca74cc40a16f1cdc8b90689a7a03.tar.gz
ports-9f5d6899f5b8ca74cc40a16f1cdc8b90689a7a03.zip
- Update to 5.0.1.
Notes
Notes: svn path=/head/; revision=299307
Diffstat (limited to 'math/sage')
-rw-r--r--math/sage/Makefile38
-rw-r--r--math/sage/distinfo4
-rw-r--r--math/sage/files/spkg-patch-polybori-0.8.1.p1_-_custom.py11
-rw-r--r--math/sage/files/spkg-patch-polybori-0.8.1.p1_-_patches_Cudd.cudd.cudd.h8
-rw-r--r--math/sage/files/spkg-patch-python-2.7.2.p4_-_src_Doc_library_fcntl.rst4
-rw-r--r--math/sage/files/spkg-patch-python-2.7.2.p4_-_src_Modules__ctypes_libffi_configure4
-rw-r--r--math/sage/files/spkg-patch-python-2.7.2.p4_-_src_Modules_fcntlmodule.c4
-rw-r--r--math/sage/files/spkg-patch-python-2.7.2.p4_-_src_Python_thread_pthread.h4
-rw-r--r--math/sage/files/spkg-patch-python-2.7.2.p4_-_src_setup.py4
-rw-r--r--math/sage/files/spkg-patch-sage-5.0_-_sage_combinat_partitions_c.cc2
-rw-r--r--math/sage/files/spkg-patch-sage-5.0_-_sage_misc_getusage.py2
11 files changed, 39 insertions, 46 deletions
diff --git a/math/sage/Makefile b/math/sage/Makefile
index 0b03aa102f3c..e68b5a0b5b54 100644
--- a/math/sage/Makefile
+++ b/math/sage/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= sage
-PORTVERSION= 5.0
-PORTREVISION= 1
+PORTVERSION= 5.0.1
CATEGORIES= math
MASTER_SITES= http://boxen.math.washington.edu/home/sagemath/sage-mirror/src/ \
http://mirrors.xmission.com/sage/src/ \
@@ -60,7 +59,8 @@ MAKE_ENV+= SAGE_PORT=yes \
SAGE_FORTRAN=${LOCALBASE}/bin/${FC} \
SAGE_FORTRAN_LIB=${LOCALBASE}/lib/gcc${GCC_DEFAULT_V}/libgfortran.so \
SAGE_ATLAS_LIB=${LOCALBASE}/lib \
- DOT_SAGE=${WRKSRC}/tmp/.sage
+ DOT_SAGE=${WRKSRC}/tmp/.sage \
+ SAGE_FAT_BINARY=yes
LATEST_LINK= sage-math # Conflicts with graphics/sage.
@@ -89,41 +89,45 @@ post-patch:
# Apply the patches to the appropriate xz'ed tarballs contained in
# ${WRKSRC}/spkg/standard. The names of the patches are
-# spkg-${NAME_OF_TARBALL}_-_${NAME_OF_PATCH}.
+# spkg-${ORIGINAL_NAME_OF_TARBALL}_-_${NAME_OF_PATCH}.
+# The actual name of the tarball will be deduced from the second line of the
+# patch.
+# ORIGINAL_NAME_OF_TARBALL is there for historical reasons (because renaming
+# the patch will ruin the CVS history). It might be renamed to
+# GENERIC_NAME_OF_TARBALL when ports moves to SVN.
@${MKDIR} ${WRKSRC}/tmp
@${RM} -rf ${WRKSRC}/tmp/*
@for p in ${FILESDIR}/spkg-patch-*; do \
- q=$${p#*/spkg-patch-}; t=$${q%_-_*}; \
- if ! [ -e ${WRKSRC}/spkg/standard/$$t.spkg ]; then \
- ${ECHO_MSG} "$$t not found."; \
+ q=$${p#*/spkg-patch-}; \
+ original_name=$${q%_-_*}; \
+ actual_name=`cat $$p | ${HEAD} -2 | ${TAIL} -1 | ${SED} -e 's/+++ //' -e 's|/.*||'`; \
+ if ! [ -e ${WRKSRC}/spkg/standard/$$actual_name.spkg ]; then \
+ ${ECHO_MSG} "$$actual_name not found."; \
exit 1; \
fi; \
- tarballs="$$tarballs $$t"; \
+ tarballs="$$tarballs $$original_name|$$actual_name"; \
done ;\
tarballs=`${PRINTF} "%s\n" $$tarballs | ${SORT} -u`; \
\
cd ${WRKSRC}/tmp || exit 1; \
for t in $$tarballs; do \
- f=${WRKSRC}/spkg/standard/$$t.spkg; \
+ original_name=$${t%|*}; actual_name=$${t#*|}; \
+ f=${WRKSRC}/spkg/standard/$$actual_name.spkg; \
if [ -e $$f-orig ]; then \
${MV} $$f-orig $$f; \
fi; \
${TAR} -xf $$f; \
- ${ECHO_MSG} "Patching $$t:"; \
- for p in ${FILESDIR}/spkg-patch-$${t}_-_*; do \
+ ${ECHO_MSG} "Patching $$actual_name:"; \
+ for p in ${FILESDIR}/spkg-patch-$${original_name}_-_*; do \
${ECHO_MSG} " applying $${p#*_-_}" ; \
${PATCH} < $$p 2>/dev/null || exit 1; \
done; \
${MV} $$f $$f-orig; \
- ${TAR} -cyf $$f $$t; \
- ${RM} -rf $$t; \
+ ${TAR} -cyf $$f $$actual_name; \
+ ${RM} -rf $$actual_name; \
done
-# Here we check dependencies of the optional packages on ports, and on other
-# optional packages. If you find any dependencies not listed here, please
-# contact the maintainer.
-
post-build:
${RM} -rf ${WRKSRC}/tmp/.sage
${CHMOD} -R a+rX ${WRKSRC}
diff --git a/math/sage/distinfo b/math/sage/distinfo
index 92875b031dec..3e734df867ed 100644
--- a/math/sage/distinfo
+++ b/math/sage/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sage-5.0.tar) = 883eab2a42df3751d2de777f6f5e9337c54c3fa286fe3d30997ef585f83d1f39
-SIZE (sage-5.0.tar) = 307988480
+SHA256 (sage-5.0.1.tar) = 28c20615403a4e15b1deb95b391cb03ae0e1959c0b663f90b8d4d3bb90f362ae
+SIZE (sage-5.0.1.tar) = 308305920
diff --git a/math/sage/files/spkg-patch-polybori-0.8.1.p1_-_custom.py b/math/sage/files/spkg-patch-polybori-0.8.1.p1_-_custom.py
deleted file mode 100644
index 54d8c0617697..000000000000
--- a/math/sage/files/spkg-patch-polybori-0.8.1.p1_-_custom.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- polybori-0.8.1.p1/custom.py-orig 2012-04-10 03:58:28.000000000 +0000
-+++ polybori-0.8.1.p1/custom.py 2012-04-10 04:01:48.000000000 +0000
-@@ -60,6 +60,8 @@
- HAVE_TEX4HT=False
- HAVE_PYTHON_EXTENSION=False
- EXTERNAL_PYTHON_EXTENSION=True
-+BOOST_TEST=False
-+BOOST_PYTHON=False
-
- # (CC and CXX should have been set by sage-env, but never mind...:)
- try:
diff --git a/math/sage/files/spkg-patch-polybori-0.8.1.p1_-_patches_Cudd.cudd.cudd.h b/math/sage/files/spkg-patch-polybori-0.8.1.p1_-_patches_Cudd.cudd.cudd.h
index 97ebd6a393e4..26cae4f7a2d1 100644
--- a/math/sage/files/spkg-patch-polybori-0.8.1.p1_-_patches_Cudd.cudd.cudd.h
+++ b/math/sage/files/spkg-patch-polybori-0.8.1.p1_-_patches_Cudd.cudd.cudd.h
@@ -1,8 +1,8 @@
---- polybori-0.8.1.p1/patches/Cudd.cudd.cudd.h.patch.orig 2012-04-13 01:19:43.000000000 +0000
-+++ polybori-0.8.1.p1/patches/Cudd.cudd.cudd.h.patch 2012-04-13 01:22:34.000000000 +0000
+--- polybori-0.8.1.p2/patches/Cudd.cudd.cudd.h.patch.orig 2012-04-13 01:19:43.000000000 +0000
++++ polybori-0.8.1.p2/patches/Cudd.cudd.cudd.h.patch 2012-04-13 01:22:34.000000000 +0000
@@ -0,0 +1,15 @@
-+--- polybori-0.8.1/Cudd/cudd/cudd.h.orig 2012-03-15 22:47:56.000000000 +0000
-++++ polybori-0.8.1/Cudd/cudd/cudd.h 2012-04-13 01:21:09.000000000 +0000
++--- a/Cudd/cudd/cudd.h.orig 2012-03-15 22:47:56.000000000 +0000
+++++ b/Cudd/cudd/cudd.h 2012-04-13 01:21:09.000000000 +0000
+@@ -87,6 +87,12 @@
+ #endif
+
diff --git a/math/sage/files/spkg-patch-python-2.7.2.p4_-_src_Doc_library_fcntl.rst b/math/sage/files/spkg-patch-python-2.7.2.p4_-_src_Doc_library_fcntl.rst
index 550fd75eefca..fcc178cf6a70 100644
--- a/math/sage/files/spkg-patch-python-2.7.2.p4_-_src_Doc_library_fcntl.rst
+++ b/math/sage/files/spkg-patch-python-2.7.2.p4_-_src_Doc_library_fcntl.rst
@@ -1,5 +1,5 @@
---- python-2.7.2.p4/src/Doc/library/fcntl.rst.orig 2011-06-11 15:46:23.000000000 +0000
-+++ python-2.7.2.p4/src/Doc/library/fcntl.rst 2012-04-22 00:31:48.000000000 +0000
+--- python-2.7.3.p0/src/Doc/library/fcntl.rst.orig 2011-06-11 15:46:23.000000000 +0000
++++ python-2.7.3.p0/src/Doc/library/fcntl.rst 2012-04-22 00:31:48.000000000 +0000
@@ -50,8 +50,6 @@
operations are typically defined in the library module :mod:`termios` and the
argument handling is even more complicated.
diff --git a/math/sage/files/spkg-patch-python-2.7.2.p4_-_src_Modules__ctypes_libffi_configure b/math/sage/files/spkg-patch-python-2.7.2.p4_-_src_Modules__ctypes_libffi_configure
index e320f86715ed..1324c8d689ea 100644
--- a/math/sage/files/spkg-patch-python-2.7.2.p4_-_src_Modules__ctypes_libffi_configure
+++ b/math/sage/files/spkg-patch-python-2.7.2.p4_-_src_Modules__ctypes_libffi_configure
@@ -1,5 +1,5 @@
---- python-2.7.2.p4/src/Modules/_ctypes/libffi/configure.orig 2011-06-11 15:46:26.000000000 +0000
-+++ python-2.7.2.p4/src/Modules/_ctypes/libffi/configure 2012-04-22 00:23:14.000000000 +0000
+--- python-2.7.3.p0/src/Modules/_ctypes/libffi/configure.orig 2011-06-11 15:46:26.000000000 +0000
++++ python-2.7.3.p0/src/Modules/_ctypes/libffi/configure 2012-04-22 00:23:14.000000000 +0000
@@ -6289,7 +6289,7 @@
rm -rf conftest*
;;
diff --git a/math/sage/files/spkg-patch-python-2.7.2.p4_-_src_Modules_fcntlmodule.c b/math/sage/files/spkg-patch-python-2.7.2.p4_-_src_Modules_fcntlmodule.c
index bebebb089967..94d269eb11b0 100644
--- a/math/sage/files/spkg-patch-python-2.7.2.p4_-_src_Modules_fcntlmodule.c
+++ b/math/sage/files/spkg-patch-python-2.7.2.p4_-_src_Modules_fcntlmodule.c
@@ -1,5 +1,5 @@
---- python-2.7.2.p4/src/Modules/fcntlmodule.c.orig 2011-06-11 15:46:27.000000000 +0000
-+++ python-2.7.2.p4/src/Modules/fcntlmodule.c 2012-04-22 00:23:34.000000000 +0000
+--- python-2.7.3.p0/src/Modules/fcntlmodule.c.orig 2011-06-11 15:46:27.000000000 +0000
++++ python-2.7.3.p0/src/Modules/fcntlmodule.c 2012-04-22 00:23:34.000000000 +0000
@@ -97,20 +97,15 @@
{
#define IOCTL_BUFSZ 1024
diff --git a/math/sage/files/spkg-patch-python-2.7.2.p4_-_src_Python_thread_pthread.h b/math/sage/files/spkg-patch-python-2.7.2.p4_-_src_Python_thread_pthread.h
index 68ccb349c2c4..39d793a7d6f1 100644
--- a/math/sage/files/spkg-patch-python-2.7.2.p4_-_src_Python_thread_pthread.h
+++ b/math/sage/files/spkg-patch-python-2.7.2.p4_-_src_Python_thread_pthread.h
@@ -1,5 +1,5 @@
---- python-2.7.2.p4/src/Python/thread_pthread.h.orig 2011-06-11 15:46:28.000000000 +0000
-+++ python-2.7.2.p4/src/Python/thread_pthread.h 2012-04-22 00:23:46.000000000 +0000
+--- python-2.7.3.p0/src/Python/thread_pthread.h.orig 2011-06-11 15:46:28.000000000 +0000
++++ python-2.7.3.p0/src/Python/thread_pthread.h 2012-04-22 00:23:46.000000000 +0000
@@ -38,13 +38,18 @@
#endif
#endif
diff --git a/math/sage/files/spkg-patch-python-2.7.2.p4_-_src_setup.py b/math/sage/files/spkg-patch-python-2.7.2.p4_-_src_setup.py
index 395e96dd9245..a977170da415 100644
--- a/math/sage/files/spkg-patch-python-2.7.2.p4_-_src_setup.py
+++ b/math/sage/files/spkg-patch-python-2.7.2.p4_-_src_setup.py
@@ -1,5 +1,5 @@
---- python-2.7.2.p4/src/setup.py-orig 2012-04-22 00:04:08.000000000 +0000
-+++ python-2.7.2.p4/src/setup.py 2012-04-22 00:10:25.000000000 +0000
+--- python-2.7.3.p0/src/setup.py-orig 2012-04-22 00:04:08.000000000 +0000
++++ python-2.7.3.p0/src/setup.py 2012-04-22 00:10:25.000000000 +0000
@@ -1432,10 +1432,24 @@
macros = dict()
libraries = []
diff --git a/math/sage/files/spkg-patch-sage-5.0_-_sage_combinat_partitions_c.cc b/math/sage/files/spkg-patch-sage-5.0_-_sage_combinat_partitions_c.cc
index 8fa517504fd7..8be8ea525d40 100644
--- a/math/sage/files/spkg-patch-sage-5.0_-_sage_combinat_partitions_c.cc
+++ b/math/sage/files/spkg-patch-sage-5.0_-_sage_combinat_partitions_c.cc
@@ -1,5 +1,5 @@
--- sage-5.0.beta13/sage/combinat/partitions_c.cc-orig 2012-04-20 01:01:41.000000000 +0000
-+++ sage-5.0/sage/combinat/partitions_c.cc 2012-04-20 01:02:47.000000000 +0000
++++ sage-5.0.1/sage/combinat/partitions_c.cc 2012-04-20 01:02:47.000000000 +0000
@@ -152,7 +152,7 @@
const unsigned int double_precision = DBL_MANT_DIG; // The assumed precision of a double.
diff --git a/math/sage/files/spkg-patch-sage-5.0_-_sage_misc_getusage.py b/math/sage/files/spkg-patch-sage-5.0_-_sage_misc_getusage.py
index a44ca946f567..e33db38a561c 100644
--- a/math/sage/files/spkg-patch-sage-5.0_-_sage_misc_getusage.py
+++ b/math/sage/files/spkg-patch-sage-5.0_-_sage_misc_getusage.py
@@ -1,5 +1,5 @@
--- sage-5.0.beta13/sage/misc/getusage.py-orig 2012-04-11 00:14:47.000000000 +0000
-+++ sage-5.0/sage/misc/getusage.py 2012-04-11 00:47:03.000000000 +0000
++++ sage-5.0.1/sage/misc/getusage.py 2012-04-11 00:47:03.000000000 +0000
@@ -20,6 +20,8 @@
"""
Return the 'top' or 'prstat' line that contains this running Sage