aboutsummaryrefslogtreecommitdiff
path: root/math/sage
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2012-05-15 12:57:27 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2012-05-15 12:57:27 +0000
commitd0b29d1a9b596c922d55d3339161b6ba609d9a91 (patch)
tree8ef270516a09647b4e37b0dcd54c0bf9b0727da5 /math/sage
parenta13c9f62c7bc580ad49aad122bb1640e47a0f6c1 (diff)
downloadports-d0b29d1a9b596c922d55d3339161b6ba609d9a91.tar.gz
ports-d0b29d1a9b596c922d55d3339161b6ba609d9a91.zip
- Use use_autotools to add autoconf dependency.
Notes
Notes: svn path=/head/; revision=296668
Diffstat (limited to 'math/sage')
-rw-r--r--math/sage/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/math/sage/Makefile b/math/sage/Makefile
index de2cf56f8852..6e1d85ecc4e0 100644
--- a/math/sage/Makefile
+++ b/math/sage/Makefile
@@ -18,8 +18,7 @@ MAINTAINER= stephen@FreeBSD.org
COMMENT= Open source Mathematics software
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
- latex:${PORTSDIR}/print/teTeX-base \
- autoconf-2.68:${PORTSDIR}/devel/autoconf
+ latex:${PORTSDIR}/print/teTeX-base
LIB_DEPENDS= atlas:${PORTSDIR}/math/atlas \
lapack:${PORTSDIR}/math/lapack \
jpeg:${PORTSDIR}/graphics/jpeg
@@ -86,6 +85,12 @@ CXXFLAGS+= -Wl,-rpath=${WRKSRC}/local/lib ${FPM_FLAG}
# work-around for the make(1) idiosyncracy mentioned in PR 164361 (which
# otherwise breaks the build of the maxima sub-package).
+USE_AUTOTOOLS= autoconf
+run-autotools:
+ @${DO_NADA}
+do-configure:
+ @${DO_NADA}
+
.include <bsd.port.pre.mk>
.if defined(WITH_4TI2) || defined(WITH_TOPCOM) || defined(WITH_BIOPYTHON) || \