aboutsummaryrefslogtreecommitdiff
path: root/math/scilab-toolbox-swt/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-10-17 16:33:00 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-10-17 16:33:00 +0000
commit0966b81bb56071cfcfd48637407c05d932a48e30 (patch)
tree206b4bff5f5f14f101313e2560ccbcf08700c143 /math/scilab-toolbox-swt/Makefile
parent506a4ae0636dc9379aa520abaced84f4580a7622 (diff)
downloadports-0966b81bb56071cfcfd48637407c05d932a48e30.tar.gz
ports-0966b81bb56071cfcfd48637407c05d932a48e30.zip
- Update to 0.1.11 for scilab-5.x
- Mark IGNORE: touches ${LOCALBASE}/share/scilab when building under superuser
Notes
Notes: svn path=/head/; revision=263156
Diffstat (limited to 'math/scilab-toolbox-swt/Makefile')
-rw-r--r--math/scilab-toolbox-swt/Makefile57
1 files changed, 34 insertions, 23 deletions
diff --git a/math/scilab-toolbox-swt/Makefile b/math/scilab-toolbox-swt/Makefile
index 8c83adab8596..ea97a6ca31fd 100644
--- a/math/scilab-toolbox-swt/Makefile
+++ b/math/scilab-toolbox-swt/Makefile
@@ -6,42 +6,53 @@
#
PORTNAME= swt
-DISTVERSION= 0.1.0rc4
-PORTREVISION= 4
+PORTVERSION= 0.1.11
CATEGORIES= math
-MASTER_SITES= SF/scwt/${PORTNAME}/0.1.0rc4Linux
+MASTER_SITES= http://atoms.scilab.org/toolboxes/swt/${PORTVERSION}/files/
PKGNAMEPREFIX= scilab-toolbox-
-DISTNAME= ${PORTNAME}${DISTVERSION}
+DISTFILES= ${DISTNAME}-1-src${EXTRACT_SUFX}
MAINTAINER= makc@FreeBSD.org
COMMENT= Scilab 1-D and 2-D Wavelet Toolbox
-BUILD_DEPENDS= ${LOCALBASE}/bin/scilab:${PORTSDIR}/math/scilab
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${SCILAB_CMD}:${PORTSDIR}/math/scilab
+RUN_DEPENDS:= ${BUILD_DEPENDS}
-IGNORE= doesn't build with Scilab 5.2
+IGNORE= touches ${LOCALBASE}/share/scilab when building under superuser
-WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
-
-SCILABDIR?= lib/scilab
-CONTRIBDIR?= ${SCILABDIR}/contrib
-TOOLBOXDIR?= ${CONTRIBDIR}/${PORTNAME}
-
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS+=--prefix=${PREFIX}/${TOOLBOXDIR}
-CONFIGURE_ENV+= SCI="${LOCALBASE}/${SCILABDIR}"
-
-PLIST_SUB= TOOLBOXDIR=${TOOLBOXDIR}
+SCILAB_CMD= ${LOCALBASE}/bin/scilab
+CONTRIBDIR?= share/scilab/contrib
+TOOLBOXDIR_REL?= ${CONTRIBDIR}/${PORTNAME}
+TOOLBOXDIR= ${PREFIX}/${TOOLBOXDIR_REL}
+PLIST_SUB= TOOLBOXDIR=${TOOLBOXDIR_REL}
OPTIONS= SIVP "Enable Image and Video support" off
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITH_SIVP)
RUN_DEPENDS+= ${LOCALBASE}/${CONTRIBDIR}/sivp/loader.sce:${PORTSDIR}/math/scilab-toolbox-sivp
.endif
-post-install:
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.post.mk>
+post-patch:
+ ${REINPLACE_CMD} -e "s,SWTDIR+','${TOOLBOXDIR}/demos," \
+ ${WRKSRC}/demos/image.sce
+pre-build:
+ ${FIND} -d ${WRKSRC} \( -name '*.orig' -or -name '*.bak' \) | ${XARGS} ${RM}
+
+do-build:
+ cd ${WRKSRC} && ${SCILAB_CMD} -nogui -f builder.sce
+
+do-install:
+ ${MKDIR} ${TOOLBOXDIR}/sci_gateway/c
+ ${INSTALL_DATA} ${WRKSRC}/loader.sce ${TOOLBOXDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sci_gateway/loader_gateway.sce \
+ ${TOOLBOXDIR}/sci_gateway
+ cd ${WRKSRC}/sci_gateway/c && \
+ ${INSTALL_DATA} loader.sce ${TOOLBOXDIR}/sci_gateway/c && \
+ ${INSTALL_PROGRAM} libswt_c.so ${TOOLBOXDIR}/sci_gateway/c
+.for d in demos etc macros
+ cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${TOOLBOXDIR}
+.endfor
+
+.include <bsd.port.mk>