aboutsummaryrefslogtreecommitdiff
path: root/math/scorec-core
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-12-25 02:42:38 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-12-25 02:43:19 +0000
commite7d61ea50e17c79515f0cb34a5730398ba0b4d2f (patch)
tree7c50a502c5cca348b0bfadc94f1d3a9aff0b6205 /math/scorec-core
parent7cac045b27d35630da9ba66f68eb452c948f2b8d (diff)
downloadports-e7d61ea50e17c79515f0cb34a5730398ba0b4d2f.tar.gz
ports-e7d61ea50e17c79515f0cb34a5730398ba0b4d2f.zip
math/scorec-core: update 2.2.7-55 → 2.2.8
Reported by: portscout
Diffstat (limited to 'math/scorec-core')
-rw-r--r--math/scorec-core/Makefile6
-rw-r--r--math/scorec-core/distinfo6
-rw-r--r--math/scorec-core/files/patch-pcu_pcu__mem.c (renamed from math/scorec-core/files/patch-pumi_pumi__sys.cc)8
-rw-r--r--math/scorec-core/pkg-plist6
4 files changed, 14 insertions, 12 deletions
diff --git a/math/scorec-core/Makefile b/math/scorec-core/Makefile
index d248c21bc80e..832a469e0817 100644
--- a/math/scorec-core/Makefile
+++ b/math/scorec-core/Makefile
@@ -1,8 +1,6 @@
PORTNAME= scorec-core
DISTVERSIONPREFIX= v
-DISTVERSION= 2.2.7-55
-PORTREVISION= 2
-DISTVERSIONSUFFIX= -g83113372
+DISTVERSION= 2.2.8
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@@ -49,4 +47,6 @@ OPENMPI_USES= mpi:openmpi
PORTSCOUT= limit:^.*[0-9]\.[0-9].* # prevent tags like remove_viz
+# 3 tests fail, see https://github.com/SCOREC/core/issues/410
+
.include <bsd.port.mk>
diff --git a/math/scorec-core/distinfo b/math/scorec-core/distinfo
index 74d0e25e6a5f..38bc40d2719c 100644
--- a/math/scorec-core/distinfo
+++ b/math/scorec-core/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1670233469
-SHA256 (SCOREC-core-v2.2.7-55-g83113372_GH0.tar.gz) = 0ee9c69b6dc3f0e8c38fca945112e3d81ec66f3a8e47a2474aafd695e55c3e33
-SIZE (SCOREC-core-v2.2.7-55-g83113372_GH0.tar.gz) = 1210395
+TIMESTAMP = 1703443096
+SHA256 (SCOREC-core-v2.2.8_GH0.tar.gz) = 5216d0d5ac031c9357a59986b1bc6f2cbdbac0356059e98a2bec78c1777a59e2
+SIZE (SCOREC-core-v2.2.8_GH0.tar.gz) = 1247064
SHA256 (SCOREC-pumi-meshes-7b84de7_GH0.tar.gz) = 72f552318dac42aeebc6f1a2f4e7f7de4eaee69da7a32026d2b1e4081c28ed71
SIZE (SCOREC-pumi-meshes-7b84de7_GH0.tar.gz) = 33991978
diff --git a/math/scorec-core/files/patch-pumi_pumi__sys.cc b/math/scorec-core/files/patch-pcu_pcu__mem.c
index 2b732b80d0a1..14118647fca5 100644
--- a/math/scorec-core/files/patch-pumi_pumi__sys.cc
+++ b/math/scorec-core/files/patch-pcu_pcu__mem.c
@@ -1,6 +1,8 @@
---- pumi/pumi_sys.cc.orig 2022-12-05 09:50:18 UTC
-+++ pumi/pumi_sys.cc
-@@ -98,6 +98,8 @@ double pumi_getMem()
+- use of linux-specific function mallinfo(): https://github.com/SCOREC/core/issues/409
+
+--- pcu/pcu_mem.c.orig 2023-12-24 18:38:48 UTC
++++ pcu/pcu_mem.c
+@@ -44,6 +44,8 @@ double PCU_GetMem() {
task_info(current_task(), TASK_BASIC_INFO, (task_info_t)&t_info, &t_info_count);
size_t size = (resident ? t_info.resident_size : t_info.virtual_size);
return (double)size/M;
diff --git a/math/scorec-core/pkg-plist b/math/scorec-core/pkg-plist
index db8a32f613bf..c6c01b6f673c 100644
--- a/math/scorec-core/pkg-plist
+++ b/math/scorec-core/pkg-plist
@@ -1,6 +1,5 @@
bin/adaptLvlSetLoop
bin/balance
-bin/box
bin/chef
bin/chefReadUrPrep
bin/chefStream
@@ -18,6 +17,7 @@ bin/from_neper
bin/from_ugrid
bin/icesheet
bin/intrude
+bin/matchedNodeElmReader
bin/measureAnisoStats
bin/measureIsoStats
bin/mkmodel
@@ -133,8 +133,6 @@ lib/cmake/SCOREC/apf_zoltan-target-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/SCOREC/apf_zoltan-target.cmake
lib/cmake/SCOREC/balance-target-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/SCOREC/balance-target.cmake
-lib/cmake/SCOREC/box-target-%%CMAKE_BUILD_TYPE%%.cmake
-lib/cmake/SCOREC/box-target.cmake
lib/cmake/SCOREC/can-target.cmake
lib/cmake/SCOREC/chef-target-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/SCOREC/chef-target.cmake
@@ -179,6 +177,8 @@ lib/cmake/SCOREC/lion-target-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/SCOREC/lion-target.cmake
lib/cmake/SCOREC/ma-target-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/SCOREC/ma-target.cmake
+lib/cmake/SCOREC/matchedNodeElmReader-target-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/SCOREC/matchedNodeElmReader-target.cmake
lib/cmake/SCOREC/mds-target-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/SCOREC/mds-target.cmake
lib/cmake/SCOREC/measureAnisoStats-target-%%CMAKE_BUILD_TYPE%%.cmake