aboutsummaryrefslogtreecommitdiff
path: root/math/simpack
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1998-11-14 09:43:39 +0000
committerSatoshi Asami <asami@FreeBSD.org>1998-11-14 09:43:39 +0000
commit96bc8048c3217bb231f2f30eadeb628134b557f5 (patch)
treec75d5bd5a6faba5d6ec73da367e4bfe5b0d4285d /math/simpack
parent637c4e8f19438274164c0673ec85af739aba205b (diff)
downloadports-96bc8048c3217bb231f2f30eadeb628134b557f5.tar.gz
ports-96bc8048c3217bb231f2f30eadeb628134b557f5.zip
Use bsd.port.{pre,post}.mk to move PORTOBJFORMAT to front, or change
shell loops to make loops. Use EXTRA_PKG_FLAGS to add install scripts instead of adding it to PKG_FLAGS after bsd.port.mk.
Notes
Notes: svn path=/head/; revision=14512
Diffstat (limited to 'math/simpack')
-rw-r--r--math/simpack/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/math/simpack/Makefile b/math/simpack/Makefile
index 9a0b9f30ee78..96f0e882adaa 100644
--- a/math/simpack/Makefile
+++ b/math/simpack/Makefile
@@ -3,7 +3,7 @@
# Date created: 5 June 1997
# Whom: Ruslan Shevchenko <rssh@cki.ipri.kiev.ua>
#
-# $Id: Makefile,v 1.2 1997/07/13 18:49:24 max Exp $
+# $Id: Makefile,v 1.3 1998/09/27 20:13:13 steve Exp $
#
DISTNAME= simpack-3.0
@@ -15,6 +15,14 @@ MAINTAINER= rssh@cki.ipri.kiev.ua
WRKSRC= ${WRKDIR}/simpack
+.include <bsd.port.pre.mk>
+
+.if ${PORTOBJFORMAT} == "elf"
+VERSION= 1
+.else
+VERSION= 1.0
+.endif
+
post-build: create-libs create-scripts
do-install: do-install-bin do-install-include do-install-lib do-install-doc
@@ -131,10 +139,4 @@ create-deq-alias:
@${ECHO} ${PREFIX}/lib/SimPack/constraint/differential/deq $$* \
>> ${WRKDIR}/temp/deq.alias
-.include <bsd.port.mk>
-
-.if ${PORTOBJFORMAT} == "elf"
-VERSION= 1
-.else
-VERSION= 1.0
-.endif
+.include <bsd.port.post.mk>