aboutsummaryrefslogtreecommitdiff
path: root/math/singular/Makefile
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2018-07-10 15:03:53 +0000
committerKurt Jaeger <pi@FreeBSD.org>2018-07-10 15:03:53 +0000
commit6a9a0fbbac9c39163bae11515226db0ad5822862 (patch)
tree07b56ea0bcfb137135958364eaaf05c16bf2274d /math/singular/Makefile
parent05bbeecf0840e72a84baf629b5aec6902112589f (diff)
downloadports-6a9a0fbbac9c39163bae11515226db0ad5822862.tar.gz
ports-6a9a0fbbac9c39163bae11515226db0ad5822862.zip
New port: math/singular
Singular is a computer algebra system for polynomial computations, with special emphasis on commutative and non-commutative algebra, algebraic geometry, and singularity theory. WWW: https://www.singular.uni-kl.de/ Submitted by: yamadam@summitsystem.co.jp
Notes
Notes: svn path=/head/; revision=474374
Diffstat (limited to 'math/singular/Makefile')
-rw-r--r--math/singular/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/math/singular/Makefile b/math/singular/Makefile
new file mode 100644
index 000000000000..d23f43af35ca
--- /dev/null
+++ b/math/singular/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= singular
+PORTVERSION= 4.1.1
+CATEGORIES= math
+MASTER_SITES= http://www.mathematik.uni-kl.de/ftp/pub/Math/Singular/SOURCES/4-1-1/
+
+MAINTAINER= oam_yamada@cc.nara-wu.ac.jp
+COMMENT= Computer algebra system for polynomial computations
+
+LICENSE= GPLv3RLE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libgmp.so:math/gmp \
+ libmpfr.so:math/mpfr
+
+USES= gmake libtool perl5 pkgconfig shebangfix
+USE_PERL5= build
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-gmp=${LOCALBASE}
+MAKE_JOBS_UNSAFE= yes
+SHEBANG_FILES= libpolys/libpolys-config.in \
+ libsingular-config.in
+
+.include <bsd.port.mk>