aboutsummaryrefslogtreecommitdiff
path: root/math/snns/Makefile
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2013-02-04 08:52:19 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2013-02-04 08:52:19 +0000
commitb2b8aabaa89ecd00044d0270aa39ab2feab5fe44 (patch)
treecc7ccd42e107b1ebd6afbdf7986a533c0c812ef0 /math/snns/Makefile
parent82b809ad1a2731fc89be7990f204d1c7c6d83042 (diff)
downloadports-b2b8aabaa89ecd00044d0270aa39ab2feab5fe44.tar.gz
ports-b2b8aabaa89ecd00044d0270aa39ab2feab5fe44.zip
- Fix build using CLANG.
- Add MAKE_JOBS_UNSAFE. PR: ports/175015 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=311585
Diffstat (limited to 'math/snns/Makefile')
-rw-r--r--math/snns/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/math/snns/Makefile b/math/snns/Makefile
index 3bd02f5f66bc..05b5a999b515 100644
--- a/math/snns/Makefile
+++ b/math/snns/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: snns
-# Date created: 2 Febuary 1997
-# Whom: reg@shale.csir.co.za
-#
+# Created by: reg@shale.csir.co.za
# $FreeBSD$
-#
PORTNAME= snns
PORTVERSION= 4.3
@@ -21,6 +17,9 @@ USE_XORG= x11 xext xt
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}/lib/snns --enable-global \
--build=${CONFIGURE_TARGET}
+MAKE_JOBS_UNSAFE= yes
+
+.include <bsd.port.options.mk>
post-extract:
.for file in config.guess config.sub
@@ -48,7 +47,7 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/Readme.license ${PREFIX}/lib/snns
${INSTALL_DATA} ${WRKSRC}/default.cfg ${PREFIX}/lib/snns
${INSTALL_DATA} ${WRKSRC}/help.hdoc ${PREFIX}/lib/snns
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
.endif