aboutsummaryrefslogtreecommitdiff
path: root/math/suitesparse-csparse
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2021-05-24 16:41:20 +0000
committerThierry Thomas <thierry@FreeBSD.org>2021-05-25 10:00:05 +0000
commitace392aa213637d97e5b347bff9b564cd4226cd1 (patch)
treea1c7058b85f087083d049e010668a7736c970b2f /math/suitesparse-csparse
parent1fa733cfc5105fe608d60164fc6590cbb3b4804c (diff)
downloadports-ace392aa213637d97e5b347bff9b564cd4226cd1.tar.gz
ports-ace392aa213637d97e5b347bff9b564cd4226cd1.zip
suitesparse-csparse: new port for the module CSparse of SuiteSparse
Diffstat (limited to 'math/suitesparse-csparse')
-rw-r--r--math/suitesparse-csparse/Makefile26
-rw-r--r--math/suitesparse-csparse/files/patch-CSparse_Makefile11
-rw-r--r--math/suitesparse-csparse/pkg-descr9
3 files changed, 46 insertions, 0 deletions
diff --git a/math/suitesparse-csparse/Makefile b/math/suitesparse-csparse/Makefile
new file mode 100644
index 000000000000..a42b1365bf37
--- /dev/null
+++ b/math/suitesparse-csparse/Makefile
@@ -0,0 +1,26 @@
+# Created by: Thierry Thomas (<thierry@pompo.net>)
+
+PORTNAME= CSparse
+PORTVERSION= 3.2.0
+CATEGORIES= math
+
+COMMENT= Concise Sparse Matrix package
+
+LICENSE= LGPL21+
+
+USES= localbase:ldflags
+
+BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
+USE_LDCONFIG= yes
+PLIST_FILES= # empty
+
+# For system-wide installation, the author recommends that you install
+# CXSparse instead.
+# The CSparse library is meant for personal experimentation. The 'make
+# install' in this Makefile only installs a static compiled library in
+# CSparse/Lib. It does not install it for system-wide usage.
+do-install:
+ ${DO_NADA}
+
+.include "${.CURDIR}/../../math/suitesparse/bsd.suitesparse.mk"
+.include <bsd.port.post.mk>
diff --git a/math/suitesparse-csparse/files/patch-CSparse_Makefile b/math/suitesparse-csparse/files/patch-CSparse_Makefile
new file mode 100644
index 000000000000..fda5d10c9e9b
--- /dev/null
+++ b/math/suitesparse-csparse/files/patch-CSparse_Makefile
@@ -0,0 +1,11 @@
+--- CSparse/Makefile.orig 2021-05-17 01:04:52 UTC
++++ CSparse/Makefile
+@@ -6,7 +6,7 @@ C:
+ ( cd Lib ; $(MAKE) )
+ ( cd Demo ; $(MAKE) )
+
+-all: C cov
++all: C
+
+ library:
+ ( cd Lib ; $(MAKE) )
diff --git a/math/suitesparse-csparse/pkg-descr b/math/suitesparse-csparse/pkg-descr
new file mode 100644
index 000000000000..6800b88c4872
--- /dev/null
+++ b/math/suitesparse-csparse/pkg-descr
@@ -0,0 +1,9 @@
+This port builds the module CSparse of SuiteSparse.
+
+CSparse is a Concise Sparse Matrix package. This code goes with the book "Direct
+Methods for Sparse Linear Systems," Timothy A. Davis, SIAM, Philadelphia, 2006.
+
+Note: the CSparse library is meant for personal experimentation. For system-wide
+installation, please install math/suitesparse-cxsparse instead.
+
+WWW: http://faculty.cse.tamu.edu/davis/suitesparse.html