aboutsummaryrefslogtreecommitdiff
path: root/math/superlu_mt
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2007-01-12 08:18:07 +0000
committerMaho Nakata <maho@FreeBSD.org>2007-01-12 08:18:07 +0000
commit3e595ee070d22aefd0313cf8970ffd97132ef1dd (patch)
tree3e5fb20288961f930383294b8b004a30caaa2abc /math/superlu_mt
parent966dff750bb6105599f83dbe6ca23453c1ac471e (diff)
downloadports-3e595ee070d22aefd0313cf8970ffd97132ef1dd.tar.gz
ports-3e595ee070d22aefd0313cf8970ffd97132ef1dd.zip
* Use gfortran42 only and not gcc42.
* Bump portrevision.
Notes
Notes: svn path=/head/; revision=182162
Diffstat (limited to 'math/superlu_mt')
-rw-r--r--math/superlu_mt/Makefile23
1 files changed, 14 insertions, 9 deletions
diff --git a/math/superlu_mt/Makefile b/math/superlu_mt/Makefile
index b04982024931..6b22e4d5f423 100644
--- a/math/superlu_mt/Makefile
+++ b/math/superlu_mt/Makefile
@@ -7,6 +7,7 @@
PORTNAME= superlu_mt
DISTVERSION= 1.0.20050524
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= http://crd.lbl.gov/~xiaoye/SuperLU/ \
http://crd.lbl.gov/~xiaoye/:doc
@@ -20,21 +21,25 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Routines for performing multithreaded sparse factorization
-.ifdef WITH_ATLAS
-LIB_DEPENDS= atlas:${PORTSDIR}/math/atlas
+WANT_FORTRAN= yes #dummy but future use
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+FC= gfortran42
+F77= gfortran42
+
+.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
+WITH_ATLAS= yes
+.endif
+.if defined(WITH_ATLAS)
+LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
+BLAS_LIBS= -lf77blas -latlas
.else
-LIB_DEPENDS= blas.1:${PORTSDIR}/math/blas
+LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
+BLAS_LIBS= -lblas
.endif
WRKSRC= ${WRKDIR}/SuperLU_MT
ALL_TARGET= superlulib
-.ifdef WITH_ATLAS
-BLAS_LIBS= -lf77blas -latlas
-.else
-BLAS_LIBS?= -lblas
-.endif
-
ARCH2FIX= CBLAS/Makefile make.alpha make.exemplar TESTING/MATGEN/Makefile \
make.origin make.inc make.pthreads SRC/Makefile