aboutsummaryrefslogtreecommitdiff
path: root/math/surf
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-04-23 16:52:21 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-04-23 16:52:21 +0000
commitb890fdf7d2a5d10c70abddc6f5649caab13dea84 (patch)
treefc2400c8cb1e74599a30d013b4c8a5a6308d1bae /math/surf
parentf18129b9cf24cc38e942e5ea264271988f7ea775 (diff)
downloadports-b890fdf7d2a5d10c70abddc6f5649caab13dea84.tar.gz
ports-b890fdf7d2a5d10c70abddc6f5649caab13dea84.zip
add surf
Visualize some real algebraic geometry
Notes
Notes: svn path=/head/; revision=41833
Diffstat (limited to 'math/surf')
-rw-r--r--math/surf/Makefile28
-rw-r--r--math/surf/distinfo1
-rw-r--r--math/surf/pkg-comment1
-rw-r--r--math/surf/pkg-descr14
-rw-r--r--math/surf/pkg-plist3
5 files changed, 47 insertions, 0 deletions
diff --git a/math/surf/Makefile b/math/surf/Makefile
new file mode 100644
index 000000000000..a6bc4b8757c1
--- /dev/null
+++ b/math/surf/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# New ports collection makefile for: surf
+# Date created: Apr 23, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= surf
+PORTVERSION= 1.0.3
+CATEGORIES= math
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ijliao@FreeBSD.org
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ tiff.4:${PORTSDIR}/graphics/tiff
+
+USE_GTK= yes
+USE_NEWGCC= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN1= surf.1
+
+.include <bsd.port.mk>
diff --git a/math/surf/distinfo b/math/surf/distinfo
new file mode 100644
index 000000000000..d7b46d0099fd
--- /dev/null
+++ b/math/surf/distinfo
@@ -0,0 +1 @@
+MD5 (surf-1.0.3.tar.gz) = 4d0cea15d9e771e60920dbb25979d1f3
diff --git a/math/surf/pkg-comment b/math/surf/pkg-comment
new file mode 100644
index 000000000000..9e6e7602554e
--- /dev/null
+++ b/math/surf/pkg-comment
@@ -0,0 +1 @@
+Visualize some real algebraic geometry
diff --git a/math/surf/pkg-descr b/math/surf/pkg-descr
new file mode 100644
index 000000000000..67800fad02fb
--- /dev/null
+++ b/math/surf/pkg-descr
@@ -0,0 +1,14 @@
+surf is a tool to visualize some real algebraic geometry: plane algebraic
+curves, algebraic surfaces and hyperplane sections of surfaces. surf is
+script driven and has (optionally) a nifty GUI using the Gtk widget set.
+
+The algorithms should be stable enough not to be confused by curve/surface
+singularities in codimension greater than one and the degree of the surface
+or curve. This has been achieved quite a bit. We have drawn curves of degree
+up to 30 and surfaces of degree up to 20 successfully. However, there are
+examples of curves/surfaces of lower degree where surf fails to produce
+perfect images. This happens especially if the equation of the curve/surface
+is not reduced. Best results are achieved using reduced equations. On the
+other hand, surf displays the Fermat-curves accurately for degree up to 98.
+
+WWW: http://surf.sourceforge.net/
diff --git a/math/surf/pkg-plist b/math/surf/pkg-plist
new file mode 100644
index 000000000000..e9dd51e2b0d3
--- /dev/null
+++ b/math/surf/pkg-plist
@@ -0,0 +1,3 @@
+bin/surf
+share/surf/surf.xpm
+@dirrm share/surf