aboutsummaryrefslogtreecommitdiff
path: root/math/testu01/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-19 10:19:39 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-19 10:19:39 +0000
commit8f2ac7c2c7ef14d7b2d642ad4b307c144b83e2dc (patch)
treec6fc00622e9fd4d5c2db5b6fe4cbb797779f60c1 /math/testu01/Makefile
parentf5afd0c9e22331edfb92ad707ca3fd47cb32db94 (diff)
downloadports-8f2ac7c2c7ef14d7b2d642ad4b307c144b83e2dc.tar.gz
ports-8f2ac7c2c7ef14d7b2d642ad4b307c144b83e2dc.zip
1: Stagify.
2: USES=libtool, bump version. Approved by: portmgr@
Notes
Notes: svn path=/head/; revision=358377
Diffstat (limited to 'math/testu01/Makefile')
-rw-r--r--math/testu01/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/math/testu01/Makefile b/math/testu01/Makefile
index 14f22abfd0cd..b6bfae6aeba0 100644
--- a/math/testu01/Makefile
+++ b/math/testu01/Makefile
@@ -3,7 +3,7 @@
PORTNAME= TestU01
PORTVERSION= 1.2.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= http://www.iro.umontreal.ca/~simardr/testu01/:0 \
http://www.iro.umontreal.ca/~lecuyer/myftp/papers/:1
@@ -13,9 +13,9 @@ EXTRACT_ONLY= ${PORTNAME}${EXTRACT_SUFX}
MAINTAINER= bf@FreeBSD.org
COMMENT= Utilities for statistical testing of uniform random number generators
-LIB_DEPENDS= gmp:${PORTSDIR}/math/gmp
+LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
-USES= gmake zip
+USES= gmake zip libtool
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --includedir="${PREFIX}/include/${PORTNAME}"
MAKE_ARGS= docdir="${DOCSDIR}" exdir="${EXAMPLESDIR}"
@@ -26,7 +26,6 @@ CFLAGS+= -fPIC
PLIST_SUB= PORTNAME="${PORTNAME}"
CONFLICTS= emboss-[0-9]*
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|return|& (0)|' ${WRKSRC}/testu01/fftc.c
@@ -41,7 +40,8 @@ post-patch:
.ifndef(NOPORTDOCS)
post-install:
- @${INSTALL_DATA} ${DISTDIR}/testu01.pdf ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${INSTALL_DATA} ${DISTDIR}/testu01.pdf ${STAGEDIR}${DOCSDIR}
.endif
check regression-test test: build