aboutsummaryrefslogtreecommitdiff
path: root/math/ump
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-02-06 18:25:04 +0000
committerJohn Marino <marino@FreeBSD.org>2015-02-06 18:25:04 +0000
commitd5bfd7b9e826b9af38534edc3c2baf530c408d08 (patch)
tree4bcd82284e99583285de0dda0445f18058ad9cb1 /math/ump
parentdb0c2c97416ee89ef8c59d05b41c931e3e5f24cb (diff)
math/ump: Finish original "fix on current"
Back on 10 OCT 2014 when the PR was opened, this unmaintained port didn't build on current. The PR stagnanted due to an unanswered question and the port was eventually fixed by amdmi3 on 21 NOV. Let's go ahead and make the remaining changes which include adding a license (GPLv2), defining desktop entries, tweaking pkg-descr, and make real_frac function match its changed header (for clang). PR: 194497 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=378549
Diffstat (limited to 'math/ump')
-rw-r--r--math/ump/Makefile12
-rw-r--r--math/ump/files/patch-Makefile2
-rw-r--r--math/ump/files/patch-src__real.cpp11
-rw-r--r--math/ump/pkg-descr5
4 files changed, 20 insertions, 10 deletions
diff --git a/math/ump/Makefile b/math/ump/Makefile
index 72eb42b36d1d..5a90be79020c 100644
--- a/math/ump/Makefile
+++ b/math/ump/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ump
PORTVERSION= 0.8.6
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= math
MASTER_SITES= SF/u-m-p/u-m-p/${PORTVERSION}
PKGNAMESUFFIX= -math
@@ -11,7 +11,7 @@ PKGNAMESUFFIX= -math
MAINTAINER= ports@FreeBSD.org
COMMENT= Graphical, easy to use math program
-CONFLICTS= ump-1.[0-9]*
+LICENSE= GPLv2
USES= gmake pkgconfig tar:bzip2
USE_GNOME= gtk20
@@ -20,15 +20,15 @@ USE_GL= glu
ALL_TARGET= ${PORTNAME}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-MAKE_ENV+= DATADIR="${DATADIR}"
+CONFLICTS= ump-1.[0-9]*
-FIND_DIRS= -type d
-FIND_DATA= -type f
+DESKTOP_ENTRIES="Ump" "" "" "ump" "Education;Math;Science;GTK;" ""
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/src/main.cpp
post-install:
- ${INSTALL_DATA} ${WRKSRC}/ump.conf ${STAGEDIR}${PREFIX}/etc/ump.conf.sample
+ ${INSTALL_DATA} ${WRKSRC}/ump.conf \
+ ${STAGEDIR}${PREFIX}/etc/ump.conf.sample
.include <bsd.port.mk>
diff --git a/math/ump/files/patch-Makefile b/math/ump/files/patch-Makefile
index 7347810ec3a4..7d1c1acf0762 100644
--- a/math/ump/files/patch-Makefile
+++ b/math/ump/files/patch-Makefile
@@ -7,7 +7,7 @@
-BIN_DIR = /usr/bin
-DATA_DIR = /usr/share/$(APP_NAME)
+BIN_DIR = $(PREFIX)/bin
-+DATA_DIR = $(DATADIR)
++DATA_DIR = $(PREFIX)/share/$(APP_NAME)
## One of these three flags must be uncommented
diff --git a/math/ump/files/patch-src__real.cpp b/math/ump/files/patch-src__real.cpp
new file mode 100644
index 000000000000..48bdd276a8ef
--- /dev/null
+++ b/math/ump/files/patch-src__real.cpp
@@ -0,0 +1,11 @@
+--- src/real.cpp.orig
++++ src/real.cpp
+@@ -764,7 +764,7 @@
+ }
+
+ // converts a Real to a fraction
+-Real frac(const Real &val, int32 highest_bottom_value) throw(error_obj)
++Real frac(const Real &val, int32 highest_bottom_value = 1000) throw(error_obj)
+ {
+ if( highest_bottom_value < 1 )
+ THROW_ERROR( ErrorType_Domain, _("Domain error: Value out of range.") );
diff --git a/math/ump/pkg-descr b/math/ump/pkg-descr
index c2a5314b66dd..4227427f214c 100644
--- a/math/ump/pkg-descr
+++ b/math/ump/pkg-descr
@@ -1,5 +1,4 @@
-ump is a graphical, easy to use math program, which works with complex numbers,
-matrices, functions and much more.
+ump is a graphical, easy to use math program, which works with complex
+numbers, matrices, functions and much more.
-Author: Mattias Hultgren
WWW: http://u-m-p.sourceforge.net/