aboutsummaryrefslogtreecommitdiff
path: root/math/vtk9
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-10-20 05:15:59 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-10-20 05:17:58 +0000
commit24eb2fbf5e80b7ba9ea3be8cabfcf7dd54b08935 (patch)
treee9a858b89460d883ddc74c9a129a084ddb5b047d /math/vtk9
parentf3bad4cab17c8d9eb179319f8893b4c4de7e6259 (diff)
downloadports-24eb2fbf5e80b7ba9ea3be8cabfcf7dd54b08935.tar.gz
ports-24eb2fbf5e80b7ba9ea3be8cabfcf7dd54b08935.zip
math/vtk9: Limit net/py-mpi4py dependency when both PYTHON and MPI options are on
PR: 267191 Reported by: VVD <vvd@unislabs.com>
Diffstat (limited to 'math/vtk9')
-rw-r--r--math/vtk9/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/math/vtk9/Makefile b/math/vtk9/Makefile
index 116521129e1b..2ec7af56d10f 100644
--- a/math/vtk9/Makefile
+++ b/math/vtk9/Makefile
@@ -1,6 +1,6 @@
PORTNAME= vtk
DISTVERSION= 9.1.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= math graphics
MASTER_SITES= https://vtk.org/files/release/${VTK_SHORT_VER}/
PKGNAMESUFFIX= 9
@@ -19,8 +19,6 @@ LIB_DEPENDS= \
libnetcdf.so:science/netcdf \
libpng.so:graphics/png \
libtiff.so:graphics/tiff
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mpi4py>0:net/py-mpi4py@${PY_FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mpi4py>0:net/py-mpi4py@${PY_FLAVOR}
USES= alias cmake compiler:c++11-lang gl jpeg localbase xorg
USE_LDCONFIG= ${PREFIX}/lib/vtk-${VTK_SHORT_VER}
@@ -112,6 +110,11 @@ USES+= gl
USE_GL= gl glu
.endif
+.if ${PORT_OPTIONS:MPYTHON} && ${PORT_OPTIONS:MMPI}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mpi4py>0:net/py-mpi4py@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mpi4py>0:net/py-mpi4py@${PY_FLAVOR}
+.endif
+
CONFLICTS= vtk6 vtk8
do-install-PYTHON-on: